Issues with album art having a purple tint

Madsonic Mashup Mod is a fork of the Subsonic 4.7 Server Build 3090 with some Subsonic Data schema modifications!

Moderator: moderators

Issues with album art having a purple tint

Postby Chorca » Wed Jan 23, 2013 2:59 pm

Since I've installed the latest version of Madsonic, I've had an issue with album art.
For some reason, in certain places, the artwork has a purple tint to it, where other places it does not. I'm not sure why this is, the art itself seems to be good, but the color is off only in certain places.

It seems to be fine in the list of album art in the folder view, but when browsing the folder itself, the larger album art is tinted. On the Android app, it shows normally in the list of folders, but on the larger album art, it shows incorrectly.

This only happens on certain album art, not all of it, but it happens fairly often.

I've included screenshots to illustrate this.
Chorca
 
Posts: 5
Joined: Mon Nov 08, 2010 5:05 pm

Re: Issues with album art having a purple tint

Postby daneren2005 » Wed Jan 23, 2013 3:14 pm

Now thats a weird one. Maybe it has to do with the scaling on the images before they are sent via the API? The only difference that I can think of between how the images are handled in the two different places is for the smaller ones they are requested smaller and the bigger ones are just requested full size.
Developer of DSub for Android
daneren2005
 
Posts: 1701
Joined: Fri Jul 06, 2012 7:52 pm

Re: Issues with album art having a purple tint

Postby gurutech » Thu Jan 24, 2013 1:53 am

Try a different theme, maybe it's just an issue with the one theme you are using.
Image
gurutech
 
Posts: 492
Joined: Sun Jan 15, 2012 9:56 pm

Re: Issues with album art having a purple tint

Postby Chorca » Thu Jan 24, 2013 8:39 pm

gurutech wrote:Try a different theme, maybe it's just an issue with the one theme you are using.


I don't think it's the theme, since it's also doing the same thing on the android app..
Chorca
 
Posts: 5
Joined: Mon Nov 08, 2010 5:05 pm

Re: Issues with album art having a purple tint

Postby Beechwoods » Wed Sep 16, 2015 9:38 pm

I also have this problem. Upgraded to 5.3 beta 2 but no change. I'm running OSX Mavericks, and the issue only started today. Not all artwork is affected, but it affects both old artwork that has been OK before, as well as some newer stuff. Some artwork has a purple tint, some a greenish tint. It affects both artwork in the webview and on the iSub iOS app.

Did anyone come up with a fix for this? I read somewhere that deleting and rebuilding the database worked for someone, but I don't want to do that unless I can keep my transcode and player settings somehow (I've tweaked these a lot).

Many thanks.
Beechwoods
 
Posts: 3
Joined: Sun Jul 14, 2013 7:47 am

Re: Issues with album art having a purple tint

Postby FrankFromHR » Tue May 03, 2016 8:00 pm

I'm having this same issue and I just upgrade from 6.0beta2 with no madsonic.. I can redownload the artwork and that seems to resolve the issue... Anyone manage to get any automated fix for this?
FrankFromHR
 
Posts: 1
Joined: Tue May 03, 2016 7:58 pm


Return to Madsonic

Who is online

Users browsing this forum: No registered users and 1 guest