Page 1 of 1

(SOLVED) Chromecast Audio problem

PostPosted: Mon Apr 10, 2017 1:39 am
by troycarpenter
Starting a few weeks ago, I noticed that DSub no longer wants to cast audio to my Chromecast Audio devices (I have not tried with the Cromecast Video device since it is not currently connected to the network). I can see all the devices in the Chromecast device selector, and when I connect to either a specific Chromecast or a group, I hear the appropriate connection sound from the device(s). DSub will display a message that simply says "Failed to Load" and nothing. Both DSub and Google Home report that the devices are being cast to, but DSub is not playing the file (play is not progressing). I can cast from other programs, but any device that tries to cast with DSub gets the same error. The Madsonic APP doesn't support Chromecast as far as I can tell, so I can't compare other apps using Madsonic as the server.

I sent an email with the error logs after one of the failures.

Re: Chromecast Audio problem

PostPosted: Thu Apr 13, 2017 4:23 pm
by troycarpenter
In a private email with daneren2005 offline about this. The certificate on my Madsonic server had expired in January and was issued by StartCOM. Given that this was working until the past few weeks, I'm guessing that there was an upgrade to the Chromecast Audio devices that finally made them reject the server's certificate as untrusted (not simply expired), and therefore didn't stream the music. With a new certificate installed on the server from Let's Encrypt, Chromecast streaming started working again.