New music scan doesn't work

Need help? Post your questions here.

Moderator: moderators

New music scan doesn't work

Postby IvanV » Tue Jan 10, 2017 9:10 am

Hi,

When I add new files Subsonic doesn't automatically adds them to the DB. "Fast access mode" is off.

1. What's the mechanism of this feature? Is it last modification time or smth else?
2. Any ideas how to fix it?

Thanks!
IvanV
 
Posts: 2
Joined: Mon Jan 09, 2017 10:05 am

Re: New music scan doesn't work

Postby IvanV » Tue Feb 07, 2017 3:56 pm

Subsonic gets my money alright, but I don't see any support options. How can get Subsonic's help?
IvanV
 
Posts: 2
Joined: Mon Jan 09, 2017 10:05 am

Re: New music scan doesn't work

Postby toolman » Tue Feb 07, 2017 10:08 pm

You can get help by submitting your problem in the help-section.
If you first read http://forum.subsonic.org/forum/viewtopic.php?f=2&t=5506 you will know what to do.
Also you can search this forum, most likely the solution to your problem can be found here.
toolman
 
Posts: 315
Joined: Fri Dec 11, 2009 4:18 pm
Location: Netherlands

Re: New music scan doesn't work

Postby switz » Sun Mar 19, 2017 7:27 pm

+1 it works for the initial scan but never finds new media after that no matter how many times I scan.

edit: 6.0 (build a7857c) – April 30, 2016
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm

Re: New music scan doesn't work

Postby toolman » Sun Mar 19, 2017 10:09 pm

And since we're all clearvoyant we know what Os you're using to run Subsonic and if you have your mediafolders local or on a networkdrive, what you're logfiles look like, if you have set permissions right etc etc.
toolman
 
Posts: 315
Joined: Fri Dec 11, 2009 4:18 pm
Location: Netherlands

Re: New music scan doesn't work

Postby switz » Mon Mar 20, 2017 4:45 am

Running the Mac binary on OS X Yosemite 10.10.5.

Files are on an external drive attached by USB.

Logs are clean - it scans the files normally with no errors:

Code: Select all
[3/20/17 12:41:57 AM EDT]   INFO   MediaScannerService   Scanned media library with 5000 entries.
[3/20/17 12:41:57 AM EDT]   INFO   MediaScannerService   Scanned media library with 5250 entries.
[3/20/17 12:41:57 AM EDT]   INFO   MediaScannerService   Scanned media library with 5451 entries.
[3/20/17 12:41:57 AM EDT]   INFO   MediaScannerService   Marking non-present files.
[3/20/17 12:42:02 AM EDT]   INFO   MediaScannerService   Marking non-present artists.
[3/20/17 12:42:02 AM EDT]   INFO   MediaScannerService   Marking non-present albums.
[3/20/17 12:42:03 AM EDT]   INFO   MediaScannerService   Completed media library scan.
[3/20/17 12:42:03 AM EDT]   INFO   PlaylistService   Starting playlist import.
[3/20/17 12:42:03 AM EDT]   INFO   PlaylistService   Completed playlist import.


It definitely can read from the drive just fine.

If I take a music folder, let's say name "Music" with the path "/Volumes/Music/Folder" and I add files, hit scan, it scans, but no new folders or files appear on Subsonic.

If I then change the folder path to "/Volumes/Music/Folder2" (a fake path that doesn't exist), hit scan and wait for it to finish, hit "Clean-up database", then change the folder back to the real one and scan again, it works. But it's time consuming and I lose play data.

But just scanning or adding new folders does nothing, no matter how many times I run it.
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm

Re: New music scan doesn't work

Postby switz » Mon Mar 20, 2017 9:16 pm

I tried running the standalone version (not the Mac binary) on the same machine and the new installation still experienced the same problem.
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm

Re: New music scan doesn't work

Postby tmwsiy » Tue Mar 21, 2017 5:09 am

switz wrote:I tried running the standalone version (not the Mac binary) on the same machine and the new installation still experienced the same problem.


There was a time when forum posts would be answered, Sindre would offer help, and basic functionality wouldn't be bricked like a brownstone in Boston....sadly, those days are long since gone.
tmwsiy
 
Posts: 171
Joined: Tue Apr 06, 2010 6:26 pm

Re: New music scan doesn't work

Postby switz » Tue Mar 21, 2017 5:05 pm

To add, this seems to only happen on my external drive. My external drive is formatted exFAT. Clearly subsonic can read from it just fine and so can my Mac, but could this cause any problems?
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm

Re: New music scan doesn't work

Postby toolman » Wed Mar 22, 2017 7:07 am

Since subsonic relies on the OS it's running on to access and read folders and files. It's more likely that this is an issue with your external drive on USB.
Don't know about Mac, but in Windows if you connect an external drive it is identified with a drive letter.
However if you disconnect the USB-drive and reconnect it to another USB port on your pc it may get another drive letter.
Perhaps something similar is happening with your Mac and the USB drive. I know Mac doesn't work with driveletters but I guess it must have some way of identifying external drives and perhaps it generates a new ID each time you connect the drive.
And as a result Subsonic isn't able to show you new indexed files.
Don't know if this is acctually so, but I'm just trying to help you find a solution to your problem.
toolman
 
Posts: 315
Joined: Fri Dec 11, 2009 4:18 pm
Location: Netherlands

Re: New music scan doesn't work

Postby switz » Sat Mar 25, 2017 3:09 am

It's a static path (/Volumes/Music). I'm going to try formatting a new drive to HFS+ and if that works I'll reformat.
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm

Re: New music scan doesn't work

Postby switz » Sat Mar 25, 2017 7:18 pm

Update: HSF+ seems to work as expected. It's not ideal, but also not the end of the world. Thanks
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm

Re: New music scan doesn't work

Postby tmwsiy » Sun Mar 26, 2017 6:54 pm

switz wrote:Update: HSF+ seems to work as expected. It's not ideal, but also not the end of the world. Thanks


So odd.....so you are saying when you had your drives formatted ExFAT that they would make an initial scan and then not pick up new music?
That's good to know for future.
tmwsiy
 
Posts: 171
Joined: Tue Apr 06, 2010 6:26 pm

Re: New music scan doesn't work

Postby switz » Wed Mar 29, 2017 4:44 pm

tmwsiy wrote:
switz wrote:Update: HSF+ seems to work as expected. It's not ideal, but also not the end of the world. Thanks


So odd.....so you are saying when you had your drives formatted ExFAT that they would make an initial scan and then not pick up new music?
That's good to know for future.
Yes. It's likely just a Mac compatibility issue though perhaps the same would happen on Windows as well. I'd imagine Linux would handle it just fine, but I didn't test it. Thankfully, I had a second drive laying around 8)

If I had more time, I would have just installed Linux and ran it permanently, but I was too lazy.
switz
 
Posts: 9
Joined: Mon Mar 18, 2013 8:22 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 2 guests