New CentOS installation cannot see indexed music

Need help? Post your questions here.

Moderator: moderators

New CentOS installation cannot see indexed music

Postby yvonne » Wed Jul 12, 2017 5:00 pm

<-------------------------Subsonic Help Request---------------------->
Problem Description: New CentOS installation cannot see indexed music

Troubleshooting Steps:
I'm logged into Subsonic Web Interface as admin from a PC in a Chrome browser using URL www.wolfpackinteractive.com:4040
I set one media folder named "Music" pointed to "/home/wolfpack/var/music"
Subsonic recognizes the folder (there's no red message saying folder doesn't exist)
I'm starting small and have only uploaded two album folders with a total of 7 tracks in MP3 format
All folders have 755 set for permissions
All tracks initially had 644 set for permissions
After changing the tracks to 755 permissions no change
When I click the link in Subsonic to scan media folders now it gives a message that setting are saves and notifies me that this may take some time.
The Subsonic About screen shows
Media collection
2 artists
2 albums
7 songs
31.8 MB
0 hours
No other error or message is received.
When I go to the Index page in the Web Interface, nothing shows up.

Playback Application and version:
Subsonic Version:
Server Version:
Version 6.1.1 (build fc853b) – May 31, 2017
Server jetty-6.1.x, java 1.8.0_121, HSQLDB, Linux (58.7 MB / 67.0 MB)

Hardware Platform: CentOS 6 64-bit
Installed in folder /var/subsonic/

Installation note from managed server tech support:
Hello, Yvonne.
I've installed Subsonic per the instructions on their site and have it running as the wolfpack user. This is the logon page:
http://wolfpackinteractive.com:4040/
It looks like that should get you started with the server setup options.
Scott Malcolm
Support Technician
Liquid Web Inc
https://www.liquidweb.com

Last ten log file lines:
[7/12/17 3:00:00 AM EDT] INFO MediaScannerService Starting to scan media library.
[7/12/17 3:00:00 AM EDT] INFO MediaScannerService Scanned media library with 12 entries.
[7/12/17 3:00:00 AM EDT] INFO MediaScannerService Marking non-present files.
[7/12/17 3:00:00 AM EDT] INFO MediaScannerService Marking non-present artists.
[7/12/17 3:00:00 AM EDT] INFO MediaScannerService Marking non-present albums.
[7/12/17 3:00:00 AM EDT] INFO MediaScannerService Completed media library scan.
[7/12/17 3:00:00 AM EDT] INFO PlaylistService Starting playlist import.
[7/12/17 3:00:00 AM EDT] INFO PlaylistService Completed playlist import.
[7/12/17 3:14:54 AM EDT] INFO PodcastService Starting scheduled Podcast refresh.
[7/12/17 3:14:54 AM EDT] INFO PodcastService Completed scheduled Podcast refresh.

Any assistance is much appreciated. I am eager to get this all working and I feel that we are nearly there. My server is under a managed plan so if there is something technical that is needed I can ask the experts who installed the software to assist once I have information from this forum.

Thank you in advance.
Yvonne
<-------------------------Subsonic Help Request---------------------->
yvonne
 
Posts: 2
Joined: Wed Jul 12, 2017 4:06 pm

Re: New CentOS installation cannot see indexed music

Postby jrh.koenig » Thu Jul 13, 2017 6:07 am

Hi Yvonne,

try setenforce 0 as user root to disable SELinux to test if your installation finds your music. If it works you have to decide to use SELinux or not. To disable SELinux you have to edit /etc/selinux/config. If you still want to use SELinux for security reasons, then you have to set the right SELinux label for your songs. For Tomcat you need tomcat_var_lib_t:s0.
So try chcon -R -t unconfined_u:object_r:tomcat_var_lib_t:s0 /home/wolfpack/var/music

Kind Regards

Johannes
jrh.koenig
 
Posts: 18
Joined: Sat Feb 27, 2010 3:51 pm
Location: Frankfurt, Germany

Re: New CentOS installation cannot see indexed music

Postby yvonne » Mon Jul 17, 2017 4:52 am

Thank you for the quick response.

I have taken a look at the SELinux enforcement policy and it looks like it's outright disabled, which is normal for cPanel servers.

[root@host ~]# getenforce
Disabled

I did some more investigation and testing. I thought if I had the music in a different folder location it might solve the problem.
Currently I have two folders configured within Subsonic. Here are the symptoms:

1) the music in /home/wolfpack/var/music shows up in the player as expected
2) the music in /var/subsonic/music does not show up in the player
3) album thumbnails do not show up properly (error messages show up in the log)
4) the Subsonic log shows all the music files in both locations were indexed (no errors), but as described above only some display in the player

[7/16/17 3:00:00 AM EDT] INFO MediaScannerService Starting to scan media library.
[7/16/17 3:00:00 AM EDT] INFO MediaScannerService Scanned media library with 16 entries.
[7/16/17 3:00:00 AM EDT] INFO MediaScannerService Marking non-present files.
[7/16/17 3:00:00 AM EDT] INFO MediaScannerService Marking non-present artists.
[7/16/17 3:00:00 AM EDT] INFO MediaScannerService Marking non-present albums.
[7/16/17 3:00:00 AM EDT] INFO MediaScannerService Completed media library scan.
[7/16/17 3:00:00 AM EDT] INFO PlaylistService Starting playlist import.
[7/16/17 3:00:00 AM EDT] INFO PlaylistService Completed playlist import.
[7/16/17 3:14:54 AM EDT] INFO PodcastService Starting scheduled Podcast refresh.
[7/16/17 3:14:54 AM EDT] INFO PodcastService Completed scheduled Podcast refresh.
[7/17/17 12:46:58 AM EDT] WARN CoverArtController Failed to create thumbnail for Media file 35 - Deadwood Music From the HBO Original Series
[7/17/17 12:46:58 AM EDT] WARN CoverArtController Failed to process cover art /home/wolfpack/var/music/Clint Black/Greatest Hits/01-03- A Good Run Of Bad Luck (Album Version).mp3: java.lang.NoClassDefFoundError: Could not initialize class sun.java2d.Disposer
[7/17/17 12:46:58 AM EDT] WARN CoverArtController Failed to create thumbnail for Media file 30 - Greatest Hits
[7/17/17 12:46:59 AM EDT] WARN CoverArtController Failed to create thumbnail for Media file 36 - No Law

Any assistance is appreciated.
Yvonne
yvonne
 
Posts: 2
Joined: Wed Jul 12, 2017 4:06 pm

Re: New CentOS installation cannot see indexed music

Postby jrh.koenig » Wed Jul 26, 2017 3:32 pm

Hi Yvonne,

a stupid question: Has your subsonic user ( player user) for both music folders access granted?

Happens the java error only with directories with special characters? the linux filesystem and special characters are pain in the ass.

Kind Regards

Johannes
jrh.koenig
 
Posts: 18
Joined: Sat Feb 27, 2010 3:51 pm
Location: Frankfurt, Germany


Return to Help

Who is online

Users browsing this forum: No registered users and 4 guests