Some new folders not displaying?

Need help? Post your questions here.

Moderator: moderators

Re: Some new folders not displaying?

Postby 45rpm » Tue Dec 22, 2015 8:18 pm

Here is what I do to add a new Artist folder to my Media Folder.

Most of what I have read recommends emptying the database and doing a fresh scan such as this:

Code: Select all
Click on "Settings" tab
Clear the checkboxes on ALL "Enabled" folders
Click "Save"
Click on "Clean-up database"
Click on "Scan media folders now"
Check all checkboxes for "Enabled" folders
Click "Save"
Click on "Scan media folders now"
Click "Refresh"

This method takes way too long for those with large music collections. This just isn't a viable method every time you want to introduce a new artist!

Here is what I suggest instead:

Suppose you have a media folder called 'Music' at '\\192.168.0.10\Music' and you want to add a new Artist folder under that parent folder called 'Music'.
A re-scan will fail to discover the new folder and hence not add your new artist's music.

So, try this...

Suppose you want to add Pink Floyd to your collection.
Add another media folder called 'Temp' and give it your new path '\\192.168.0.10\Music\Pink Floyd'
Click 'Save'
Click 'Scan media folders now'
Wait until it completes.
Open the following URL in your browser:
http://localhost:4040/db.view (be sure to change whatever port and IP you use to access Subsonic)
You should get a box with an 'OK' button next to it
Enter the following code into it (be sure to adjust the path of where your top media folder is located)

Code: Select all
UPDATE media_file
SET folder = '\\192.168.0.10\Music'
WHERE folder = '\\192.168.0.10\Music\Pink Floyd';

Click OK

Wait for it to finish (couple seconds and the page will refresh)
Go back to settings at '/index.view' and delete the media folder called 'Temp' (Pink Floyd)
Click 'Save'
Then click 'Refresh' above your list of Artists.

That's it!

This method will force the new files to be discovered and then adds them to your original media folder.
This way is much quicker than a re-scan of an emptied database. It may be a little more work, but it pays off in the end.

Just thought I'd share - thanks!
45rpm
 
Posts: 12
Joined: Tue Dec 22, 2015 7:33 pm

Re: Some new folders not displaying?

Postby Azagthoth » Tue Dec 22, 2015 9:38 pm

45rpm wrote:This method will force the new files to be discovered and then adds them to your original media folder.
This way is much quicker than a re-scan of an emptied database. It may be a little more work, but it pays off in the end.

Just thought I'd share - thanks!


Holy hell, a quicker work around? :shock: THANK YOU!!!!

Sure there's a few steps but it sure beats resetting everything and then waiting over an hour just to get ALL my music to show up!
It's still unfortunate that there's no official fix on this; but as long as I can get my music to show up quicker in my database, I'm content.

Thanks again! <3

EDIT: I'm the biggest idiot and I fixed my own problem of following your steps. Just replaced the damn IP address to my own directory. Aye wey.

Unless it's just me, it doesn't show the album images or show up on the Recently Added tab on the Phone. Is that the only downside?
Azagthoth
 
Posts: 18
Joined: Thu Apr 14, 2011 9:48 am

Re: Some new folders not displaying?

Postby 45rpm » Sat Jan 02, 2016 10:51 pm

If it doesn't show your images, something is wrong. My images remain intact.

Do you mind me asking what your internal IP and music folder is?
Like...
Code: Select all
\\192.168.0.10\Music


I might be able to help you fix your problem.

I should be able to give you tailor-made instructions to fix this.
45rpm
 
Posts: 12
Joined: Tue Dec 22, 2015 7:33 pm

Re: Some new folders not displaying?

Postby RedHaze » Mon Feb 22, 2016 5:02 pm

It's a damn shame that the team just chooses to not reply to this ongoing issue. I would try to take a stab at it but I won't meddle with SVN. I just make it a scheduled task to rebuild my library completely on Friday nights.

EDIT: Would also like to point out that the issue is indeed still present in the new 6.0.1 beta
RedHaze
 
Posts: 5
Joined: Wed Feb 23, 2011 9:39 pm

Re: Some new folders not displaying?

Postby 45rpm » Thu Feb 25, 2016 10:07 pm

What are your thoughts about the new artist layout? I think I will miss the Artist List on the left too much to update. Will hold out as long as possible.
45rpm
 
Posts: 12
Joined: Tue Dec 22, 2015 7:33 pm

Re: Some new folders not displaying?

Postby el aye » Sun Apr 17, 2016 3:26 pm

RedHaze wrote:It's a damn shame that the team just chooses to not reply to this ongoing issue. I would try to take a stab at it but I won't meddle with SVN. I just make it a scheduled task to rebuild my library completely on Friday nights.

EDIT: Would also like to point out that the issue is indeed still present in the new 6.0.1 beta


I'm wondering if this is a similar issue to what I'm having...

Media setup directories look like (setup on Server 2012 using DrivePool):
D:\Music\Artists
D:\Music\Lists
D:\Music\Soundtracks

I have these separated distinctly in Subsonic so I can more easily select them from the index
Music - Artists | D:\Music\Artists
Music - Lists | D:\Music\Lists
Music - Soundtracks | D:\Music\Soundtracks

I also have subsonic indexing movies, such like:
D:\Movies\HDMovies
D:\Movies\3DMovies

In subsonic I just have it listed as
Movies | D:\Movies

Any new folders/media I add into HDMovies seems to index fine. Any new folders under Music\Artists does NOT show up, and even new albums under existing artists does not show up in the index. Existing albums all show up fine still. I don't recall ever making any changes to folder structure, permissions, etc; the only changes has been keeping subsonic up to date. I've even gone in and manually re-added permissions to make sure no folders were invisible to any process/user subsonic may be accessing it from.
el aye
 
Posts: 3
Joined: Wed Jun 20, 2012 3:31 pm

Re: Some new folders not displaying?

Postby Azagthoth » Sun Apr 17, 2016 9:35 pm

I've tried upgrading the new version (6.0.beta.2) and set all permissions to admin (within Subsonic and out of it) and I still can't get any of the new folders to show up. I'm really at a loss and even more frustrated that NONE of subsonic team wants to reply to this ongoing problem; it seems like a lot of people here have the exact same issue as I and still we've been given no hint as to what could be wrong. Nothing. Again, all I can do is completely wipe my database and set up my entire library again, which can take up to an hour.

I remember there was a point where some new folders were displaying a long time ago, but now it's every album that I add that won't show up. Posted this back in 2013, and still no help. :cry:
Azagthoth
 
Posts: 18
Joined: Thu Apr 14, 2011 9:48 am

Re: Some new folders not displaying?

Postby 45rpm » Sat Jul 23, 2016 6:34 pm

If your music folder is set up like so:
Code: Select all
\\server\music

and the directories under this folder are your artists:
Code: Select all
(such as)
\\server\music\The Beatles
\\server\music\U2
etc...

and your albums are directories under those folders:
Code: Select all
(such as)
\\server\music\The Beatles\Revolver
\\server\music\The Beatles\Rubber Soul
\\server\music\U2\Achtung Baby
\\server\music\U2\The Joshua Tree

Then if you add new albums to a new Artist folder (one that doesn't already exist) under your music folder "\\server\music", then it will NOT be recognized.
If you add new albums to existing Artist folders, then those albums WILL be recognized.
Each time you introduce a new artist, you have to specify a new music folder in Settings (ie -> \\server\music\The Rolling Stones) for Subsonic to recognize it even though it may be a subfolder under your original music folder.
I just use a SQL script afterwards to combine the music folders into one.

This is what I have found to be true.

It's like Subsonic doesn't even look for new folders under your specified music folder during a rescan - it just looks for new files in existing artist folders.
45rpm
 
Posts: 12
Joined: Tue Dec 22, 2015 7:33 pm

Previous

Return to Help

Who is online

Users browsing this forum: No registered users and 11 guests