External Player Playlists Using Local IP in 5.3

Need help? Post your questions here.

Moderator: moderators

External Player Playlists Using Local IP in 5.3

Postby theast » Wed Oct 28, 2015 6:29 pm

Everything else seems to be working just fine, it's just that all the track URLs in the M3U generated by SS uses my local LAN IP instead of my external web IP. Poked around the options to see if there was something new that toggles/changes this behavior, but I haven't come across it yet.

I had to downgrade back to 5.2.1 because external player playlists are my preferred method of using Subsonic. No worries, nothing in 5.3 I was dying to have, but I do like to stay current :D

I was just wondering if anybody else had experienced this issue after upgrading to 5.3, or if I should start looking into stuff specific to my setup.
theast
 
Posts: 4
Joined: Wed Aug 17, 2011 5:23 pm

Re: External Player Playlists Using Local IP in 5.3

Postby DaveWut » Fri Oct 30, 2015 6:23 pm

Yes, I too have the issue. I have posted about the issue by specifying a little more what my problem was :
viewtopic.php?f=2&t=16098
User avatar
DaveWut
 
Posts: 57
Joined: Fri Nov 11, 2011 12:29 am

Re: External Player Playlists Using Local IP in 5.3

Postby flanderb » Fri Oct 30, 2015 7:26 pm

I have this issue as well. Nothing really to add since the title spells it out. Just know you are not alone. External playlists worked in 5.3beta2 but not in 5.3. Is there a bug tracker we can add this to?
flanderb
 
Posts: 7
Joined: Fri Dec 17, 2010 2:00 am

Re: External Player Playlists Using Local IP in 5.3

Postby agentgreen » Tue Nov 03, 2015 2:11 pm

Happening here too, except it's pulling an IP address assigned to a VM; not really sure how it's pulling that off!
agentgreen
 
Posts: 6
Joined: Mon Sep 09, 2013 7:29 pm

Re: External Player Playlists Using Local IP in 5.3

Postby Jägs » Sat Dec 12, 2015 4:40 am

Same for me too: viewtopic.php?f=2&t=16205

I installed a standalone version of 5.2.1, leaving everything else the same and it worked. Anyone know if you can simply downgrade the current installation?

[EDIT: never mind the last part, as downgrading worked perfectly; hopefully this is fixed in the next version]
Jägs
 
Posts: 94
Joined: Wed Apr 06, 2011 9:52 pm

Re: External Player Playlists Using Local IP in 5.3

Postby Jägs » Tue Dec 15, 2015 5:32 pm

Actually, downgrading didn't work perfectly. Everything seems to be work except for Google Image searching for album artwork.
Jägs
 
Posts: 94
Joined: Wed Apr 06, 2011 9:52 pm

Re: External Player Playlists Using Local IP in 5.3

Postby flanderb » Mon Jan 18, 2016 2:03 pm

Just going with the commit log title(I won't pretend to know what is going on with the code) it looks like Sindre knows about the issue and fixed it last week in the source. http://sourceforge.net/p/subsonic/code/4622/

I'm looking forward to when this will get into production.
flanderb
 
Posts: 7
Joined: Fri Dec 17, 2010 2:00 am

Re: External Player Playlists Using Local IP in 5.3

Postby acroyear » Sat Feb 13, 2016 9:50 pm

Jägs wrote:Actually, downgrading didn't work perfectly. Everything seems to be work except for Google Image searching for album artwork.


That isn't the fault of Subsonic, and every pre-6 version has that problem. Google removed the public API for image search that it relied on.

The new version uses Last.fm instead, which is good for many things (but not for my classical collection, where I greatly modify the ID3 from the originals in order to find anything, but nevermind as that's my problem, not Last.fm's).
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 684
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA


Return to Help

Who is online

Users browsing this forum: No registered users and 5 guests