Help with web radio

Need help? Post your questions here.

Moderator: moderators

Help with web radio

Postby mapomme1108 » Thu Apr 20, 2017 6:44 am

Hello,

I am new to Subsonic.
I have installed it on my Qnap NAS

I have added a web radio with this url :
http://direct.franceinter.fr/live/franceinter-midfi.mp3

But when I click on "Internet TV/Radio" I am not able to play it.
Instead I have this message :
"html5: Video file not found http://192.168.0.20:4040/internetRadioStream.view?id=4"

How can I fix it?

Thanks.
mapomme1108
 
Posts: 5
Joined: Thu Apr 20, 2017 6:39 am

Re: Help with web radio

Postby acroyear » Thu Apr 20, 2017 4:54 pm

Code: Select all
<video src="http://<mydomain>:4040/internetRadioStream.view?id=0" class="fp-engine" preload="metadata" x-webkit-airplay="allow"></video>


that's the DOM element. it should be an audio tag, not a video, and it should be passing in the expected mime/type. I'm not sure if that is a bug in "flowerplayer" or a bug in how subsonic is calling it, but it is definitely a bug. Not sure of a workaround other than using an alternate client that supports internet radio directly.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 623
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Help with web radio

Postby mapomme1108 » Sat Apr 22, 2017 1:21 pm

Hi,

Ok, I will wait for the next release.

Thanks
mapomme1108
 
Posts: 5
Joined: Thu Apr 20, 2017 6:39 am

Re: Help with web radio

Postby Kliikko » Mon Apr 24, 2017 10:06 pm

I get the same error, no matter what kind of stream I try to play on Subsonic's "Internet Radio" - didn't a very recent changelog say that this had finally been fixed now ?

Anyway, for example this radio has three or four different stream formats available, none of them play in current 6.1 beta2:

http://laxestereo.com
Kliikko
 
Posts: 9
Joined: Fri Mar 24, 2017 5:26 am

Re: Help with web radio

Postby sindre_mehus » Mon May 01, 2017 6:36 pm

I don't know, but both these radio URLs works for me (Subsonic 6.1.beta2, OSX, Chrome):

http://direct.franceinter.fr/live/franceinter-midfi.mp3
http://laxestereo.com/proserv256K.pls

Please note that Subsonic transcodes the streams to mp3, using ffmpeg. Can you take a look at subsonic.log for any errors?

Thanks
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Help with web radio

Postby acroyear » Tue May 02, 2017 1:53 am

Just "[5/1/17 9:47:11 PM EDT] INFO InternetRadioStreamController Starting converter for radio: /var/subsonic/transcode/ffmpeg -i http://streaming.radionomy.com/MuppetCentralRadio -f mp3 -v 0 -"

nothing entered the player below, and the main window still had what we've described "html5: Video file not found", along with the url of the first station.

both stations play fine in SubFire, using the API for the streaming url.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 623
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Help with web radio

Postby FlyingPersian » Thu May 04, 2017 12:08 am

I had this problem a while back, see here. The fix, although not helpful here, was to install subsonic via the FreeNAS App. Using the standalone install didn't work with regards to using the radio, not sure why, cuz the versions were the same.
I'm now using a standalone version again and the radio is also not working, with the same html5 error.
FlyingPersian
 
Posts: 29
Joined: Mon Oct 31, 2016 11:43 pm

Re: Help with web radio

Postby Kliikko » Thu May 04, 2017 12:43 am

Thanks for the message, good to see the genius behind Subsonic on the forums :)

I've factory reset so can't provide the actual log but I guess it was a ffmpeg/Synology problem (again).

In log when playing e.g. FLAC from normal library it would find and try to use the ffmpeg, but without any further detail there's an error "Can't transcode, playing original". Since you say radio is automatically transcoded, I suppose that would have been the problem with those radio streams too.



sindre_mehus wrote:I don't know, but both these radio URLs works for me (Subsonic 6.1.beta2, OSX, Chrome):

http://direct.franceinter.fr/live/franceinter-midfi.mp3
http://laxestereo.com/proserv256K.pls

Please note that Subsonic transcodes the streams to mp3, using ffmpeg. Can you take a look at subsonic.log for any errors?

Thanks
Sindre
Kliikko
 
Posts: 9
Joined: Fri Mar 24, 2017 5:26 am

Re: Help with web radio

Postby FlyingPersian » Thu May 04, 2017 11:07 pm

sindre_mehus wrote:I don't know, but both these radio URLs works for me (Subsonic 6.1.beta2, OSX, Chrome):

http://direct.franceinter.fr/live/franceinter-midfi.mp3
http://laxestereo.com/proserv256K.pls

Please note that Subsonic transcodes the streams to mp3, using ffmpeg. Can you take a look at subsonic.log for any errors?

Thanks
Sindre


Can you please tell us what you have setup under settings --> transcode?

Mine says this:


Code: Select all
ffmpeg -i %s -map 0:0 -b:a %bk -v 0 -f mp3 -


Edit: Setting the radio works fine when using dsub (Android app).

Edit2: Is it possible to add logging to the stream transcoding? I think "-v 0" under transcode stands for "logging level panic", right (see here. The only thing resembling -v is logging. Setting it to 48 (debug) doesn't do anything, even in the log it still says -v 0

Edit3: Although playing on my android app works fine, I cannot cast it to my chromecast.
FlyingPersian
 
Posts: 29
Joined: Mon Oct 31, 2016 11:43 pm

Re: Help with web radio

Postby chrisl » Wed Jan 03, 2018 7:36 pm

sindre_mehus wrote:I don't know, but both these radio URLs works for me (Subsonic 6.1.beta2, OSX, Chrome):

http://direct.franceinter.fr/live/franceinter-midfi.mp3
http://laxestereo.com/proserv256K.pls

Please note that Subsonic transcodes the streams to mp3, using ffmpeg. Can you take a look at subsonic.log for any errors?

Thanks
Sindre


Hi,

same issue here.

. Works: http://laxestereo.com/proserv256K.pls
- Doesnt work: http://direct.franceinter.fr/live/franceinter-midfi.mp3. Results in "html5: Video file not found"
Log: [03.01.18 19:20:51 UTC] INFO InternetRadioStreamController Starting converter for radio: /var/subsonic/transcode/ffmpeg -i http://direct.franceinter.fr/live/franceinter-midfi.mp3 -f mp3 -v 0 -

Any ideas?

BR
Chrisl
chrisl
 
Posts: 5
Joined: Sun Nov 05, 2017 1:59 pm

Re: Help with web radio

Postby koloss » Thu Aug 30, 2018 10:23 am

I had similar problem on Debian 9.0.

After test in terminal:
Code: Select all
sudo /var/subsonic/transcode/ffmpeg -i http://direct.franceinter.fr/live/franceinter-midfi.mp3 -f mp3 -v verbose 0 - 2>> output.txt


I got error:
[tcp @ 0xbe46000] Failed to resolve hostname direct.franceinter.fr: System error
http://direct.franceinter.fr/live/franceinter-midfi.mp3: Input/output error

I think it doesn't love subdomains.

What works for me:
I was installed ffmpeg from apt
Code: Select all
sudo apt-get install ffmpeg


then I was renamed(backup) /var/subsonic/transcode/ffmpeg to ffmpeg_
Code: Select all
sudo mv /var/subsonic/transcode/ffmpeg /var/subsonic/transcode/ffmpeg_


and last step I was created a symlink to ffmpeg from subsonic's transcode folder(/var/subsonic/transcode/)

Code: Select all
sudo ln -s /usr/bin/ffmpeg /var/subsonic/transcode/ffmpeg


I'm not an expert but it sole dicision which works for me.

Hope this helps somebody!
koloss
 
Posts: 1
Joined: Thu Aug 30, 2018 9:54 am

Re: Help with web radio

Postby zeroth » Wed Feb 20, 2019 1:04 pm

no go for me. I can't get any radio stations playing. Log shows the below and nothing more. I don't really have anything else to go off.

2019-02-20 12:50:21,534] INFO InternetRadioStreamController - Starting converter for radio: /var/subsonic/transcode/ffmpeg -i http://192.240.97.154:3690/977_HITS_SC -f mp3 -v 0 -
zeroth
 
Posts: 46
Joined: Sat Jan 17, 2015 2:56 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 21 guests