Need help? Post your questions here.

Moderator: moderators


Postby bluesthinker » Wed Jun 20, 2018 3:51 am


Thanks, that did it!! :lol:
Posts: 3
Joined: Tue Jun 19, 2018 2:26 pm


Postby disgustipated » Sat Jul 07, 2018 1:44 pm

From the stack trace from the only log file i saw in this thread it looks like there was a problem in the xml for the applicationContext-sonos.xml file, was that file corrupted somehow or edited?
Posts: 96
Joined: Wed Jan 26, 2011 4:18 pm
Location: US


Postby bupkis » Wed Aug 15, 2018 7:12 pm

dave31175 wrote:
bluesthinker wrote:The solutions discussed above, don't seem to fit me.

After trying the solutions above (and those mentioned in my post previous to yours) and still receiving the 503, I completely uninstalled and started from scratch yesterday. So far all is working as expected. It's certainly not an ideal solution, but apparently in this case it was the *only* solution. I do wish there was another viable means for streaming one's own music collection, but having found none, I may just have to live with starting from square one every couple of months.

When you uninstall everything, what do you lose? Is "recently added" still in order or does everything look like it was added at the same time?

Also: what exactly do you uninstall and how?
Posts: 22
Joined: Sat Jan 19, 2013 8:08 pm


Postby bupkis » Sat Aug 18, 2018 10:09 am

I'm convinced that this error has to do with java upgrades breaking something that jetty relies on. It isn't just a subsonic problem as people are complaining about it on madsonic and airsonic forums.

Also, I had the problem, completely uninstalled subsonic including the entire /var/subsonic directory, then did a new install and still had the problem.

These lines from the log are telling:

Code: Select all
368 [main] WARN org.mortbay.log - Failed startup of context org.mortbay.jetty.webapp.WebAppContext@43496793{/,jar:file:/usr/share/subsonic/subsonic.war!/} error in opening zip file

The only relevant .zip file I've found is in /usr/lib/jvm/java-7-openjdk-amd64 and it's a broken symlink called I surmise that something broke that link. There is an actual file called but it's in /opt/jdk1.8.0_161/ but I'm not going to fix the broken symlink to link to it for fear that it'd break all kinds of stuff.

Has anyone tried completely removing java (see here) and reinstalling?
Posts: 22
Joined: Sat Jan 19, 2013 8:08 pm


Postby bupkis » Sun Aug 19, 2018 2:45 pm

bupkis wrote:Has anyone tried completely removing java (see here) and reinstalling?

I've now done this and it solved the problem. My steps under Ubuntu 14.04.5 (ymmv):

1. Back up /var/subsonic (I did this days ago at the moment I knew subsonic wasn't working anymore).
2. Stop subsonic if it's running: sudo service subsonic stop (in my case)
3. Totally delete subsonic: sudo dpkg -P subsonic
4. Delete /var/subsonic: sudo rm -R /var/subsonic
5. Totally remove all versions of java (only acceptable if you're not dependent on a specific version of java other than 7 for other software you use) following this procedure.
6. Reinstall java 7: sudo apt-get install openjdk-7-jre
7. Download subsonic and install it with: sudo dpkg -i subsonic-6.1.3.deb
8. Since I've always run subsonic as it's own user (called "subsonic") and because I forgot to preserve ownership when I backed up, I recursively changed the ownership of /var/subsonic: sudo chown -R subsonic:subsonic /var/subsonic
9. Edited /etc/default/subsonic to increase the memory allocation and change the subsonic user to "subsonic": sudo nano /etc/default/subsonic
10. Restart subsonic: sudo service subsonic start

That was all it took. Everything back and running and just the way I left it before it stopped working.

I'm convinced that an upgrade to oracle java 8 that I didn't pay sufficient attention to broke the install and caused the jetty errors that resulted in HTTP 503.

Hope this helps someone.
Posts: 22
Joined: Sat Jan 19, 2013 8:08 pm


Postby guss » Fri Oct 05, 2018 9:17 am

I'm on Ubuntu 18.04 and subsonic works fine with java 8. But as soon, as I switch to the actual java 11 I get the error 503.

0 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1101 auto mode
1 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1101 manual mode
* 2 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1081 manual mode

Does is work for anyone with java 11? I don't want to try the complete uninstalling unless I know that it works for anybody and your are not all using the old java version. Thanks!

Posts: 1
Joined: Mon Sep 17, 2018 9:58 am


Return to Help

Who is online

Users browsing this forum: No registered users and 15 guests