Everything is indexed, but nothing is displayed!? [SOLVED]

Need help? Post your questions here.

Moderator: moderators

Everything is indexed, but nothing is displayed!? [SOLVED]

Postby metaflux » Wed May 16, 2018 3:19 pm

S O L V E D !

Shit... I've never been this stupid.

BUT, in my defense I have to say that in older versions, the admin account ALWAYS had immediate access to all libraries. Now I have to check the box.

Old question:

Please help:

A few days ago I reinstalled my Rock64 (similar to a RaspberryPi). I have installed Debian (Stretch) and Java 8, Subsonic runs in version 6.1.3.

2,350 artists, 6,809 albums, 93,211 songs, 1063.81 GB and 15,484 hours were indexed.

But neither in the Android Apps (D-Sub and Subsonic) nor in the browser (Chrome) anything is displayed under HOME or INDEX. I have already deleted and re-indexed the DB folders several times, always with the same result.

The music is on a mounted USB hard disk, which is formatted with NTFS and can be read and written via "ntfs-3g". In /etc/fstab I have the following entry:

Code: Select all
LABEL=boot /boot/efi vfat defaults 0 0
UUID=E614438C14435EA5   /media/usb   ntfs   auto,nofail,sync,users,rw   0   0

I've read about people with NTFS (and or Windows10) problems here in the forum several times now.
With an older Subsonic version I had no problems with Subsonic in the same combination (USB NTFS hard disk).

Does anyone know more?

P.S. subsonic runs as root user on port 4040 with 1024M of Ram:

Code: Select all

Subsonic deamon status:
Code: Select all
● subsonic.service - LSB: Subsonic daemon
   Loaded: loaded (/etc/init.d/subsonic; generated; vendor preset: enabled)
   Active: active (running) since Tue 2018-05-15 18:29:11 UTC; 20h ago
     Docs: man:systemd-sysv-generator(8)
  Process: 6462 ExecStop=/etc/init.d/subsonic stop (code=exited, status=0/SUCCESS)
  Process: 6490 ExecStart=/etc/init.d/subsonic start (code=exited, status=0/SUCCESS)
    Tasks: 46 (limit: 4915)
   CGroup: /system.slice/subsonic.service
           └─6508 java -Xmx1024m -Dsubsonic.home=/var/subsonic -Dsubsonic.host= -Dsubsonic.port=4040 -Dsubsonic.httpsPort=0 -Dsubsonic.contextPath=/ -Dsubsonic.db= -Dsubsonic.defaultMusicFolder=/var/music -Dsubsonic.defaultPodcastFo
lder=/var/music/Podcast -Dsubsonic.defaultPlaylistFolder=/var/playlists -Djava.awt.headless=true -verbose:gc -jar subsonic-booter-jar-with-dependencies.jar

May 15 18:29:11 rock64 systemd[1]: Starting LSB: Subsonic daemon...
May 15 18:29:11 rock64 subsonic[6490]: Started Subsonic [PID 6508, /var/subsonic/subsonic_sh.log]
May 15 18:29:11 rock64 systemd[1]: Started LSB: Subsonic daemon.
Posts: 3
Joined: Thu Mar 28, 2013 8:00 am

Return to Help

Who is online

Users browsing this forum: No registered users and 2 guests