Subsonic and Sonos - Songs Play For Several Seconds Only

Need help? Post your questions here.

Moderator: moderators

Subsonic and Sonos - Songs Play For Several Seconds Only

Postby edwardrudman@cox.net » Sun Dec 02, 2018 8:47 pm

Last week, Sonos and Subsonic were working together wonderfully on my system. Then I got a message one morning that I couldn't use Subsonic anymore, I had to have Subsonic Premium. I purchased a license and installed it, and ever since that time when I tried to play music through Sonos and my Subsonic Library, a song will play for anywhere between 10 and 20 seconds, then will stop, then will skip to the next song. And I get a message between each song "unable to connect to subsonic service". I don't believe it's a Sonos problem because if I put some music on a local C drive, and add that to Sonos music library, it works fine. But Sonos and subsonic will not play my subsonic music located on a network drive connected via Ethernet to my network. I have uninstalled and reinstalled Sonos and subsonic, and have also turned off and turn back on all of my Hardware, router modem computer. Anybody have any thoughts or help? As of right now, I can't use subsonic at all comma after having paid.
edwardrudman@cox.net
 
Posts: 2
Joined: Sun Dec 02, 2018 8:21 pm

Re: Subsonic and Sonos - Songs Play For Several Seconds Only

Postby edwardrudman@cox.net » Mon Dec 03, 2018 1:51 am

So, I made a new discovery.....

SubSonic seems to be working fine if I go into my router web control panel, then go to "Security" --> Apps and Gaming--> Port Range Forwarding --> and DISABLE the 80-80 and the 4040-4040 that was enabled to allow SubSonic phone app to see SubSonic Premium on my Windows PC, I did a little testing and songs don't seem to be skipping anymore. But this means, of course, that I *won't* be able to utilize SubSonic Premium from my phone, so that sucks.

QUESTION: Along with "forwarding this 4040 port", should I also be establishing a "static IP" for the SubSonic service? I am a computer guy and semi-knowledgable, but not a "network" guy, so I'm hazy on that stuff....Anyone?
edwardrudman@cox.net
 
Posts: 2
Joined: Sun Dec 02, 2018 8:21 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 15 guests