1.6.5 will not start

Need help? Post your questions here.

Moderator: moderators

1.6.5 will not start

Postby jarome » Sat Dec 29, 2018 12:49 am

I am running on OpenSUSE Leap 15. I had an issue with 1.6.3, which would not work until I set JAVA_HOME to point to Java 1.8 in both /etc/init.d/subsonic, and in /etc/sysconfig/subsonic. But this trick no longer works in 1.6.5.

jardell:/var/log/apache2 # systemctl start subsonic
jardell:/var/log/apache2 # systemctl status subsonic
● subsonic.service - LSB: Subsonic daemon
Loaded: loaded (/etc/init.d/subsonic; generated; vendor preset: disabled)
Active: active (exited) since Fri 2018-12-28 19:37:21 EST; 11min ago
Docs: man:systemd-sysv-generator(8)
Process: 11075 ExecStop=/etc/init.d/subsonic stop (code=exited, status=0/SUCCESS)
Process: 11095 ExecStart=/etc/init.d/subsonic start (code=exited, status=0/SUCCESS)

Dec 28 19:37:21 jardell systemd[1]: Starting LSB: Subsonic daemon...
Dec 28 19:37:21 jardell systemd[1]: Started LSB: Subsonic daemon.

This is /etc/sysconfig/subsonic:
Code: Select all
#
# This is the configuration file for the Subsonic service
# (/etc/init.d/subsonic)
#
# To change the startup parameters of Subsonic, modify
# the SUBSONIC_ARGS variable below.
#
# Type "/usr/share/subsonic/subsonic.sh --help" on the command line to read an
# explanation of the different options.
#
# For example, to specify that Subsonic should use port 80 (for http)
# and 443 (for https), and use a Java memory heap size of 200 MB, use
# the following:
#
# SUBSONIC_ARGS="--port=80 --https-port=443 --max-memory=200"

#SUBSONIC_ARGS="--port=4041 --max-memory=1500 --https-port=8043"

# The user which should run the Subsonic process. Default "root".
# Note that non-root users are by default not allowed to use ports
# below 1024. Also make sure to grant the user write permissions in
# the music directories, otherwise changing album art and tags will fail.

SUBSONIC_USER=subsonic

JAVA_HOME=/etc/alternatives/java_sdk_1.8.0
#
SUBSONIC_ARGS="--port=4041 --max-memory=1500 --https-port=8043 --pidfile=/var/subsonic/subsonic.pid --add-modules=java.xml.bind --quiet false"

jarome
 
Posts: 85
Joined: Sat Apr 16, 2011 2:53 am

Re: 1.6.5 will not start

Postby jarome » Sun Dec 30, 2018 4:33 pm

I get the following error:
Code: Select all
594 [main] WARN org.mortbay.log - Nested in org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'sonosEndpoint': Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: javax/jws/WebService:
java.lang.ClassNotFoundException: javax.jws.WebService

I suspect that Sonos support has been added to this Subsonic version. How do I get this class?
jarome
 
Posts: 85
Joined: Sat Apr 16, 2011 2:53 am

Re: 1.6.5 will not start

Postby jarome » Tue Jan 01, 2019 3:27 pm

Something is wrong with the startup script. It does not seem to read /etc/sysconfig/subsonic. Nor is there a subsonic entry in /usr/lib/systemd/system.
But the following script works to start subsonic:
Code: Select all
#!/bin/bash -a
#
# This is the configuration file for the Subsonic service
# (/etc/init.d/subsonic)
#
# To change the startup parameters of Subsonic, modify
# the SUBSONIC_ARGS variable below.
#
# Type "/usr/share/subsonic/subsonic.sh --help" on the command line to read an
# explanation of the different options.
#
# For example, to specify that Subsonic should use port 80 (for http)
# and 443 (for https), and use a Java memory heap size of 200 MB, use
# the following:
#
# SUBSONIC_ARGS="--port=80 --https-port=443 --max-memory=200"

#SUBSONIC_ARGS="--port=4041 --max-memory=1500 --https-port=8043"

# The user which should run the Subsonic process. Default "root".
# Note that non-root users are by default not allowed to use ports
# below 1024. Also make sure to grant the user write permissions in
# the music directories, otherwise changing album art and tags will fail.

SUBSONIC_USER=subsonic

JAVA_HOME=/etc/alternatives/java_sdk_1.8.0
#
#SUBSONIC_ARGS="--port=4041 --max-memory=1500 --https-port=8043 --pidfile=/var/subsonic/subsonic.pid --add-modules=java.xml.bind,javax.jws.WebService --quiet false"

PATH=/sbin:/usr/sbin:/bin:/usr/bin:$PATH
DESC="Subsonic Daemon"
NAME=subsonic
#PIDFILE=/var/run/$NAME.pid
#LOCKFILE=/var/lock/subsys/$NAME
DAEMON=/usr/bin/$NAME
#DAEMON_ARGS="--pidfile=$PIDFILE $SUBSONIC_ARGS"
DAEMON_ARGS=
SCRIPTNAME=/etc/init.d/$NAME
SUBSONIC_PIDFILE=/var/subsonic/subsonic.pid

SUBSONIC_HOME=/var/subsonic
SUBSONIC_HOST=jardell
SUBSONIC_PORT=4041
SUBSONIC_HTTPS_PORT=8043
#SUBSONIC_CONTEXT_PATH=${SUBSONIC_CONTEXT_PATH:-/}
#SUBSONIC_DB=/var/subsonic/db
#SUBSONIC_MAX_MEMORY=${SUBSONIC_MAX_MEMORY:-150}
SUBSONIC_DEFAULT_MUSIC_FOLDER=/data1/Music
SUBSONIC_DEFAULT_PODCAST_FOLDER=${SUBSONIC_DEFAULT_PODCAST_FOLDER:-/var/music/Podcast}
SUBSONIC_DEFAULT_PLAYLIST_FOLDER=${SUBSONIC_DEFAULT_PLAYLIST_FOLDER:-/var/playlists}


# Exit if the package is not installed.
[ -x "$DAEMON" ] || exit 0

# Run as root if SUBSONIC_USER is not set.
[ "$SUBSONIC_USER" = "" ] && SUBSONIC_USER=root

su -c "$DAEMON $DAEMON_ARGS" $SUBSONIC_USER
jarome
 
Posts: 85
Joined: Sat Apr 16, 2011 2:53 am

Re: 1.6.5 will not start

Postby jarome » Tue Jan 01, 2019 7:30 pm

removing the PID file allowed it to start. Duh.
jarome
 
Posts: 85
Joined: Sat Apr 16, 2011 2:53 am


Return to Help

Who is online

Users browsing this forum: No registered users and 17 guests