chrome cast not working from google chrome

Need help? Post your questions here.

Moderator: moderators

chrome cast not working from google chrome

Postby adragon202 » Sun Mar 17, 2019 7:01 pm

Whether I load subsonic in google chrome on my desktop or Android phone, I don't get the ability to cast the videos or music on my server. The button doesn't appear. On my desktop I can cast the tab using the cast button in chrome, but that's nowhere near as clean as it used to be when I could cast from subsonic direct.

I did some digging in the browsers dev console and it appears that chrome.cast is undefined. I suspect that chrome_sender isn't loading correctly. Is there anything I can do on my end to get this back up? Is this a known bug?

Server info
License Subsonic Premium
Version 6.1.5 (build 759abe) – December 1, 2018
Server jetty-6.1.x, java 1.8.0_191, HSQLDB, Linux (72.6 MB / 145.0 MB)

Browser Info
Google Chrome 72.0.3626
adragon202
 
Posts: 3
Joined: Tue Jul 31, 2012 12:57 pm

Re: chrome cast not working from google chrome

Postby acroyear » Mon Mar 18, 2019 10:27 pm

Well, I'm not replicating in that I am still seeing the Chromecast icon appear, both in the desktop app and in my own html5 players.

However, something in the APIs have clearly changed in the last few months, because as I'm testing it now on my html5 player (SubFire M2 in this case), I'm not getting the same behavior I used to. In particular I'm not getting the updates from the time (how many seconds into the track it has played) like I used to. Other things aren't working they way they did just a few months ago, so it looks like I know what I'll be arguing with this week.

Subsonic used to have a much older version of Chromecast APIs installed and things may have changed that are causing the random issues. I might know more in a few days.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 633
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: chrome cast not working from google chrome

Postby acroyear » Mon Mar 18, 2019 10:29 pm

On your desktop, though, you could try the official Chromecast icon in your apps bar (to the right of the url address bar) instead of the on-screen button. If it casts to the Subsonic chromecast receiver, things are ok...but if it casts the whole tab, then something else has gone funny. Not sure how to fix that, though. Last time, we had to wait for an upgrade.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 633
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: chrome cast not working from google chrome

Postby adragon202 » Wed Mar 20, 2019 2:06 am

That's the thing though. Nothing cast related is working with the subsonic player directly, and I suspect it's because in the loaded page chrome.cast is undefined. I've worked around it by casting the tab, but cannot cast the player.

Like you this is a steady degradation though. About 6 months ago I was able to cast from my phone, then just a few weeks ago it stopped working from my desktop.
adragon202
 
Posts: 3
Joined: Tue Jul 31, 2012 12:57 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 14 guests