Page 1 of 1

Can't connect extrernally after (possibly) Android update

PostPosted: Thu Mar 28, 2019 4:17 am
by PainoMan

I can't seem to get my phone to connect to my server when not connected to my home network, and I think it might be related to a recent Android update that came to my phone (Galaxy Note 9) a few days ago. My phone is now using Android Version 9 (Pie?)

My son's phone did not get an update and it can connect just fine, and my friends who have accounts all can connect as well. It seems that only my phone now can't connect.

It now times out whether I'm using the Subsonic Android app, or going through a web browser on the phone. My server is on a PC running Windows 7, and I've checked everything I can to make sure nothing on the PC is blocking the phone's IP address. I've also checked that port 4040 is open and seeable.

Could it be something with the new Android OS not being compatible with the Subsonic server?

Re: Can't connect extrernally after (possibly) Android updat

PostPosted: Thu Mar 28, 2019 11:30 am
by 3Dscrewer
You didn't forget to write the :4040 at the end of the URL like and don't forget the colon ....
Otherwise you might have a firewall or the APP Blokada who will reject the URL.

If you like, write me an PM, I give you my Address and you can check it out where the Problem is .....

Re: Can't connect extrernally after (possibly) Android updat

PostPosted: Fri Mar 29, 2019 1:16 am
by PainoMan
I've found that with any wifi connection, not just my home network, I can connect to my server. So it's only when the phone is using cellular that it won't connect, even with different IP addresses assigned while using mobile data connections.

All other phones I've tried connect fine, so I can only assume that the Android 9 update changed something.

*Edit* My other son's Galaxy S9+ is running Pie and it connects fine on mobile data. So it must be a bug with the combination of the Note 9 and Pie.

Re: Can't connect extrernally after (possibly) Android updat

PostPosted: Mon Apr 15, 2019 4:18 pm
by gobluebuckeye
I am having this same issue. I cannot access my library when I am connected to wi-fi, but not with a mobile network. I only started having this problem after the recent Android update.

Re: Can't connect extrernally after (possibly) Android updat

PostPosted: Thu Apr 25, 2019 6:01 pm
by chuckens
I had issues also. Go into network settings in your browser and make sure you have clicked the box : "Access your server over the Internet using an easy-to-remember"

That fixed it for me.

Re: Can't connect extrernally after (possibly) Android updat

PostPosted: Mon May 06, 2019 9:12 pm
by mykol404
I think this might be related to the issue some folks are seeing in the newest version.
It seems that after a few days, at least for me, Subsonic (still not sure if software or server) is forgetting the applied external access settings.
Still works at home over WiFi, but not externally. Not even by ip address:port (vs URL, which makes me think its a software bug, not server side issue).