Page 1 of 1

How to add VGM/VGZ files in Subsonic

PostPosted: Wed Sep 18, 2019 1:06 am
by Azkatro
I've got a collection of video game music that I've been trying to add to my library.

In the case of VGZ files, I've implemented a way to transcode it via ffmpeg and it's working nicely. However, I can't convince Subsonic to recognise VGZ files.

I've added vgz to the "Music files" file formats list under Settings/General. Despite a couple of full rescans of the media library, they just won't appear.

Can anybody give me any ideas on how I can make them appear? Is it because the media scanner doesn't recognise the file type?

*EDIT: For anybody interested, the transcoding command line is this (note that vgm2wav.exe can be obtained from here: ... s/tag/v1.3):

Code: Select all
vgm2wav %s --fade-ms 2000 - | ffmpeg -i pipe: -b:a %bk -f ogg -

Re: Additional file formats not showing

PostPosted: Wed Sep 18, 2019 11:31 pm
by Azkatro
Woke up this morning, checked and they were showing. No idea, can only guess that the scheduled media scan did something differently to the settings-triggered one?

Anyway, for anybody interested, I had to tweak the transcoding command. It required me to create a CMD file in windows as the pipe to ffmpeg didn't work. Here is my vgm.cmd (created this as a batch file under C:\subsonic\transcode):

Code: Select all
vgm2wav.exe %1 --fade-ms 2000 - | ffmpeg.exe -i pipe: -b:a %2k -f ogg -

(If you don't want to have it fade out at the end, remove the --fade-ms 2000 part)

And the transcode setting in subsonic now becomes:

Code: Select all
vgm.cmd %s %b

Listening to Altered Beast music right now. It's a terrible soundtrack but it works great.