Music only showed on the index page

Need help? Post your questions here.

Moderator: moderators

Music only showed on the index page

Postby guswogjs499 » Fri Oct 11, 2019 10:51 am

Hello. I've just installed Subsonic. But I found a little weird thing. My music collection is only shown on the index page. I can't see my music on home or other tabs.

Meanwhile streaming on index page is just working well.

I am using 6.1.5 (build 759abe) version on my custom Ubuntu 18.04.3 machine. I tried this on Chrome and Firefox.

Have any ideas about this issue?

Image
Image
guswogjs499
 
Posts: 3
Joined: Fri Oct 11, 2019 10:37 am

Re: Music only showed on the index page

Postby G8DHE » Sat Oct 12, 2019 8:06 pm

On the home page tap the Hamburger menu once and the media folders should appear below the option menu's
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 66
Joined: Sun Nov 04, 2012 4:56 pm

Re: Music only showed on the index page

Postby thoto » Sun Nov 03, 2019 12:42 pm

Hi,
I faced the exact same problem as you do, but there's more:

I used to use v6.0 (build a7857c) that was installed when using "plugins" on FreeNAS systems. And everything was working fine.
Then, one day, the problem you described simply appeared, without any other change on my side...

So, I did a fresh install on a dedicated Debian 9 VM, and installed a fresh 6.1.5 (build 759abe)... And unexpectedly, the problem showed again...
I updated the atabase, checked everything related to file permissions and so on (since I use a setup not running subsonic as root user).... no luck..

Anyway, as I was beginning to lose hope, I tried another database refresh from subsonic GUI.... And now everything seems to be fixed...
So, I imagine it may be related to file ownership in the /var/subsonic/db folder .... And maybe you need to refesh the database after having the file permissions changed...
thoto
 
Posts: 1
Joined: Sun Nov 03, 2019 12:28 pm

Re: Music only showed on the index page

Postby guswogjs499 » Tue Nov 05, 2019 11:29 am

G8DHE wrote:On the home page tap the Hamburger menu once and the media folders should appear below the option menu's


Ah... negative. there are no folders appear.
guswogjs499
 
Posts: 3
Joined: Fri Oct 11, 2019 10:37 am

Re: Music only showed on the index page

Postby guswogjs499 » Tue Nov 05, 2019 11:44 am

thoto wrote:Hi,
I faced the exact same problem as you do, but there's more:

I used to use v6.0 (build a7857c) that was installed when using "plugins" on FreeNAS systems. And everything was working fine.
Then, one day, the problem you described simply appeared, without any other change on my side...

So, I did a fresh install on a dedicated Debian 9 VM, and installed a fresh 6.1.5 (build 759abe)... And unexpectedly, the problem showed again...
I updated the atabase, checked everything related to file permissions and so on (since I use a setup not running subsonic as root user).... no luck..

Anyway, as I was beginning to lose hope, I tried another database refresh from subsonic GUI.... And now everything seems to be fixed...
So, I imagine it may be related to file ownership in the /var/subsonic/db folder .... And maybe you need to refesh the database after having the file permissions changed...


Sir, May I know what "refresh the database" actually stands for? Should I delete the files on /var/subsonic/db folder?
guswogjs499
 
Posts: 3
Joined: Fri Oct 11, 2019 10:37 am


Return to Help

Who is online

Users browsing this forum: No registered users and 9 guests