Troubleshooting streaming when no on wifi

Need help? Post your questions here.

Moderator: moderators

Troubleshooting streaming when no on wifi

Postby ian41t » Sun Oct 20, 2019 2:29 pm

Completely new here..had some problems with install and setup but I have everything working over wifi. I'm having trouble with port forwarding. This hasn't been an issue in the past, and the Subsonic settings the Status: Successfully forwarding port 4040

I'm not able to stream via the Subsonic app on my phone unless I'm on the wifi network. Any help would be greatly appreciated!

Subsonic:
6.1.5 (build 759abe) – December 1, 2018
Server jetty-6.1.x, java 1.8.0_131, HSQLDB, Mac OS X (95.8 MB / 140.5 MB)

Running Subsonic on MacOS 10.14.6 and streaming on iOS from iSub app.

Recent log:
[10/20/19 8:25:25 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 8:25:25 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 8:25:25 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 8:31:00 AM EDT] INFO NetworkService Successfully forwarding port 4040.
[10/20/19 8:40:13 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 8:40:13 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 8:40:13 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 8:42:14 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 8:42:14 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 8:42:14 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 9:16:51 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 9:16:51 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 9:16:51 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 9:17:01 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 9:17:01 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 9:17:01 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 9:17:17 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 9:17:17 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 9:17:17 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 9:22:29 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 9:22:30 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 9:22:30 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 9:27:12 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 9:27:12 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 9:27:12 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 9:30:15 AM EDT] WARN RESTFilter Error in REST API: EofException
[10/20/19 9:30:16 AM EDT] ERROR JAXBWriter Failed to marshal JAXB
[10/20/19 9:30:16 AM EDT] ERROR RESTFilter Failed to write error response.
[10/20/19 10:19:24 AM EDT] INFO NetworkService Successfully forwarding port 4040.
Last edited by ian41t on Sun Oct 20, 2019 3:18 pm, edited 1 time in total.
ian41t
 
Posts: 4
Joined: Sun Oct 20, 2019 2:05 am

Re: Troubleshooting streaming when no on wifi

Postby ian41t » Sun Oct 20, 2019 3:13 pm

I should add that I don't have any active firewall...that I know about.
ian41t
 
Posts: 4
Joined: Sun Oct 20, 2019 2:05 am

Re: Troubleshooting streaming when no on wifi

Postby G8DHE » Sun Oct 20, 2019 3:17 pm

What about the firewall between your router and the Internet connections, have you set up port forwarding on there?
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 66
Joined: Sun Nov 04, 2012 4:56 pm

Re: Troubleshooting streaming when no on wifi

Postby ian41t » Sun Oct 20, 2019 3:55 pm

G8DHE wrote:What about the firewall between your router and the Internet connections, have you set up port forwarding on there?


Thanks for the reply. Yes. I have a static IP set up for the computer that I'm running Subsonic on. I have forwarded port 4040 to that IP, however I'm only given the option of using TCP/UDP for the port forwarding. Subsonic suggests using UPnP or NAT-PMP. Not sure if that would make a difference.

The problem with the router is that I'm on Comcast and they are telling me I need to use an iOS app to login to the router. The login/pass isn't working at 10.0.0.1. I'm trying to get them to do a factory reset, because I know I have access to more network settings through the 10.0.0.1 login.

canyouseeme.org is showing that I am open, however before I was not. I'm going to try again with my phone off of wifi. Fingers crossed.
ian41t
 
Posts: 4
Joined: Sun Oct 20, 2019 2:05 am

Re: Troubleshooting streaming when no on wifi

Postby ian41t » Sun Oct 20, 2019 4:03 pm

Didn't do anything, but the port forwarding opened up and now I'm good off of wifi. So I think this is working.

One other question. For sharing with other people, do I create a guest account and then share my subsonic URL? Or I see an option for internet radio...is that to create a streaming station from my library?
ian41t
 
Posts: 4
Joined: Sun Oct 20, 2019 2:05 am


Return to Help

Who is online

Users browsing this forum: No registered users and 6 guests