Lost ability to create a new public link

Need help? Post your questions here.

Moderator: moderators

Lost ability to create a new public link

Postby malebron » Tue Jul 28, 2020 2:17 am

I seem to have lost the ability to create a public link.

Other than that everything is working well, and has been for a couple of years. Existing public links can be seen under SHARED MEDIA & still work. The Android app works (both locally and remote via web). My PREMIUM subscription is up to date
The last time I had to do this (a month or so ago) it seemed intuitive. Now I can't see any way to create a new one.

What is the procedure to create a public link? (I'm unable to find this on the web) I vaguely remember a menu with options - none visible now.

Could something be preventing this capability from being displayed? If so, where to look for a resolution?

Thanks!

<-------------------------Subsonic Help Request---------------------->
Problem Description: No obvious way to create a new public shared link
Troubleshooting Steps: Rebooted. Upgraded to latest Subsonic 6.1.6
Playback Application and version: Standard Subsonic web interface
Subsonic Version: 6.1.6 (build 0cfa60) – November 10, 2019
Server Version: jetty-6.1.x, java 1.8.0_151, HSQLDB, Linux (76.0 MB / 141.0 MB)
Hardware Platform: Fedora Linux (running Amahi hda, headless) 4.13.16-100.fc25.x86_64 ,x86_64
Java Memory Limit: N/A
Problem Filename: N/A
Output from ffmpeg -i: N/A
Last ten log file lines:
[7/27/20 3:00:49 AM PDT] INFO MediaScannerService Scanned media library with 16139 entries.
[7/27/20 3:00:49 AM PDT] INFO MediaScannerService Marking non-present files.
[7/27/20 3:00:49 AM PDT] INFO MediaScannerService Marking non-present artists.
[7/27/20 3:00:49 AM PDT] INFO MediaScannerService Marking non-present albums.
[7/27/20 3:00:49 AM PDT] INFO MediaScannerService Completed media library scan.
[7/27/20 3:00:49 AM PDT] INFO PlaylistService Starting playlist import.
[7/27/20 3:00:49 AM PDT] INFO PlaylistService Completed playlist import.
[7/27/20 11:36:38 AM PDT] INFO PodcastService Starting scheduled Podcast refresh.
[7/27/20 11:36:38 AM PDT] INFO PodcastService Completed scheduled Podcast refresh.
<-------------------------Subsonic Help Request---------------------->
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am

Re: Lost ability to create a new public link

Postby 3Dscrewer » Wed Jul 29, 2020 12:28 pm

Can you please specify what you get if you try to share the link and what happend? Best, post a link to a test share, that is not working, or by PN

At newer Android devices you will get probably only a black screen, solution switch the browser to desktop mode and it will work.
Even if subsonic will work without port after the URL, it seems that the share link must have the port.
Are you using the subsonic domain, or your own DDNS Service? If using your own domain you must add the port behind the domain
3Dscrewer
 
Posts: 177
Joined: Tue Feb 13, 2018 1:11 pm

Re: Lost ability to create a new public link

Postby malebron » Wed Jul 29, 2020 7:00 pm

Thanks @3Dscrewer for taking the time to reply. Unfortunately you have misunderstood my problem. It has nothing to to with links working or not working.

My problem is that using the standard Subsonic web UI, while logged in as admin, I can no longer see any menu or link which will enable me to create a new public link.

I have created links in the past, and those links still work. I remember it being obvious and intuitive, but can no longer see any way to do it.

Maybe those menus are only available if certain things are true? (file permissions??) Or have I just forgotten how to do it - I can't find any documentation which covers this.

Very frustrating!

THANKS!

(If it matters, yes, I am using the Subsonic domain "myname.subsonic.org". Works great!)
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am

Re: Lost ability to create a new public link

Postby G8DHE » Wed Jul 29, 2020 9:51 pm

If you look at the bottom of your current playing list on the lowest line is a Share link!
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 87
Joined: Sun Nov 04, 2012 4:56 pm

Re: Lost ability to create a new public link

Postby malebron » Wed Jul 29, 2020 10:58 pm

Thanks @G8HDE - That's what I remember. Thanks for proving I'm not going crazy!

Trouble is, there's no share link there now! This is my problem. Where has it gone, and why?

If I knew how, I'd share a screenshot.
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am

Re: Lost ability to create a new public link

Postby 3Dscrewer » Thu Jul 30, 2020 7:39 am

Oh sorry, englisch is not my nativ language.

I would try to create a testuser like admin2 and activate all checkboxes or only
User allowed to share files with anyone
If that is working I would try to change the password of the admin, may be you can disable the Media Folders temporarily too, I guess that will rewrite the database for the admin, since you can't delete admin I don't see another way.

If that don't fix it, at last you can use admin2 as work around.
3Dscrewer
 
Posts: 177
Joined: Tue Feb 13, 2018 1:11 pm

Re: Lost ability to create a new public link

Postby G8DHE » Thu Jul 30, 2020 9:44 am

Its at the bottom of the scroll listing itself not the bottom line of the screen that doesn't scroll, you just tick the boxes and hit Share.
Image
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 87
Joined: Sun Nov 04, 2012 4:56 pm

Re: Lost ability to create a new public link

Postby malebron » Thu Jul 30, 2020 6:03 pm

Thanks @G8HDE - My UI looks like this, but the Share link is missing on my screen.
(Are there instructions somewhere for how to post an image?)

This explains why it seemed so obvious to me in the past.

Can anyone tell me what determines whether the "Share" link is displayed? Something in my system must have changed (maybe an update to other software?), but I don't know where to look...



Thanks for the suggestion @3Dscrewer. I'll give that a try.
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am

Re: Lost ability to create a new public link

Postby malebron » Thu Jul 30, 2020 6:27 pm

UPDATE
@3Dscrewer - creating "admin2" with permission to share files does work. Thanks for the workaround!

However even as administrator "admin2" only has a subset of functionality of "admin" - so it's not a replacement.

The other suggestions did not restore the share link for "admin".

Perhaps the equivalent permissions for "admin" are available in a configuration file somewhere? (they cannot be changed in the GUI)
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am

Re: Lost ability to create a new public link

Postby 3Dscrewer » Fri Jul 31, 2020 9:46 am

Subsonic is using H(yper)SQL Database. There might be an error at the admin table, but I don't know how to use SQL Databases
There is also the possibility that your HDD has a bad block. Disabling automatic scan was the first thing I have done, because huge discload. Even if I have added a couple of albums and forget to scan, I can do that from my iOS Apps.

A short research, I found this
HSQL has built-in GUI query tool called Database manager. In the directory of the database files run:
java -cp ../lib/hsqldb.jar org.hsqldb.util.DatabaseManager
Finding the right values I don't know.

On the other hand there is a folder db.backup but this will be over written from time to time, so there might be also the damaged table.
What I would try, renaming the db folder, create a new db folder, copy all files of the renamed folder to db and overwrite with backup. Test if your settings ok again. Eventually try to force a rewrite of the admin table as mentioned above, PWD, Media Folder ...
I have also a Useraccount with admin rights, I have compared the settings and didn't find any difference to the admin account.

Unfortunately I have no more ideas ...

Forgett what I wrote above ....

The settings for the user and also admin are in /db/subsonic.script
The Value for sharing is 11
so you have to look for this

INSERT INTO ROLE VALUES(1,'admin')
INSERT INTO ROLE VALUES(2,'download')
INSERT INTO ROLE VALUES(3,'upload')
INSERT INTO ROLE VALUES(4,'playlist')
INSERT INTO ROLE VALUES(5,'coverart')
INSERT INTO ROLE VALUES(6,'comment')
INSERT INTO ROLE VALUES(7,'podcast')
INSERT INTO ROLE VALUES(8,'stream')
INSERT INTO ROLE VALUES(9,'settings')
INSERT INTO ROLE VALUES(10,'jukebox')
INSERT INTO ROLE VALUES(11,'share')
INSERT INTO ROLE VALUES(12,'video_conversion')


INSERT INTO USER_ROLE VALUES('admin',1)
INSERT INTO USER_ROLE VALUES('admin',2)
INSERT INTO USER_ROLE VALUES('admin',3)
INSERT INTO USER_ROLE VALUES('admin',4)
INSERT INTO USER_ROLE VALUES('admin',5)
INSERT INTO USER_ROLE VALUES('admin',6)
INSERT INTO USER_ROLE VALUES('admin',7)
INSERT INTO USER_ROLE VALUES('admin',8)
INSERT INTO USER_ROLE VALUES('admin',9)
INSERT INTO USER_ROLE VALUES('admin',10)
INSERT INTO USER_ROLE VALUES('admin',11)
INSERT INTO USER_ROLE VALUES('admin',12)

There is also a backup version of subsonic.script in db.backup
Try to compare the values. The script is updated very often, may be a read,write error has altered some values ...
3Dscrewer
 
Posts: 177
Joined: Tue Feb 13, 2018 1:11 pm

Re: Lost ability to create a new public link

Postby malebron » Mon Aug 10, 2020 2:38 am

Thanks @3Dscrewer. This definitely looks like part of the problem.

When I check subsonic.script, for user 'admin', the values 11 and 12 are not present. (They are there for user 'admin2' - which correctly allows sharing).

I can edit subsonic.script and add the lines. (I double-check that my changes are saved correctly!). However when I restart Subsonic the file reverts to the previous version and my changes are lost.

It looks like subsonic.script may be re-written on startup, based on values stored elsewhere??

Any ideas?
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am

Re: Lost ability to create a new public link

Postby 3Dscrewer » Mon Aug 10, 2020 9:09 am

In db.backup is also a copy of subsonic.script.
In my opinion there are two possibilities. The first, rename the script in db.backup, the second, all files in db folder having the same date and time, except *.log and *.lck. May be if you change date and time after editing back to same date, will help.
An easy way to alter date and time is Total Commander, I'm doing that from time to time when I have modified only the tags of some tracks and subsonic don't scan it again, then I set files and folder to actual date and subsonic is scanning it as new album. Total Commander is very useful to rename multiple files in one batch, you need a time to find all features, but I can't live without it :) it is shareware, but you can use it a couple of time hitting a button (nagscreen).
https://www.ghisler.com/index.htm

Hope that is helping
3Dscrewer
 
Posts: 177
Joined: Tue Feb 13, 2018 1:11 pm

Re: Lost ability to create a new public link

Postby malebron » Mon Aug 10, 2020 6:18 pm

I stopped Subsonic. Renamed all versions of subsonic.script, including the ones in backup. Then restarted Subsonic.

On startup, subsonic.script was re-created with all the old values. It looks like this file is an output of the process, not an input. The values must be stored elsewhere (the database??). If so, I don't know how to even read it, let alone edit. It's frustrating that the web GUI allows you to set these values for every user except 'admin'.

I'm not clear what changing the date and time is intended to achieve, but in any case I can't use Total Commander since I am running Subsonic on Fedora Linux in headless mode - command line only.

Appreciate the help.
malebron
 
Posts: 7
Joined: Tue Jul 28, 2020 1:44 am


Return to Help

Who is online

Users browsing this forum: No registered users and 5 guests