New Install but Folder Not Found

Need help? Post your questions here.

Moderator: moderators

New Install but Folder Not Found

Postby SubAshton » Sun Aug 09, 2020 4:12 pm

Hey everyone,
I'm new to Subsonic. Searched on forum but could not find answers.

I just installed Subsonic on Mac and i keep getting Folder Not Found. I logged in as admin on web local server. I put the correct folder path (double checked in terminal). However, it keeps saying folder not found. I also add Subsonic.app to full disk access in mac system preference.

Mac version: MacOS Catalina 10.15.5
Subsonic is the newest

How can i solve this issue?
Really appreciate your help!
SubAshton
 
Posts: 3
Joined: Sun Aug 09, 2020 3:47 pm

Re: New Install but Folder Not Found

Postby G8DHE » Mon Aug 10, 2020 9:09 am

It normally comes down to the fact that the Subsonic application is running under an account that doesn't have access to those files. Whilst your logged in as Admin, that isn't to say Subsonic is running under the Admin account, check which account it is running under and make sure that account has access.
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 91
Joined: Sun Nov 04, 2012 4:56 pm

Re: New Install but Folder Not Found

Postby SubAshton » Mon Aug 10, 2020 1:26 pm

G8DHE wrote:It normally comes down to the fact that the Subsonic application is running under an account that doesn't have access to those files. Whilst your logged in as Admin, that isn't to say Subsonic is running under the Admin account, check which account it is running under and make sure that account has access.


Hi, thx a lot for your reply.
I have checked that Subsonic is running under my user name which does have read and write access to my music folder.
Any fix on this?

Appreciate!
SubAshton
 
Posts: 3
Joined: Sun Aug 09, 2020 3:47 pm

Re: New Install but Folder Not Found

Postby 3Dscrewer » Mon Aug 10, 2020 3:34 pm

what says the logfile? So far I know .. it should be there
/Library/Application Support/Subsonic

or have a look at about Subsonic and scroll down, there is also the path to the log file.
3Dscrewer
 
Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm

Re: New Install but Folder Not Found

Postby SubAshton » Tue Aug 11, 2020 2:05 pm

3Dscrewer wrote:what says the logfile? So far I know .. it should be there
/Library/Application Support/Subsonic

or have a look at about Subsonic and scroll down, there is also the path to the log file.


Hello and thx for the reply.
If i open the log file located at /Library/Application Support/Subsonic, I see most contents like the following:

Code: Select all
/*C1*/SET SCHEMA PUBLIC
CONNECT USER SA
DISCONNECT


If i check logs on local web:

Code: Select all
[8/11/20 9:44:47 PM CST]   INFO   HsqlDaoHelper   Checking database schema.
[8/11/20 9:44:48 PM CST]   INFO   HsqlDaoHelper   Done checking database schema.
[8/11/20 9:44:48 PM CST]   INFO   SettingsService   Java: 1.8.0_131, OS: Mac OS X
[8/11/20 9:44:48 PM CST]   INFO   MediaScannerService   Automatic media library scanning scheduled to run every 1 day(s), starting at Wed Aug 12 03:00:00 CST 2020
[8/11/20 9:44:48 PM CST]   INFO   UPnPService   Starting UPnP service...
[8/11/20 9:44:48 PM CST]   INFO   PodcastService   Automatic Podcast update scheduled to run every 24 hour(s), starting at Tue Aug 11 21:49:48 CST 2020
[8/11/20 9:44:48 PM CST]   INFO   UPnPService   Disabling UPnP/DLNA media server
[8/11/20 9:44:48 PM CST]   INFO   UPnPService   Starting UPnP service - Done!
[8/11/20 9:44:58 PM CST]   INFO   NetworkService   Deleted port mapping for port 4040
[8/11/20 9:45:06 PM CST]   INFO   BootstrapVerificationFilter   Servlet container: jetty-6.1.x
[8/11/20 9:45:09 PM CST]   INFO   VersionService   Resolved local Subsonic version to: 6.1.6
[8/11/20 9:45:09 PM CST]   INFO   PlayerDao   Created player 3.
[8/11/20 9:45:10 PM CST]   INFO   VersionService   Resolved latest Subsonic final version to: 6.1.6
[8/11/20 9:45:10 PM CST]   INFO   VersionService   Resolved latest Subsonic beta version to: 6.1.beta2
[8/11/20 9:49:48 PM CST]   INFO   PodcastService   Starting scheduled Podcast refresh.
[8/11/20 9:49:48 PM CST]   INFO   PodcastService   Completed scheduled Podcast refresh.
[8/11/20 9:52:15 PM CST]   INFO   MediaScannerService   Automatic media library scanning scheduled to run every 1 day(s), starting at Wed Aug 12 03:00:00 CST 2020
[8/11/20 9:52:18 PM CST]   INFO   MediaScannerService   Starting to scan media library.
[8/11/20 9:52:18 PM CST]   INFO   MediaScannerService   Scanned media library with 0 entries.
[8/11/20 9:52:18 PM CST]   INFO   MediaScannerService   Marking non-present files.
[8/11/20 9:52:18 PM CST]   INFO   MediaScannerService   Marking non-present artists.
[8/11/20 9:52:18 PM CST]   INFO   MediaScannerService   Marking non-present albums.
[8/11/20 9:52:18 PM CST]   INFO   MediaScannerService   Completed media library scan.
[8/11/20 9:52:18 PM CST]   INFO   PlaylistService   Starting playlist import.
[8/11/20 9:52:18 PM CST]   INFO   PlaylistService   Completed playlist import.


In addition, I uninstalled Subsonic and re-installed. Checked in terminal that Subsonic.app is installed as :
drwxr-xr-x 3 root admin Subsonic.app

Any suggestions?
Thanks
SubAshton
 
Posts: 3
Joined: Sun Aug 09, 2020 3:47 pm

Re: New Install but Folder Not Found

Postby 3Dscrewer » Wed Aug 12, 2020 6:47 am

I can only guess what happens, but it seems that subsonic is scanning an empty folder ....
Or your Music is not archived in this style artist/album/song ....
Since I'm not familiar with Mac OS I have no other Idea, may be there is something in a system log, that shows a problem, but it seems it is not subsonic causing the failure
3Dscrewer
 
Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 21 guests