refused to connect

Need help? Post your questions here.

Moderator: moderators

refused to connect

Postby almal100 » Thu Aug 20, 2020 8:00 am

Hi

I set up subsonic yesterday in Windows 10 and was connecting fine through the Dsub android app, however, this morning i am unable to connect. I've tried several browsers and i just get a message which is either "[IP address] refused to connect" or "localhost refused to connect". the Subsonic control panel states "Running. Auto-start." and no error message

i've tried restarting it and i've checked and the static IP and port forwarding i set up are still in place. and the firewall is still allowing subsonic through.

i realise there's probably a million things that could cause this, but i am new to this and don't really know where to start, so any help would be appreciated
almal100
 
Posts: 6
Joined: Thu Aug 20, 2020 7:48 am

Re: refused to connect

Postby 3Dscrewer » Thu Aug 20, 2020 9:18 am

That's not so much information
you are using that string and couldn't connect?

http://localhost:4040/login.view?

Are you using http://yourname.subsonic.org for external access, or using your own DDNS Service, or using simply the IP you have received from your provider?
using something like http://80.80.80.80:4040 might be changing over night and you have to use the new IP
also in most cases you MUST use http:// in front, otherwise the browser will always try https:// and will fail ...
If using http:// in front, your browser might come up with a warning, you have to look for something like extended setting and ignore warning
3Dscrewer
 
Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm

Re: refused to connect

Postby almal100 » Thu Aug 20, 2020 9:35 am

thanks for the reply, apologies for the lack of info.

yes, i'm using http://localhost:4040/login.view as well as http://yourname.subsonic.org, which translates in the address bar into http://[IPaddress]:4040

i'll try making sure i use the http:// and see if that helps

thanks again
almal100
 
Posts: 6
Joined: Thu Aug 20, 2020 7:48 am

Re: refused to connect

Postby 3Dscrewer » Thu Aug 20, 2020 10:00 am

I don't use the subsonic DDNS but I'm reading often that the service is not reliable.
I suggest to use an external DDNS, like dnsomatic, dyndns or similar. you can use both at same time, so if one is not working, try the other one.
A lots of routers have an option for DDNS Services, if your Router doesn't try Marcs Updater a software that is checking for IP changes, a lot of DDNS Services are pre configured.
3Dscrewer
 
Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm

Re: refused to connect

Postby almal100 » Thu Aug 20, 2020 10:44 am

i'll try that, thanks

it seems like when i restart my laptop, it works for a short period of time, but then after half an hour or so. it just loses the connection and the subsonic-service process is having really high CPU usage. Restarting the service doesn't help, only restarting the whole system. any ideas?
almal100
 
Posts: 6
Joined: Thu Aug 20, 2020 7:48 am

Re: refused to connect

Postby 3Dscrewer » Thu Aug 20, 2020 1:45 pm

I don't know the reason for high cpu usage.
May be defender is the reason or the firewall. In my case I have setup the firewall manual in extended mode, picking the pathes to the three subsonic exe in program files (X86) subsonic.
also scanning the music files the first time will cause huge cpu load, even more if you don't exclude music files in defender because it is touching every file that will be read.

at least, wait a time and have a look if cpu load will be lower
3Dscrewer
 
Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm

Re: refused to connect

Postby Patrikc325 » Sun Aug 30, 2020 1:41 am

I just started not being able to connect.
My Port forwarding looks good.
Status: Successfully forwarding port 4040
Status: Could not connect to patrikc.subsonic.org. (NoRouteToHostException)

Any ideas on what went wrong.

Desktop
Windows 10
Patrikc325
 
Posts: 6
Joined: Tue Jul 30, 2013 1:17 pm

Re: refused to connect

Postby alphawave7 » Sun Aug 30, 2020 3:47 am

Go to canyouseeme.org and test for port 4040. If this fails, it will fail for the redirect server (.subsonic.org) too, and indicates your router needs to be manually configured to open port 4040. Once configured, re-test with canyouseeme.
alphawave7
 
Posts: 1037
Joined: Thu Feb 11, 2010 9:54 am


Return to Help

Who is online

Users browsing this forum: Bing [Bot] and 10 guests