Issue with Subsonic URL ( Public IP Address Works)[Solved]

Need help? Post your questions here.

Moderator: moderators

Issue with Subsonic URL ( Public IP Address Works)[Solved]

Postby charlie.brush » Wed Feb 08, 2012 4:29 am

Problem Description:

I can't access my Subsonic URL remotely unless I use the Public IP Address, but I
think this changes frequently since I have residential Comcast service. Plus, I
would like for the regular URL to work for easy remote access.

Troubleshooting Steps:

I have tried using different ports (i.e. 4040 and 4444) and forwarding them on my
Netgear Router (WNDR3700), but this didn't help. I ran netstat and the Port isn't
listed though, so that could be part of the issue. My router has the latest
Firmware and UPnP is enabled. I tried accessing the URL via the regular address and
then :4444 (or one of the other ports I tried using with the Subsonic Music
Streamer on my System Tray).

When I go to Network | Settings and click "Save" I receive this error message...
Status: username.subsonic.org is registered, but could not connect to it.
(ConnectTimeoutException)

Note: username = my Subsonic Username which I changed on this post for security reasons.

I tried using a differnet server "name" before .subsonic.org and it registered, but
had the same error as above.
When trying to use a fifferent server name, I did the following in Settings |
Network...
I unchecked both boxes, waited a few seconds, re-checked them, and then clicked on
"Save."

I reset my Router to the Factory Defaults, but this didn't help.

I connected my PC directly to my modem, bypassing my router, but this didn't help
either.

I connected to an external computer outside of my network to do the external
testing all along. After all of this, I was still able to access Subsonic via the
Public IP Address, but not the same, so it appears that something is wrong with
DNS. On the external computer where I was able to access Subsonic via the Public IP
Address, I pinged my full Subsonic Server name and it returned with a different IP
Address, which I thought was kinkd of strange. I am not going to call Comcast ISP
Support, since they won't be keen on me using my PC as a streaming music server.

--------

Playback Application and version:

Google Chrome (latest), but same issue in Firefox and IE.

Server Version:

4.6 (build 2583) – December 6, 2011

Java Memory Limit:

100 MB

--------

Thanks for any help/suggestions!

Charlie
charlie.brush
 
Posts: 5
Joined: Wed Feb 08, 2012 2:40 am

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby GJ51 » Wed Feb 08, 2012 8:44 am

You may be trying to use a name that someone else has already registered. Try a different name.
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3500
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby gurutech » Thu Feb 09, 2012 12:31 am

I believe the latest version is 4.6, build 2585. That's what I'm running. Try upgrading to that, and also check your port forwarding. Give the host machine on your network a "reserved IP address", so it will always obtain the same IP from the DHCP server/router, then port forward from the router to that IP address.

Also, are you using any form of dynamic DNS service, such as dyndns, or no-ip? If so, you will need to make sure that is set up correctly as well. With no-ip, the feature is called a "port 80 redirect", which will allow you to only type the name of the site (example: myhost.mymusic.com), and it will automatically forward to your public IP address, on port 4040 (or which ever you have Subsonic on).
Image
gurutech
 
Posts: 472
Joined: Sun Jan 15, 2012 9:56 pm

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby charlie.brush » Sat Feb 11, 2012 4:26 pm

I have already trying a different name and am already port forwarding, although I will try another name.
Here's my port forwarding (images below), so if these don't look right, please let me know...

http://dl.dropbox.com/u/12994534/portforward.JPG

I used my PC's internal IP Address for the forwarding address and I changed the port to 4444 on my Subsonic Music app on the system tray and then restarted the Service (see image below).
http://dl.dropbox.com/u/12994534/Subsonic.JPG

I am running the latest version.

Thanks for any help, as this is driving me crazy!

Charlie
Last edited by charlie.brush on Sat Feb 11, 2012 5:07 pm, edited 1 time in total.
charlie.brush
 
Posts: 5
Joined: Wed Feb 08, 2012 2:40 am

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby GJ51 » Sat Feb 11, 2012 5:00 pm

go to http://canyouseeme.org to test that your port is really open. 99% of this type of problem is due to port forwarding not set up properly.
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3500
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby charlie.brush » Sat Feb 11, 2012 5:10 pm

GJ51 wrote:go to http://canyouseeme.org to test that your port is really open. 99% of this type of problem is due to port forwarding not set up properly.


Gary, thanks for the reminder about this website. I may have forgotten to mention that this didn't work when I previously typed my port on this website, as here is the response...

Error: I could not see your service on 67.189.110.226 on port (4444)
Reason: Connection timed out

I have tried several different ports and then re-started the Subsonic Service.

I have also tried temporarily turning off my Windows Firewall since adding the Port Exceptions didn't help.

>>>>

Update: OK, I just realized my Internal IP Address was different than the one I forwarded in my router so I made a static IP address in the network settings of my LAN connection and then changed the forwarding port on my router. I re-ran the port forwarding test on http://canyouseeme.org and not it's open. So, I will try accessing my public Subsonic URL (by name) soon from an external network connection.
charlie.brush
 
Posts: 5
Joined: Wed Feb 08, 2012 2:40 am

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby GJ51 » Sat Feb 11, 2012 7:01 pm

The port HAS to be open and forwarding correctly for you to connect from outside your network. You MUST make it visible from canyouseeme or any other efforts will not fix the problem. Reread your router's manual, the instructions can often be a bit obtuse and unfortunately all router interfaces are unique to each mfgr. Occasionally we have seen instances where the router needs to be rebooted in order for the settings to take effect. Be certain, however that you will not make any progress until the port can be seen from canyouseeme.

If your on Windows (and even if your not) here is some detailed setup information that may help:

viewtopic.php?f=6&t=4867
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3500
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby charlie.brush » Sat Feb 11, 2012 9:02 pm

GJ51 wrote:The port HAS to be open and forwarding correctly for you to connect from outside your network. You MUST make it visible from canyouseeme or any other efforts will not fix the problem. Reread your router's manual, the instructions can often be a bit obtuse and unfortunately all router interfaces are unique to each mfgr. Occasionally we have seen instances where the router needs to be rebooted in order for the settings to take effect. Be certain, however that you will not make any progress until the port can be seen from canyouseeme.

If your on Windows (and even if your not) here is some detailed setup information that may help:

viewtopic.php?f=6&t=4867


----

Thanks, like I said in my last message, the port is open now and I verified this on the canyouseeme website (after making my PC's IP Address settings Static).
I already power cycled my modem and then my router after setting my Static IP Address and unregistering/re-registering my Subsonic name on the web interface (also, I restarted the Subsonic Service).
I will try another name again, although the one I am using used to work.
I am a network consultant so know how to forward ports, but will check the manual, anyway.
The Public IP still works, so it still looks like some kind of DNS issue IMO.
Thanks for the link, I will check it out.
charlie.brush
 
Posts: 5
Joined: Wed Feb 08, 2012 2:40 am

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby GJ51 » Sat Feb 11, 2012 9:17 pm

The servername.subsonic.org names DO NOT use DNS. It is an http redirect service.

I guess you meant "NOW it's open" instead of "not it's open" which I read as it's not open. Sorry for the confusion.

I f the port is open and the name is available, go to Settings/Network and Save again and relay any response msg.

Your site is responding via SSL through port 80, but not on port 4444.

You have something wrong. Subsonic is designed to be called through the http name and then switch to SSL after the connection is made.

Disable SSL settings to first get everything working properly, then enable the SSL function. After it is enabled you still reach the site by HTTP://servername.subsonic.org - if you try using httpS://servername.subsonic.org it will fail. Once ss.org redirects the request to your site your server will then establish the SSL connection and switch to the SSL port defined.

HTH
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3500
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Re: Issue with Subsonic URL (only Public IP Address Works)

Postby charlie.brush » Sun Feb 12, 2012 6:16 pm

GJ51 wrote:The servername.subsonic.org names DO NOT use DNS. It is an http redirect service.

I guess you meant "NOW it's open" instead of "not it's open" which I read as it's not open. Sorry for the confusion.

I f the port is open and the name is available, go to Settings/Network and Save again and relay any response msg.

Your site is responding via SSL through port 80, but not on port 4444.

You have something wrong. Subsonic is designed to be called through the http name and then switch to SSL after the connection is made.

Disable SSL settings to first get everything working properly, then enable the SSL function. After it is enabled you still reach the site by HTTP://servername.subsonic.org - if you try using httpS://servername.subsonic.org it will fail. Once ss.org redirects the request to your site your server will then establish the SSL connection and switch to the SSL port defined.

HTH


Yes, I previously meant "now it's open" and not "not it's open", sorry for the confusion.

I disabled SSL Settings and then restarted the Subsonic Service. Then, I connected to one of my client's Servers and was able to connect to my Subsonic URL via http successfully via Internet Explorer.
Then, I re-enabled SSL and restarted the Subsonic Service. Then, I connected to 2 of my client's Servers and was able to connect to my Subsonic URL via https successfully via Internet Explorer.
That did the trick, thanks!

For some reason, Subsonic on my Android app doesn't work with https but still the Public IP Address, but maybe I will start another thread for that if I still can't get it to work.

Case closed!

BTW, I really like the Web Interface of Subsonic, it's nice and clean, and I like the list/detailed view, as opposed to Google Music, etc.
Plus, I don't have to worry about the Audio Tags like I do with Google Music and it seems to be organized on file/folder name rather than Audio Tags.
charlie.brush
 
Posts: 5
Joined: Wed Feb 08, 2012 2:40 am

Re: Issue with Subsonic URL ( Public IP Address Works)[Solve

Postby hillsnorway » Fri Feb 17, 2012 11:48 am

I have a similar problem:

I have set up my router (Linksys e4200) with portforwarding for port 4040 to the internal LAN IP for my Subsonic server.
My ISP assigns a dynamic WAN IP to my router. Periodically (f.eks. if my router is disconnected from the internett for a period of time) I end up with a new WAN IP.

Whenever this happens I have problems using the xxxxx.subsonic.org address the subsonic box is set up to use (it points me to the old WAN IP, not the new one).
I can always connect if I manually navigate to "http://WAN_IP:4040".

Oddly enough, if I just switch to another domain alias (change the xxxxx part in xxxxx.subsonic.org), the adress lookup functionality works again, and the new domain alias points to the correct WAN IP. This, however, is a pain -- then all the users have to update their clients to use a new domain alias.

I read somewhere that Sindre had said the domain forwarding info (I'm assuming the IP & port # looked up for a particular alias) gets updated every 120 minutes. However, in my experience this is not the case.

I've also read other places that disabling and re-enabling the Network Settings for port forwarding (UPnP NAT-PMP) and domain forwarding (the xxxxx.subsonic.org alias) is supposed to trigger an update. This has not worked for me either.

Can anyone shed any light on this for me?
hillsnorway
 
Posts: 5
Joined: Fri Feb 17, 2012 10:54 am

Re: Issue with Subsonic URL ( Public IP Address Works)[Solve

Postby BKKKPewsey » Fri Feb 17, 2012 4:59 pm

If you go to settings/network - and just hit save this will update your SS.org address.
The status message will alert you if there is a problem.
:mrgreen:
Everyone is entitled to be stupid, Image but some abuse the privilege!

Due to the confusion from too many genres of music, we have decided to put both country music and rap music into the genre of Crap music.
User avatar
BKKKPewsey
 
Posts: 2115
Joined: Mon May 23, 2011 12:16 pm
Location: United Kingdom

Re: Issue with Subsonic URL ( Public IP Address Works)[Solve

Postby hillsnorway » Tue Feb 21, 2012 8:34 am

BKKKPewsey wrote:If you go to settings/network - and just hit save this will update your SS.org address.
The status message will alert you if there is a problem.
:mrgreen:


No, that doesn't work in my case.

I had testnas.subsonic.org working until a week ago. Then my DSL connection got reset (ISP had scheduled downtime, and after internet was online again I got a new WAN IP address). Since then I've been unable to get testnas.subsonic.org to work. When I browse to testnas.subsonic.org from my work PC it still resolves to the old WAN IP.

I am still able to connect to my subsonic but had to change to a new address (e.g. xxxxx.subsonic.org), this gets mapped to my new WAN-IP. I can also connect directly using http://WAN-IP:4040.

It seems to me that for some reason the address testnas.subsonic.org won't release its binding to the old IP - not sure why.

- Hillsnorway
hillsnorway
 
Posts: 5
Joined: Fri Feb 17, 2012 10:54 am

Re: Issue with Subsonic URL ( Public IP Address Works)[Solve

Postby GJ51 » Tue Feb 21, 2012 8:57 am

What msg. do you get when you go to Settings/Network and hit Save after the ip has changed?
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3500
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Re: Issue with Subsonic URL ( Public IP Address Works)[Solve

Postby MJRajs » Wed Feb 29, 2012 8:49 pm

In subsonic change your desired domain name. Save it. Restart. Go back in and change it back...
MJRajs
 
Posts: 4
Joined: Wed Sep 21, 2011 1:16 pm


Return to Help

Who is online

Users browsing this forum: Bing [Bot] and 4 guests