Subsonic 6.1.beta1 released

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic 6.1.beta1 released

Postby tmwsiy » Thu Mar 16, 2017 3:21 pm

Alsaya wrote:Got the 503 problem, too, switched back to 6.0


I thought you couldn't downgrade. Was it easy to do?
tmwsiy
 
Posts: 173
Joined: Tue Apr 06, 2010 6:26 pm

Re: Subsonic 6.1.beta1 released

Postby Tak-MK » Thu Mar 16, 2017 3:24 pm

tmwsiy wrote:
Alsaya wrote:Got the 503 problem, too, switched back to 6.0


I thought you couldn't downgrade. Was it easy to do?

I downgraded too, and nope, I needed to do a clean installation of v6.
User avatar
Tak-MK
 
Posts: 69
Joined: Thu Dec 22, 2016 3:27 pm

Re: Subsonic 6.1.beta1 released

Postby Alsaya » Thu Mar 16, 2017 8:48 pm

I saved my database but I got Errors now, still trying
Subsonic on Server 2012, only flac
Image
Alsaya
 
Posts: 56
Joined: Thu Feb 04, 2010 2:46 pm

Re: Subsonic 6.1.beta1 released

Postby pdcorcoran » Fri Mar 17, 2017 12:39 am

Pretty much noticed the slow database rescans in the 6.1 beta. When I first updated, none of my album covers showed up, so I did rescan of the database, which took hours for c. 80,000 songs. The album covers then appeared as they should. Subsequent rescans (scheduled daily at 0300) and the one I started a few minutes ago are also taking a long time.

No other issues with the beta so far.

Despite the database issue, which I have confidence will get resolved, thank you Sindre for a great application.
pdcorcoran
 
Posts: 19
Joined: Mon May 11, 2009 1:52 am

Re: Subsonic 6.1.beta1 released

Postby Alsaya » Fri Mar 17, 2017 8:38 am

Complete new install of 6.0 and then the copy of the working installation did it.
Subsonic on Server 2012, only flac
Image
Alsaya
 
Posts: 56
Joined: Thu Feb 04, 2010 2:46 pm

Re: Subsonic 6.1.beta1 released

Postby sindre_mehus » Fri Mar 17, 2017 7:05 pm

Well, the upgrade to HSQLDB 2.3.4 doesn't seem to be a big success, so I will have to revert that.

Please hold on to your database backup as you will need it later.

As always, thanks a lot for your feedback!

Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1937
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 6.1.beta1 released

Postby JimGilliland » Fri Mar 17, 2017 10:09 pm

I'm seeing the same thing - rescanning the library is taking a ridiculous length of time to complete. I'm really regretting installing the beta.

When I first installed 6.1, the result was a completely unusable system. Cover art disappeared, and most of the library couldn't be played at all. It showed up, but when you clicked on a song, nothing happened.

So I deleted the database and let subsonic rebuild it. That solved the big problems. Cover art came back, and everything plays. The first scan to build the new database took about 18 hours, but I expected that.

Tonight I added some new music to the library, 15-20 new albums, so not a huge addition. But when I initiated the "Scan Media Folders", it ran very slowly. Normally, under Subsonic 6.0, it would take around 5 minutes to complete. But the current scan has been running for well over an hour, and it appears to be between 15 and 20 percent complete at this point. So a very crude estimate suggests that it is running more than 50 times slower than under 6.0. That estimate is not intended to be at all precise, but it does show that the difference in scan performance is huge.

At the moment the log file is about 4MB and growing quickly - it reached 6MB by the time I finished writing this sentence. The entire log consists of entries like this tiny extract:

/*C3250676*/SET SCHEMA PUBLIC
DELETE FROM ARTIST WHERE ID=449
INSERT INTO ARTIST VALUES(449,'The Who','D:\Rock\The Who\Join Together\cover.jpg',17,'2017-03-17 16:16:26.000000',TRUE,1)
COMMIT
DISCONNECT
/*C3250677*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250678*/SET SCHEMA PUBLIC
DELETE FROM MEDIA_FILE WHERE ID=29708
INSERT INTO MEDIA_FILE VALUES(29708,'D:\Rock\The Who\Who''s Next Deluxe Edition (Disc 1)','D:\Rock','ALBUM',NULL,NULL,'Who''s Next: Deluxe Edition (Disc 1)','The Who',NULL,NULL,NULL,2003,'Rock',NULL,FALSE,NULL,NULL,NULL,NULL,'D:\Rock\The Who\Who''s Next Deluxe Edition (Disc 1)\cover.jpg','D:\Rock\The Who',0,NULL,NULL,'2014-05-23 20:51:10.630000','2014-05-23 20:51:10.630000','2017-03-17 16:16:26.000000','2014-05-23 20:51:10.630000',TRUE,5)
COMMIT
DISCONNECT
/*C3250679*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250680*/SET SCHEMA PUBLIC
DELETE FROM MEDIA_FILE WHERE ID=2952
INSERT INTO MEDIA_FILE VALUES(2952,'D:\Rock\The Who','D:\Rock','DIRECTORY',NULL,NULL,NULL,'The Who',NULL,NULL,NULL,NULL,NULL,NULL,FALSE,NULL,NULL,NULL,NULL,NULL,'D:\Rock',0,NULL,NULL,'2014-05-23 20:51:10.646000','2014-05-23 20:51:10.646000','2017-03-17 16:16:26.000000','2014-05-23 20:51:10.646000',TRUE,5)
COMMIT
DISCONNECT
/*C3250681*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250682*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250683*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250684*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250685*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250686*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250687*/SET SCHEMA PUBLIC
DELETE FROM ALBUM WHERE ID=1990
INSERT INTO ALBUM VALUES(1990,'D:\Rock\The Yardbirds\Ultimate (Disc 1)','Ultimate (Disc 1)','The Yardbirds',1,139,'D:\Rock\The Yardbirds\Ultimate (Disc 1)\cover.jpg',0,NULL,NULL,'2010-10-24 01:00:13.243000','2017-03-17 16:16:26.000000',TRUE,2001,'Rock',1)
COMMIT
DISCONNECT
/*C3250688*/SET SCHEMA PUBLIC
DISCONNECT
/*C3250689*/SET SCHEMA PUBLIC
DELETE FROM ARTIST WHERE ID=450
INSERT INTO ARTIST VALUES(450,'The Yardbirds','D:\Rock\The Yardbirds\Greatest Hits Vol. 1 1964-1966\cover.jpg',1,'2017-03-17 16:16:26.000000',TRUE,1)
COMMIT
DISCONNECT
/*C3250690*/SET SCHEMA PUBLIC
DELETE FROM MEDIA_FILE WHERE ID=30015
INSERT INTO MEDIA_FILE VALUES(30015,'D:\Rock\The Yardbirds\Ultimate (Disc 1)\03 - A Certain Girl (The Yardbirds).mp3','D:\Rock','MUSIC','mp3','A Certain Girl','Ultimate (Disc 1)','The Yardbirds','The Yardbirds',NULL,3,2001,'Rock',320,FALSE,139,5649805,NULL,NULL,NULL,'D:\Rock\The Yardbirds\Ultimate (Disc 1)',0,NULL,NULL,'2010-10-24 01:00:12.933000','2010-10-24 01:00:12.933000','2017-03-17 16:16:26.000000','1969-12-31 19:00:00.000000',TRUE,5)
COMMIT
DISCONNECT
JimGilliland
 
Posts: 9
Joined: Sun Mar 31, 2013 6:07 pm

Re: Subsonic 6.1.beta1 released

Postby JimGilliland » Sat Mar 18, 2017 2:39 am

It's now 5 hours later, and the scan is still running. It's probably between 80 and 90 percent complete at this point, after running for about 6 hours. So what once took 6-7 minutes now takes 6-7 hours. The library comprises a bit more than 100,000 songs, so it's not small.

Is it possible that there are tweaks to the DB parameters on the new version that could resolve this?

I'm really happy with the new search rules. In the old version, if I searched for, say, "Let It Be", I'd find dozens of songs that contain one or more of those words. It would never get far enough to actually find "Let It Be". In the new version, it finds exactly 10 versions of "Let It Be", and nothing more. That's a huge change for the better. Thanks!
JimGilliland
 
Posts: 9
Joined: Sun Mar 31, 2013 6:07 pm

Re: Subsonic 6.1.beta1 released

Postby tmwsiy » Sun Mar 19, 2017 12:44 am

Most of my library now missing and I can't scan. Does one track and quits.
tmwsiy
 
Posts: 173
Joined: Tue Apr 06, 2010 6:26 pm

Re: Subsonic 6.1.beta1 released

Postby guss77 » Sun Mar 19, 2017 3:13 pm

I've had some problems after upgrading, and as a result I nuked the settings and restarted from scratch.

Now I have the following problems:
1. I can't find the Last.fm settings in either the admin settings or the user settings
2. I don't see "play artist radio" button on the artist page - just the "Play top tracks".
3. I've added some folders in the Media Folders configuration, but only tracks from the first folder show up - when I chose any of the other folders in the Index or Home, they show up empty. I tried re-scanning a few times but that didn't help. I found a workaround though - I disabled the first folder, rescanned, made sure I now see tracks for the other folders in the index, re-enabled the main folder and now it works fine.

Lastly - I wanted to re-download the 6.1 beta, but can't find the link: the download page now shows only version 6.0.
guss77
 
Posts: 4
Joined: Sun Sep 18, 2016 1:37 pm

Re: Subsonic 6.1.beta1 released

Postby guss77 » Sun Mar 19, 2017 3:15 pm

guss77 wrote:Lastly - I wanted to re-download the 6.1 beta, but can't find the link: the download page now shows only version 6.0.


I just now saw Sindre's message about removing the link. Sorry for the noise.
guss77
 
Posts: 4
Joined: Sun Sep 18, 2016 1:37 pm

Re: Subsonic 6.1.beta1 released

Postby Soorploom » Sun Mar 19, 2017 5:20 pm

Aaaargh!! 6.1 Beta displays passwords in About Subsonic/Log for everyone to see.

Quickly back to 6.0.
Soorploom
 
Posts: 6
Joined: Fri Jul 22, 2011 11:27 am

Re: Subsonic 6.1.beta1 released

Postby JimGilliland » Tue Mar 21, 2017 3:54 am

Maybe I'm just obtuse, but I can't find any way to scroll the Play Queue in the new beta. If the queue is longer than the screen, I can't figure out a way to get to the bottom of it. Am I missing something? Somebody tell me what I'm doing wrong. :)
JimGilliland
 
Posts: 9
Joined: Sun Mar 31, 2013 6:07 pm

Re: Subsonic 6.1.beta1 released

Postby tmwsiy » Tue Mar 21, 2017 3:57 am

JimGilliland wrote:Somebody tell me what I'm doing wrong. :)


Probably nothing. The release had numerous issues and was pulled. Should never have been released.
tmwsiy
 
Posts: 173
Joined: Tue Apr 06, 2010 6:26 pm

Re: Subsonic 6.1.beta1 released

Postby gronkdalonka » Tue Mar 21, 2017 8:44 am

Probably nothing. The release had numerous issues and was pulled. Should never have been released.


That's why it's called a "beta", it may contain bugs ;)
gronkdalonka
 
Posts: 3
Joined: Sun Jan 29, 2017 11:40 am

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: Bing [Bot] and 1 guest