Subsonic 6.1.3 (pre-)released

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic 6.1.3 (pre-)released

Postby Alsaya » Mon Nov 06, 2017 9:56 pm

Works like a charm

Thank you Sindre
Subsonic on Server 2012, only flac
Image
Alsaya
 
Posts: 64
Joined: Thu Feb 04, 2010 2:46 pm

Re: Subsonic 6.1.3 (pre-)released

Postby DaveWut » Tue Nov 07, 2017 1:40 pm

Hey Sindre,

Since you are fixing bugs in this release, here's another one I recently found:
- Configure Subsonic to authenticate on LDAP.
- Login as an LDAP user.
- Logout and login as an admin to give this new user all admin rights
- Logout again and login again with that LDAP user
- Navigate a little
- Open a new Incognito tab (On Chrome, or a private browser tab on another browser)
- On the login page, ONLY type the username, leave the password field blank and then press enter on your keyboard.
- Once the page refreshes, you can see the message: "Wrong username or password." doesn't show up. Try to login with the username and password back and you won't be able. It seems like this breaks the authentication mechanisms.

Here's my setup:
Ubuntu Server 16.04 x64
Apache Tomcat/7.0.68 (Ubuntu), java 1.8.0_131, HSQLDB, Linux

The following valve has been added for my reverse proxy setup:
<Valve
className="org.apache.catalina.valves.RemoteIpValve"
internalProxies="*****"
remoteIpHeader="x-forwarded-for"
proxiesHeader="x-forwarded-by" />

Tomcat is listening on port 4040 and the connector has the following additional attributes:
proxyName="example.com"
proxyPort="443" scheme="https" secure="true"

Proxy server is running HA-Proxy version 1.6.3 2015/12/25
The following security headers are injected with all requests that goes through HAProxy:
Strict-Transport-Security "max-age=31536000; includeSubDomains; preload"
X-Frame-Options "SAMEORIGIN"
X-XSS-Protection "1; mode=block"
X-Content-Type-Options "nosniff"
Referrer-Policy "strict-origin-when-cross-origin"

Because Subsonic includes a lot of inline scripts and evals, it uses this header instead of the default configured one:
Content-Security-Policy "default-src https: data: blob:; script-src https: 'unsafe-inline' 'unsafe-eval'; style-src https: 'unsafe-inline'"

Thanks in advance for looking onto this problem.
David
User avatar
DaveWut
 
Posts: 57
Joined: Fri Nov 11, 2011 12:29 am

Re: Subsonic 6.1.3 (pre-)released

Postby hairbag » Tue Nov 07, 2017 10:12 pm

Thank you soooo much for this update!
The disappearing data issues seem to be fixed. After a full re-scan following the update I did some extensive file changing and moving today, everything showed as it should even without additional scans. I was about to jump ship so thank you for fixing this painful problem. :)
hairbag
 
Posts: 3
Joined: Sun Jul 23, 2017 9:54 pm

Re: Subsonic 6.1.3 (pre-)released

Postby antti » Wed Nov 08, 2017 11:08 pm

After upgrade Podcast are not working. When clicking podcast link in main menu, got strange error with path to unexsisting directory for random podcast

Also when scanning, I get lot of WARN JaudiotaggerParser Error when parsing tags errors
antti
 
Posts: 7
Joined: Wed Feb 10, 2016 9:20 pm

Re: Subsonic 6.1.3 (pre-)released

Postby zeroday » Tue Nov 14, 2017 8:00 am

First crash since long time and just after upgrading to 6.1.3

[2017-11-14 03:19:33,123] WARN JaudiotaggerParser - Error when parsing tags in /media/music/Mixed by DJ Dano.wav
org.jaudiotagger.audio.exceptions.CannotReadException: /media/music/Mixed by DJ Dano.wav:null
at org.jaudiotagger.audio.generic.AudioFileReader.read(AudioFileReader.java:117)
at org.jaudiotagger.audio.AudioFileIO.readFile(AudioFileIO.java:355)
at org.jaudiotagger.audio.AudioFileIO.read(AudioFileIO.java:198)
at net.sourceforge.subsonic.service.metadata.JaudiotaggerParser.getRawMetaData(JaudiotaggerParser.java:58)
at net.sourceforge.subsonic.service.metadata.MetaDataParser.getMetaData(MetaDataParser.java:29)
at net.sourceforge.subsonic.service.MediaFileService.createMediaFile(MediaFileService.java:504)
at net.sourceforge.subsonic.service.MediaFileService.checkLastModified(MediaFileService.java:118)
at net.sourceforge.subsonic.service.MediaFileService.getChildrenOf(MediaFileService.java:188)
at net.sourceforge.subsonic.service.MediaScannerService.scanFile(MediaScannerService.java:219)
at net.sourceforge.subsonic.service.MediaScannerService.scanFile(MediaScannerService.java:223)
at net.sourceforge.subsonic.service.MediaScannerService.doScanLibrary(MediaScannerService.java:161)
at net.sourceforge.subsonic.service.MediaScannerService.access$000(MediaScannerService.java:31)
at net.sourceforge.subsonic.service.MediaScannerService$2.run(MediaScannerService.java:130)
Caused by: java.nio.BufferUnderflowException
at java.nio.DirectByteBuffer.get(DirectByteBuffer.java:271)
at java.nio.ByteBuffer.get(ByteBuffer.java:715)
at org.jaudiotagger.audio.generic.Utils.getString(Utils.java:262)
at org.jaudiotagger.audio.wav.chunk.WavInfoChunk.readChunks(WavInfoChunk.java:40)
at org.jaudiotagger.audio.wav.chunk.WavListChunk.readChunk(WavListChunk.java:53)
at org.jaudiotagger.audio.wav.WavTagReader.readChunk(WavTagReader.java:120)
at org.jaudiotagger.audio.wav.WavTagReader.read(WavTagReader.java:59)
at org.jaudiotagger.audio.wav.WavFileReader.getTag(WavFileReader.java:50)
at org.jaudiotagger.audio.generic.AudioFileReader.read(AudioFileReader.java:106)
... 12 more

also I see this

[GC (Allocation Failure) 66220K->54468K(113136K), 0.0430809 secs]
[GC (Allocation Failure) 85700K->71153K(113136K), 0.0499469 secs]
[GC (Allocation Failure) 102385K->75517K(113136K), 0.0213500 secs]
[GC (Allocation Failure) 106749K->77519K(113136K), 0.0158390 secs]


it seems that this has to do with out of memory stuff

[2017-11-14 09:09:14,576] WARN JaudiotaggerParser - Error when parsing tags in /media/music/Mixed by Steve Murphy.wav
java.lang.OutOfMemoryError: Java heap space

problems became visible after upgrading to 6.1.3

update
one of the things I have done is remove openjdk 7 and install openjdk 8 it might help ..
Right now subsonic is scanning +3TB of my music

Uprading JAVA helped, no crash yes, lots of info in the log though
[2017-11-14 15:37:18,534] WARN JaudiotaggerParser - Error when parsing tags in /media/music/candy dulfer/Candy Dulfer - Beat Side 1990.wav
java.lang.OutOfMemoryError: Java heap space

[2017-11-14 15:37:24,686] INFO MediaScannerService - Scanned media library with 123750 entries.

and switching to java 8 helped

[2017-11-14 17:11:59,064] INFO MediaScannerService - Scanned media library with 159553 entries.
[2017-11-14 17:11:59,064] INFO MediaScannerService - Marking non-present files.
[2017-11-14 17:12:24,078] INFO MediaScannerService - Marking non-present artists.
[2017-11-14 17:12:25,093] INFO MediaScannerService - Marking non-present albums.
[2017-11-14 17:12:28,072] INFO MediaScannerService - Completed media library scan.
zeroday
 
Posts: 7
Joined: Wed Oct 29, 2014 8:56 am

Re: Subsonic 6.1.3 (pre-)released

Postby antti » Fri Nov 17, 2017 12:14 pm

Here is screenshot about Podcast error
Image

And here is settings page
Image
ebay image hosting free

Version info
Image
image processing service
antti
 
Posts: 7
Joined: Wed Feb 10, 2016 9:20 pm

Re: Subsonic 6.1.3 (pre-)released

Postby zeroday » Sat Nov 18, 2017 1:05 pm

antti wrote:Here is screenshot about Podcast error
Image


security issue, subsonic has no rights at that specific location. Can you reach it when you try to access
maybe not in the upper folders . .
when in shell can you access it?
user / group / rights?
zeroday
 
Posts: 7
Joined: Wed Oct 29, 2014 8:56 am

Re: Subsonic 6.1.3 (pre-)released

Postby antti » Sat Nov 18, 2017 1:15 pm

Problem is that Podcasts setting are not working. The correct path is /music/Podcast. There are no directory mentioned in error. It’s like there is hardcoded /mnt/media somewhere.
antti
 
Posts: 7
Joined: Wed Feb 10, 2016 9:20 pm

Re: Subsonic 6.1.3 (pre-)released

Postby cleepa » Tue Nov 21, 2017 4:26 am

sindre_mehus wrote:Bugfix: Externally modified tracks disappear in Subsonic.

I upgraded for this fix, from 6.1.1.

I had an album with some (but not all) flac files with invalid DATE tags. I fixed the tags with an external tagger and rescanned. The retagged files disappeared from the Subsonic web ui, but the files that were not changed remained.

I then upgraded to 6.1.3 and rescanned. The flac files that had disappeared came back, however the tags appeared as they did before I did anything at all.

So the issue is not fully resolved yet. I haven't been able to find a workaround.
cleepa
 
Posts: 1
Joined: Wed Mar 02, 2016 7:04 pm

Re: Subsonic 6.1.3 (pre-)released

Postby magnumforce2006 » Tue Nov 28, 2017 1:02 pm

I'd like to report a bug with 6.1.3


A couple days ago (after updating to newest subsonic version 6.1.3), I realized that I could no longer play songs. The play buttons disappeared, and I couldn't find the settings for Subsonic in my web browser. In an act of desperation I deleted all of my local settings files and created a new user on Subsonic (still on version 6.1.3). Seemed to work, but the next day, I once again could not use the settings in the Web UI, and the play/queue controls were gone.

I have now repeated this process of removing my local settings files, setting up a new user, but also downgraded to 6.1.2. I did this yesterday, and today I am no longer having the issue.

I believe this feature:

"Bugfix: Hide links, buttons etc in the web interface if a user is not allowed to play music."

Is causing issues with users, even when they are granted the proper permissions. I was sure to give my custom user ALL Subsonic privileges, including admin rights, and yet the settings and play controls were still gone the next day.
magnumforce2006
 
Posts: 14
Joined: Sun Feb 13, 2011 10:48 pm
Location: US

Re: Subsonic 6.1.3 (pre-)released

Postby kermit22 » Tue Dec 05, 2017 3:51 pm

[quote]Bugfix: Externally modified tracks disappear in Subsonic.[/quote]

Thank you for fixing this issue.
-My Subsonic Server-

OS: Windows Server 2016
Processor: Intel Xeon 5440
Memory: 8GB


1,972 artists
3,936 albums
35,452 songs
236.92 GB
2,401 hours
User avatar
kermit22
 
Posts: 215
Joined: Fri Feb 20, 2009 7:00 pm

Re: Subsonic 6.1.3 (pre-)released

Postby antti » Tue Dec 12, 2017 12:31 pm

antti wrote:Problem is that Podcasts setting are not working. The correct path is /music/Podcast. There are no directory mentioned in error. It’s like there is hardcoded /mnt/media somewhere.


Hello!

Still Podcast are not working.

Music is stored in folder /music
Podcast should be in folder /music/Podcasts/

Error message gives strange path that doesn't exist nor have ever existed. I have tried to link /mnt/ to right place but that didn't help.

Image

Where information about podcasts is located?
antti
 
Posts: 7
Joined: Wed Feb 10, 2016 9:20 pm

Previous

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest