Windows 8 client

Announcements and discussion of new releases.

Moderator: moderators

Re: Windows 8 client

Postby andyoak » Thu Apr 11, 2013 1:20 pm

Gido wrote:Hi andyoak,

Yes I do have folders like :

A1
B1
C1
E1

etc.

Under A1 I have all artitst ( bands ) started with a A
Under B1 I have all artitst ( bands ) started with a B
Under C1 I have all artitst ( bands ) started with a C
Under E1 I have all artitst ( bands ) started with a E

etc.

I don't use HTTPS and I use another port number than default.



This should be fixed in the next update (which already is under MS certification).
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby andyoak » Thu Apr 11, 2013 1:27 pm

Skobone wrote:Crashed my Madsonic server when started to download album covers.


Hi thanks for reporting. Unless Madsonic has a different api for retrieving album covers this shouldnt be an issue. Are you able to use other Subsonic clients with your server?
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby Gido » Fri Apr 12, 2013 6:39 pm

Hi andyoak,

installed the update, folders are visable now but the program has some problems with UTF-8 ( see screenshot )

Image

If you wish I can make you a login so you can see the difference between the web version and the Windows 8 application. If so? give me this weekend because i'm just installing new hardware.

...

Image
Gido
 
Posts: 7
Joined: Tue Apr 09, 2013 9:09 pm

Re: Windows 8 client

Postby andyoak » Fri Apr 12, 2013 9:57 pm

Hi Gido, there's no need.. I know what the problem is and it'll be fixed in the next update :)
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby Gido » Fri Apr 12, 2013 10:16 pm

Excellent :D

Image
Gido
 
Posts: 7
Joined: Tue Apr 09, 2013 9:09 pm

Re: Windows 8 client

Postby bushman4 » Sat Apr 13, 2013 1:50 pm

Just tried the newest version, against both standard Subsonic running with SSL on Tomcat and with Madsonic running standalone, and got certificate errors...

"The Remote Certificate is Invalid according to the validation procedure."

Thanks,

Glenn
Glenn Sullivan
Subsonic 5.2.1 (Standalone on Apache/Tomcat 6)
WHS 2003, Dual Core Athlon, 4 Gb RAM, 12 TB
50 regular Subsonic Users

Library as of 2016-03-21:
4,034 artists
16,595 albums
182,904 songs
4582.16 GB
21,558 hours
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Re: Windows 8 client

Postby andyoak » Mon Apr 15, 2013 12:28 pm

bushman4 wrote:Just tried the newest version, against both standard Subsonic running with SSL on Tomcat and with Madsonic running standalone, and got certificate errors...

"The Remote Certificate is Invalid according to the validation procedure."

Thanks,

Glenn


Hi, I'm afraid this will not be supported. A Win8 store app that connects to a SSL must be deployed alongside its certificate file, which is not possible in this case, since each user will have potentially a different server.
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby zoic21 » Wed Apr 17, 2013 1:29 pm

Hi,

I just try your application but I got a probleme I can not loggin into my server (supersonic always say : Wrong username or password).
I think is du to ssl or my password (there is a symbole "+" on my password). Is there any way to solve this?
zoic21
 
Posts: 9
Joined: Wed Mar 14, 2012 5:55 pm

Re: Windows 8 client

Postby andyoak » Wed Apr 17, 2013 3:32 pm

Hi zoic21,

yes you're right that will be fixed in the next update. Thanks for reporting. in the meantime you could replace the character + in your password with a %2B. That should work for now :)
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby zoic21 » Fri Apr 19, 2013 7:38 am

Thank for your reply it's work now but on lot of music I get this error (not on all musics) :
error.jpg


And I have another question : are they any implementation of playlist (just play not mangement) ?
zoic21
 
Posts: 9
Joined: Wed Mar 14, 2012 5:55 pm

Re: Windows 8 client

Postby andyoak » Fri Apr 19, 2013 6:53 pm

Does that happen when playing albums? And if so, do they have only one song? Regarding the Subsonic platylists, I dont use them, but that might be implemented in a near future..
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby zoic21 » Fri Apr 19, 2013 6:57 pm

Yes is an album with only one music
zoic21
 
Posts: 9
Joined: Wed Mar 14, 2012 5:55 pm

Re: Windows 8 client

Postby andyoak » Sat Apr 20, 2013 10:03 am

I've just fixed that yesterday :) Please wait for the next update, which should come out soon
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby andyoak » Wed May 29, 2013 6:22 pm

For those using SSL certificates with Subsonic I found out that there's a way to use Supersonic after all. Try this:

1 - Export the certificate from web browser to a file in your computer
2 - Install (right-click certificate file -> install -> local machine -> "Place all certificates ..." -> "Trusted root certificate..")
3 - Launch Supersonic

Note: I don't think it works with self-signed certificates. I believe it must point to the real subsonic domain/address. See here how to create one http://forum.subsonic.org/forum/viewtopic.php?t=5295

Thanks to Alex Steadman for figuring this out
andyoak
 
Posts: 23
Joined: Tue Mar 26, 2013 9:38 am

Re: Windows 8 client

Postby rob63 » Thu May 30, 2013 4:44 am

Hi,

I'm running plain vanilla Subsonic 4.8. It connects to demo server fine but getting "a connection attempt failed because the connected party did not properly respond after a period of time, ... when trying to connect to my server. Not using SSL. No issues connecting using same parameters with browser or remote app.
rob63
 
Posts: 19
Joined: Thu Oct 25, 2012 5:35 pm

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: Bing [Bot] and 5 guests