Subsonic 4.9.beta1 released

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic 4.9.beta1 released

Postby sindre_mehus » Fri Nov 08, 2013 9:59 pm

FoxBJK wrote:Thanks for releasing an update, Sindre!!

I found a bug, though. Should I report it here or somewhere else? Let me know and I'll write up as much as I can. Thanks again!


Hi,

Please post it here or send me an email. Alternatively, you can post it on http://sourceforge.net/p/subsonic/bugs

Thanks in advance,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta1 released

Postby sindre_mehus » Fri Nov 08, 2013 10:01 pm

baaldemon wrote:I have the beta up an running on Tomcat6, it was a pain to downgrade to Tomcat6 when I upgraded my server OS on my last hardware refresh. I have yet to spinup a VM and test it out on Tomcat7 before I upgrade and was wondering if anyone can shed some light onto how it performs on Tomcat7. Also if I remember right when I was trying to get it to work on Tomcat7 before I had to disable a security feature enabled by default in Tomcat7 does anyone know if this was addressed with this release (sorry im drawing a blank on the specific config as its been a long time since I dove into trying to get it working on tomcat7 when it wasnt supported).


If I remember correctly Subsonic 4.9 works on a vanilla Tomcat7 without any modifcations.

Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta1 released

Postby wannabe_nerd » Fri Nov 08, 2013 11:55 pm

Please post it here or send me an email. Alternatively, you can post it on http://sourceforge.net/p/subsonic/bugs

Thanks in advance,
Sindre


I think i discovered another Bug (Mediascanner freezes at the same number of files again and again ) bzt at http://sourceforge.net/p/subsonic/bugs i can only post bugs for 4.8 instead of 4.9...
Cloud Computing .... i made my own cloud !
wannabe_nerd
 
Posts: 36
Joined: Wed May 11, 2011 9:06 am

Re: Subsonic 4.9.beta1 released

Postby rubbersoul » Sat Nov 09, 2013 2:21 pm

so excited to see another update!!! subsonic is one of my most used programs so updates make me giddy, haha.

jayw654 wrote:This would be a good time for the Sindre to fix the skip of .3 - .5 second skip when I play songs using the android app. I don't know if its because of the server or the android client but when ever I play a song using the android client the first song always skips but this is assuming I have multiple songs set to be played automatically. If I decide to choose every song I play individually after the last song is finished playing then the next song I play with have the annoying skip. I tried dsub and and the official subsonic app and both seem to have the issue. Haven't tried other players outside those two. It seems it may be server related of how the server connects to the android apps within the jellybean OS. However Amazon MP3 cloud player and Google music do NOT have this issue. The issue also does not seem to exist on my old Motorola Droid X which is running Android 2.3.3. Seems to affect Android Jellybean on my Samsung Note 2 and my Nexus 7. Lastly it does NOT matter if I stream over the 4G network or Wi-Fi it will skip just the same. Seems like its a downloading, buffering and/or caching issue.

I had forgotten to add some important information. I forgot to add that I have ALL transcoding and down-sampling cleared out, which means it is running completely naked. I have all files converted to 320 MP3. By disabling the transcoding and down-sampling it is far less taxing on my computer as I have other server software running and since mp3 is supported by almost everything it is why I chose the mp3 format so there was no need for transcoding and down-sampling.

Notice that the skip is also present when playing flac files. Issue is format independent.

P.S. Kudos for adding DLNA
this doesn't belong here; it's a problem with the android app so won't be addressed with a server upgrade. try dsub, it doesn't have any playback issues and even has nearly gapless playback for jellybean+.
rubbersoul
 
Posts: 127
Joined: Thu Aug 18, 2011 2:27 pm

Re: Subsonic 4.9.beta1 released

Postby jayw654 » Sun Nov 10, 2013 3:01 am

rubbersoul wrote:so excited to see another update!!! subsonic is one of my most used programs so updates make me giddy, haha.

jayw654 wrote:This would be a good time for the Sindre to fix the skip of .3 - .5 second skip when I play songs using the android app. I don't know if its because of the server or the android client but when ever I play a song using the android client the first song always skips but this is assuming I have multiple songs set to be played automatically. If I decide to choose every song I play individually after the last song is finished playing then the next song I play with have the annoying skip. I tried dsub and and the official subsonic app and both seem to have the issue. Haven't tried other players outside those two. It seems it may be server related of how the server connects to the android apps within the jellybean OS. However Amazon MP3 cloud player and Google music do NOT have this issue. The issue also does not seem to exist on my old Motorola Droid X which is running Android 2.3.3. Seems to affect Android Jellybean on my Samsung Note 2 and my Nexus 7. Lastly it does NOT matter if I stream over the 4G network or Wi-Fi it will skip just the same. Seems like its a downloading, buffering and/or caching issue.

I had forgotten to add some important information. I forgot to add that I have ALL transcoding and down-sampling cleared out, which means it is running completely naked. I have all files converted to 320 MP3. By disabling the transcoding and down-sampling it is far less taxing on my computer as I have other server software running and since mp3 is supported by almost everything it is why I chose the mp3 format so there was no need for transcoding and down-sampling.

Notice that the skip is also present when playing flac files. Issue is format independent.

P.S. Kudos for adding DLNA
this doesn't belong here; it's a problem with the android app so won't be addressed with a server upgrade. try dsub, it doesn't have any playback issues and even has nearly gapless playback for jellybean+.


Hey I bought Dsub some time ago and it had the same issue as the official Subsonic app. However, Now I tried it again after some updating had been done to Dsub and it does in fact clear up the issue. Thank you for reminding of Dsub as now the issue is resolved.
jayw654
 
Posts: 40
Joined: Fri Oct 14, 2011 12:36 am

Re: Subsonic 4.9.beta1 released

Postby bile » Sun Nov 10, 2013 4:04 am

toif wrote:
jsonnabend wrote:
ironcross wrote:Has the Various Artist issue been addressed?

http://forum.subsonic.org/forum/viewtopic.php?f=3&t=11023&p=58427&hilit=various+artist#p58427

If nothing else could it become a selectable option in the settings?

+1

+1


Please, please fix this. Is there any reason it's not been? People have been asking about it for forever. It's a major annoyance.
bile
 
Posts: 45
Joined: Mon Apr 18, 2011 11:36 am

Re: Subsonic 4.9.beta1 released

Postby oggie » Sun Nov 10, 2013 2:41 pm

Great addition for the dlna functionality. One thing that would be nice would be able to see your playlists in the dlna client as well.
oggie
 
Posts: 35
Joined: Sun Dec 18, 2011 2:41 am

Re: Subsonic 4.9.beta1 released

Postby sindre_mehus » Sun Nov 10, 2013 4:02 pm

ironcross wrote:Has the Various Artist issue been addressed?

http://forum.subsonic.org/forum/viewtopic.php?f=3&t=11023&p=58427&hilit=various+artist#p58427

If nothing else could it become a selectable option in the settings?


Sorry for neglecting this for so long. I'm working on properly supporting album artists now. It will make it into 4.9, but I probably have to make another beta release first.

Thanks
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta1 released

Postby sindre_mehus » Sun Nov 10, 2013 4:08 pm

oggie wrote:Great addition for the dlna functionality. One thing that would be nice would be able to see your playlists in the dlna client as well.


From what I have read (and experienced myself), making a DLNA implementation that works with most endpoints is very difficult.
I'm interested to get feedback with respect to what works and what doesn't with your specific DLNA clients.

Yes, playlist support is a great idea and I'll look into that once the basic stuff works.

Thanks
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta1 released

Postby oggie » Sun Nov 10, 2013 4:52 pm

sindre_mehus wrote:
oggie wrote:Great addition for the dlna functionality. One thing that would be nice would be able to see your playlists in the dlna client as well.


From what I have read (and experienced myself), making a DLNA implementation that works with most endpoints is very difficult.
I'm interested to get feedback with respect to what works and what doesn't with your specific DLNA clients.

Yes, playlist support is a great idea and I'll look into that once the basic stuff works.

Thanks
Sindre



I tested it briefly on android with bubbleUpnp and on an aluratek radio. It worked fine in the brief testing I did.
oggie
 
Posts: 35
Joined: Sun Dec 18, 2011 2:41 am

Re: Subsonic 4.9.beta1 released

Postby kargath » Tue Nov 12, 2013 4:07 pm

What does the increase of the internal database to 8GB do for the end user? Will it fix the issue with some folders refusing to update with new media?
kargath
 
Posts: 33
Joined: Wed Feb 15, 2012 2:31 pm

Re: Subsonic 4.9.beta1 released

Postby jsonnabend » Tue Nov 12, 2013 6:32 pm

sindre_mehus wrote:
ironcross wrote:Has the Various Artist issue been addressed?

http://forum.subsonic.org/forum/viewtopic.php?f=3&t=11023&p=58427&hilit=various+artist#p58427

If nothing else could it become a selectable option in the settings?


Sorry for neglecting this for so long. I'm working on properly supporting album artists now. It will make it into 4.9, but I probably have to make another beta release first.

Thanks
Sindre

Excellent!
jsonnabend
 
Posts: 42
Joined: Wed May 23, 2012 3:18 am

Re: Subsonic 4.9.beta1 released

Postby achmetinternet » Wed Nov 13, 2013 12:59 pm

I am soooooo AMPED!
achmetinternet
 
Posts: 31
Joined: Fri Feb 11, 2011 3:23 pm

Re: Subsonic 4.9.beta1 released

Postby wowo » Tue Nov 26, 2013 12:29 pm

Excellent :!: :
In subsonic 4.9 beta2 the display of artists in various artists compilation albums is now correct. :P

See picture.
Subsonic 4.7 (build 3105) running on QNAP TS-239 Pro II (Intel Atom 1.8GHz Single-core ; 1GB RAM)
wowo
 
Posts: 25
Joined: Mon Oct 24, 2011 9:27 pm

Re: Subsonic 4.9.beta1 released

Postby FoxBJK » Thu Jan 16, 2014 5:48 pm

sindre_mehus wrote:
FoxBJK wrote:Thanks for releasing an update, Sindre!!

I found a bug, though. Should I report it here or somewhere else? Let me know and I'll write up as much as I can. Thanks again!


Hi,

Please post it here or send me an email. Alternatively, you can post it on http://sourceforge.net/p/subsonic/bugs

Thanks in advance,
Sindre


Posted! http://sourceforge.net/p/subsonic/bugs/98/
Let me know if you need me to do any testing/debugging
FoxBJK
 
Posts: 29
Joined: Fri Jun 29, 2012 5:58 pm

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 6 guests