Subsonic 4.9.beta4 released

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic 4.9.beta4 released

Postby sindre_mehus » Sat Jan 11, 2014 2:14 pm

retteketet wrote:Hi Sindre,

great news that we can select genre & decade in de "home.view" in the new realease.
But are we stuck by min/max of 40 albums on the page?
the option listSize doesnt seem to work anymore.

I use the listSize option in my subsonic. I take the window size and calculate the amount of albums that can be shown in the window using some javascript.

Can you please put the listSize option back in the final release?


Hi,

Would you mind sharing the details about the javascript you use to accomplish this? I might consider adding it to Subsonic.

Thanks,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta4 released

Postby sindre_mehus » Sat Jan 11, 2014 2:24 pm

joost wrote:upnp is mostly working now. It does not send the correct link to a file by default if there are multiple interfaces. Also correct metric values didnt do the trick there. stopping the vpn and bringing tun0 down did.


You can force Subsonic to use a certain network interface by specifying "subsonic.host". On Windows, this is done in c:/program files (x86)/subsonic/subsonic-service.exe.vmoptions file, e.g.:

Code: Select all
-Dsubsonic.host=10.1.2.3


On Linux you specify this in /etc/default/subsonic or /etc/sysconfig/subsonic, e.g.:

Code: Select all
SUBSONIC_HOST=10.1.2.3


Hope this helps!
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta4 released

Postby sindre_mehus » Sat Jan 11, 2014 2:41 pm

phazzard wrote:Any help would be appreciated - Still getting this error message: Status: XXXXXXXX.subsonic.org returned HTTP error code 404 Not Found. I have only received this since the beta 4 version. I have tried everything including uninstalling plus deleting subsonic folder with db info. Fresh install and getting the same message. It is rescanning my media now, but works fine on my local machine but unable to get access over the internet. I am fully licensed and have had the same address for several years through multiple revisions and never had this issue before? Any ideas?


I doubt this is related to the new beta, but please contact me directly with your details so I can look into it.

Thanks
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta4 released

Postby phazzard » Sat Jan 11, 2014 2:55 pm

Just sent you a PM
phazzard
 
Posts: 49
Joined: Thu Jul 08, 2010 6:43 pm

Re: Subsonic 4.9.beta4 released

Postby retteketet » Sat Jan 11, 2014 3:05 pm

sindre_mehus wrote:
retteketet wrote:Hi Sindre,

great news that we can select genre & decade in de "home.view" in the new realease.
But are we stuck by min/max of 40 albums on the page?
the option listSize doesnt seem to work anymore.

I use the listSize option in my subsonic. I take the window size and calculate the amount of albums that can be shown in the window using some javascript.

Can you please put the listSize option back in the final release?


Hi,

Would you mind sharing the details about the javascript you use to accomplish this? I might consider adding it to Subsonic.

Thanks,
Sindre



Hi Sindre,
i'm not a programmer. but this is what i did: (a lot of copy paste from google)

1 read the window size initial and after resizing the window
2 calculate the amount of albums that would fit. (minimum of 4)
3 if the amount of albums is different then before a reload will be triggered with the new amount of albums
3 calculate extra padding for vertical alignment on the page

i show the albums using the text-alignment "jusify" for horizontal alignment on the page.


function get_albums()
{

var a = 4;
var margin_width = 4;
var framewidth = window.innerWidth
|| document.documentElement.clientWidth
|| document.body.clientWidth;

framewidth = framewidth + margin_width
var albumwidth = Math.floor(framewidth / 114);


var margin_bottom = 0;


var frameheight = window.innerHeight
|| document.documentElement.clientHeight
|| document.body.clientHeight;

frameheight = frameheight - margin_bottom;
var albumheight = Math.floor(frameheight / 147);
var extrapadding = frameheight%147;
extrapadding = Math.floor(extrapadding / albumheight);
var totals = albumheight*albumwidth;

if (totals < 4)
{
a = 4;
}
else
{
a = albumheight*albumwidth;
}


var b = QueryString.listSize;
var c = window.location.href
c=c.replace(new RegExp("&listSize=[0-9]*","ig"),"")

if (a != b)
{
window.location.href = c + "&listSize=" + a;
}

divs=document.getElementsByTagName('div');

for (var i=0;i<divs.length;i++){
if (divs[i].id.indexOf("blockdiv")==0){//only if 'image' is at the beginning of the id
divs[i].style.padding = "0px 0px " + extrapadding + "px 0px";
}
}
User avatar
retteketet
 
Posts: 6
Joined: Wed Sep 21, 2011 12:23 pm

Re: Subsonic 4.9.beta4 released

Postby sindre_mehus » Sat Jan 11, 2014 3:19 pm

Thanks retteketet - appreciate it.

My personal opinion is that this Javascript code has too many assumptions/hardcodings and is too unmaintable to include it in the main trunk of Subsonic.

Come to think of it, a better solution is probably to get rid of the paging mechanism altogether and instead dynamically add more albums when the user scrolls the page (like Google image search). I'll look into that in the next version.

Thanks,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.9.beta4 released

Postby retteketet » Sat Jan 11, 2014 3:36 pm

sindre_mehus wrote:Thanks retteketet - appreciate it.

My personal opinion is that this Javascript code has too many assumptions/hardcodings and is too unmaintable to include it in the main trunk of Subsonic.

Come to think of it, a better solution is probably to get rid of the paging mechanism altogether and instead dynamically add more albums when the user scrolls the page (like Google image search). I'll look into that in the next version.

Thanks,
Sindre


Sindre,
you right about the too many assumptions/hardcodings ;)
i really wanted to get rid of the scroll bar.
kind regards,
Dennis
User avatar
retteketet
 
Posts: 6
Joined: Wed Sep 21, 2011 12:23 pm

Re: Subsonic 4.9.beta4 released

Postby freekdb » Sat Jan 11, 2014 3:46 pm

Hi, I'm a long time Subsonic user and very excited about the DLNA support in the new beta release.
Unfortunately, when I launch BubbleUPnP or UPnPlay on my Android clients I don't get to see the library. It connects fine to the Subsonic server but I can only see the playlists (only one for the moment) and then there is an entry called 'MP3' with the number 790 next to it. When clicked, the same page is shown, I don't get to see the list of artists, albums or songs.
The playlists seems to work fine.

Both apps (BubbleUPnP and UPnPlay) have the same issue so my guess is that there is something wrong on the server.

Thanks for your excellent work!
freekdb
 
Posts: 6
Joined: Tue Jan 07, 2014 4:09 pm

Re: Subsonic 4.9.beta4 released

Postby joost » Sat Jan 11, 2014 5:39 pm

sindre_mehus wrote:
joost wrote:upnp is mostly working now. It does not send the correct link to a file by default if there are multiple interfaces. Also correct metric values didnt do the trick there. stopping the vpn and bringing tun0 down did.


You can force Subsonic to use a certain network interface by specifying "subsonic.host". On Windows, this is done in c:/program files (x86)/subsonic/subsonic-service.exe.vmoptions file, e.g.:

Code: Select all
-Dsubsonic.host=10.1.2.3


On Linux you specify this in /etc/default/subsonic or /etc/sysconfig/subsonic, e.g.:

Code: Select all
SUBSONIC_HOST=10.1.2.3


Hope this helps!


Thnx for the reply. Tried all options, most of the upnp apps i've tested work so far. I think that it is a xbmc issue then. To be sure i have posted the same question on there forum too...
joost
 
Posts: 53
Joined: Thu Jan 10, 2013 7:46 pm

Re: Subsonic 4.9.beta4 released

Postby joost » Sun Jan 12, 2014 10:58 am

Tried several options, where do i define the default host running tomcat6 on debian? When defining address variable in /etc/tomcat6/server.xml it uses this value for subsonic, but not for its upnp. All the other variables aren t picked by subsonic at all....

Cheers :)
joost
 
Posts: 53
Joined: Thu Jan 10, 2013 7:46 pm

Re: Subsonic 4.9.beta4 released

Postby _jd_ » Sun Jan 12, 2014 12:36 pm

After erasing the old subsonic files completely, my issues with encodings have disappeared.

With regard to the DLNA, I would like to be able to set transcoding schemes for various clients (most can play all formats I have, but some clients cannot handle the flac files).
_jd_
 
Posts: 6
Joined: Sat Dec 28, 2013 8:07 pm

Re: Subsonic 4.9.beta4 released

Postby GJ51 » Sun Jan 12, 2014 5:01 pm

sindre_mehus wrote:Thanks Gary.

I get the Error popup as well. It comes from the frame on the right (with the chat and now playing info).

I have seen this error before, but haven't been able to find the bug. I think it will go away if you restart the server. I'll see if there's anything I can do to prevent it.

Regarding the other problem (changes to tags not being reflected in Subsonic), can you tell me how you edit the tags? If you use an external tag editor, can you please check if the last-modified time of the files are updated? If not, Subsonic will not rescan the file.



Latest testing now shows tags updates being seen by SS both when modified through a tag editor or directly through Subsonic. Problem seems to have disappeared for the moment. I'm wondering if a bit of "Heisenberg Uncertainty" isn't at work here and that the mere act of having Windows file manager open to see if the file date/times were properly updated may in fact have an impact on SS being able to see the changes?
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3492
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Re: Subsonic 4.9.beta4 released

Postby frimix » Mon Jan 13, 2014 8:53 am

Sindre,
thanks a lot for the new subsonic release. :D
This release works great, also DLNA does (although there is no picture)
There is a little thing that would be great for the new DLNA support:
For DLNA, with a huge music library and a device like the Pioneer N-50, it would be great to have the same folder structure sorted alphabetically like it is on http:
-subsonic
--music
---A (<-- this would be great!)
----Aaliyah
----etc.

Kind regards
frimix
 
Posts: 1
Joined: Mon Jan 13, 2014 8:34 am

Re: Subsonic 4.9.beta4 released

Postby IwishIcanFLighT » Mon Jan 13, 2014 9:06 am

Hey there I wanted to report a tiny bug in the comment feature.
If you write line starting by

Code: Select all
11. name song - artist


it will shown up as

1. name song - artist


Exemple:
Image
Image

I'm running 4.8 (build 3434) right now, so maybe the bug as been fixed with the beta, but I wanted to be sure.

Cheers!
IwishIcanFLighT
 
Posts: 14
Joined: Fri May 10, 2013 8:26 am

Re: Subsonic 4.9.beta4 released

Postby daneren2005 » Tue Jan 14, 2014 4:48 am

So I think I might have figured out a trigger for the irritating issue where the web client tries to play everything as an external playlist instead of the web one. It only seems to happen when I download stuff on my phone while I am logged on the web client on the same lan. It seems to be getting confused. It shows that it is playing off of the correct player, but it seems to be trying to play from the mobile player. The only solution appears to be to delete all the existing players, then log out and back in. I can't seem to figure out an exact set of steps to reproduce, but it has been more recently that I've noticed that it always only happens when logged in at home and after having tried to download something from my phone. I'm also wondering if maybe you have to download the same thing that you are listening to in the browser?
Developer of DSub for Android
daneren2005
 
Posts: 1709
Joined: Fri Jul 06, 2012 7:52 pm

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 6 guests