Subsonic 5.1.beta1 released

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic 5.1.beta1 released

Postby Trufax » Fri Jan 09, 2015 8:28 pm

looks great! would it be possible to give an option to select my own top level domain inside subsonic (for sharing feature) instead of only *.subsonic,org?
Trufax
 
Posts: 21
Joined: Tue Dec 06, 2011 8:32 pm

Re: Subsonic 5.1.beta1 released

Postby JMoreau » Fri Jan 09, 2015 9:55 pm

Sindre,

After reading all the posts... I'm like many other users.... The new thumbnails interface is a pain... I had to roll back to subsonic version 5.0 (cannot operate with 5.1)
Can you put an option to disable the thumbnails?
To steel the expression from another post... I'm a fan of simple...and the thumbnails are a pain to read and navigate quickly.

I have a database with more than 8000 albums.
My structure is the most popular one... 1 folder for each letter (a,b,c...) / Artist (Discography) (Genre) / Artist - Year - Album / 01 Song Title

Especially, that i put the ''genre'' after the artist name.
Example: Eric Clapton (Discography) (Blues)
When the thumbnails are activated, it's impossible to see the description of the ''genre'' in the thumbnails.

Thanks for all your hard work!
Last edited by JMoreau on Fri Jan 09, 2015 11:02 pm, edited 1 time in total.
JMoreau
 
Posts: 10
Joined: Mon Aug 15, 2011 9:58 pm
Location: Austin, TX USA

Re: Subsonic 5.1.beta1 released

Postby JMoreau » Fri Jan 09, 2015 10:22 pm

Sindre,

Since the last version 5.0... when you download an album... the ZIP file does not include the "Cover.jpg" file anymore.
The ZIP file include only the MP3 files of the folder.

Is it possible to include the "cover.jpg" in the ZIP file... like before version 5.0 ?

More details:
My structure is the most popular one... 1 folder for each letter (a,b,c...) / Artist (Discography) (Genre) / Artist - Year - Album / 01 Song Title
Inside each "Artist - Year - Album" folder, with the MP3 files, I have a "Cover.jpg" file.

Thanks Sindre for your hard work!
JMoreau
 
Posts: 10
Joined: Mon Aug 15, 2011 9:58 pm
Location: Austin, TX USA

Re: Subsonic 5.1.beta1 released

Postby JMoreau » Fri Jan 09, 2015 10:59 pm

Sindre,

with version 5.0, below each "album cover", I always see a gap before the album title. (see the red arrows on the attachment).

Is it possible to fix that issue?

Thanks!
Last edited by JMoreau on Sat Jan 10, 2015 6:19 am, edited 1 time in total.
JMoreau
 
Posts: 10
Joined: Mon Aug 15, 2011 9:58 pm
Location: Austin, TX USA

Re: Subsonic 5.1.beta1 released

Postby jarome » Fri Jan 09, 2015 11:49 pm

All my album art has disappeared on OpenSuse 13.2. They were working in the last 5.0, but no longer!
How do I get them back?

In the attached file, I clicked on the broken picture icon, and the picture appeared, so they are there.
Last edited by jarome on Fri Jan 09, 2015 11:59 pm, edited 1 time in total.
jarome
 
Posts: 87
Joined: Sat Apr 16, 2011 2:53 am

Re: Subsonic 5.1.beta1 released

Postby trickydick » Fri Jan 09, 2015 11:52 pm

does anyone have the standalone war file for 5.1 beta 1, I can't seem to download it from sourceforge?
Tricky
User avatar
trickydick
 
Posts: 147
Joined: Wed Mar 30, 2011 12:43 am
Location: Sanford, North Carolina

Re: Subsonic 5.1.beta1 released

Postby jarome » Sat Jan 10, 2015 12:36 am

I think my above problem with pictures is due to difficulties starting and stopping subsonic.
Code: Select all
jarfx:/etc/init.d # ./subsonic stop
Started Subsonic [PID 3236, /var/subsonic/subsonic_sh.log]
Stopping subsonic ...killproc: Empty pid file /var/run/subsonic.pid for /usr/bin/subsonic


This does not in fact kill subsonic. The web page is still active. The only way I can stop subsonic is to do
Code: Select all
ps -lae | grep java

and kill all of those processes

Nor does /etc/init.d/subsonic start properly start it. The lck file is left in /var/subsonic/db
After the above stop attempt, subsonic started properly (it display images now). But there is no lck file in the db directory.

Something is wrong with the startup script I think. I run as user subsonic.

The log file keeps getting null pointers trying to process non-existent art. I think this should be an exception that you catch. It is normal to not have cover art.
jarome
 
Posts: 87
Joined: Sat Apr 16, 2011 2:53 am

Re: Subsonic 5.1.beta1 released

Postby nabab » Sat Jan 10, 2015 1:48 pm

Brilliant release!
For me, if you added subtitles support for videos, and the ability to have several pictures for an album (CD booklet) the app would be just absolutely perfect... But it's great anyway!
Thank you for all your work
nabab
 
Posts: 16
Joined: Sun Aug 25, 2013 3:22 am

Re: Subsonic 5.1.beta1 released

Postby Skywatcher » Sat Jan 10, 2015 7:39 pm

WildWalker wrote:

Sindre, PLEASE can we have the option back where we could chose the number of albums visible on the front page (I used to use 15) as on smaller screen devices having lots of albums is a real pain, PLEASE :)


If at all possible, please yes. In smaller screens the amount of thumbnails is just too much at the moment. It's my main peeve with subsonic at the moment.
Skywatcher
 
Posts: 41
Joined: Tue Feb 16, 2010 7:08 am

Re: Subsonic 5.1.beta1 released

Postby sindre_mehus » Sat Jan 10, 2015 9:00 pm

Thanks for your comments regarding thumbnails etc.

To address these concerns I have implemented two different view modes: list and grid (thumbnails). The user can toggle between these directly from the artist/video page, without going to Settings.

Will be included in 5.1.beta2, hope you'll like it!

Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 5.1.beta1 released

Postby sindre_mehus » Sat Jan 10, 2015 9:02 pm

nabab wrote:Brilliant release!
For me, if you added subtitles support for videos, and the ability to have several pictures for an album (CD booklet) the app would be just absolutely perfect... But it's great anyway!
Thank you for all your work


Yeah, I've tried hard to implement subtitles but all attempts have failed due to miscellaneous technical limitations, unfortunately...
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 5.1.beta1 released

Postby sindre_mehus » Sat Jan 10, 2015 9:05 pm

JMoreau wrote:Sindre,

with version 5.0, below each "album cover", I always see a gap before the album title. (see the red arrows on the attachment).

Is it possible to fix that issue?

Thanks!


Please try the 5.1 (beta) version, this has changed quite a lot. Also, if you happen to use IE, please consider changing to another browser.
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 5.1.beta1 released

Postby manwithaplan » Sun Jan 11, 2015 12:38 am

Sindre, to simplify my earlier request, would it be possible to be able to mark a folder as 'Hidden' for certain users, so that if I have a folder of certain music files that I only want to make available to one or two users, I can do that, without affecting and confusing all other users? To simplify, that folder's contents would then not be searchable either, and if it's easier, you could just make that true regardless of which user is searching (even the users for whom the folder appears).

There are several very valid use cases for this - I tried to outline one such use case earlier, but there are many more where this would be desirable. I believe Madsonic has this, but I'd rather stay with the main codebase of Subsonic at this point.
Subsonic 5.2.1 on 2009 Apple XServe w/ Yosemite Server 10.10.5; 96GB RAM. Lots of Music - High Rez, native DSD streaming, and otherwise.
manwithaplan
 
Posts: 152
Joined: Sun Nov 28, 2010 5:01 pm

Re: Subsonic 5.1.beta1 released

Postby kargath » Sun Jan 11, 2015 3:16 am

sindre_mehus wrote:Thanks for your comments regarding thumbnails etc.

To address these concerns I have implemented two different view modes: list and grid (thumbnails). The user can toggle between these directly from the artist/video page, without going to Settings.

Will be included in 5.1.beta2, hope you'll like it!

Sindre

THANK YOU! Definitely looking forward to that. Don't get me wrong, you have a great product and I'm all for innovation. I just like having options as well since things like this typically aren't "one size fits all".
kargath
 
Posts: 33
Joined: Wed Feb 15, 2012 2:31 pm

Re: Subsonic 5.1.beta1 released

Postby markusschloesser » Tue Jan 13, 2015 2:52 pm

i think i've found the problem why starting with beta 5.1 i couldn't reach the subsonic instance anymore except from localhost (had the the same with beta 2):
"[1/13/15 3:45:01 PM CET] INFO NetworkService Deleted port mapping for port 4433"
does this refer to subsonic internals or windows firewall? both seem unlikely as upnp and "Automatically configure your router to all....." is disabled in subsonic

After adding a new (!) exception in the windows firewall rules, I can access everything fine again
markusschloesser
 
Posts: 8
Joined: Sun Jan 04, 2015 3:03 pm

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests