Sonos owners wanted for beta testing

Announcements and discussion of new releases.

Moderator: moderators

Re: Sonos owners wanted for beta testing

Postby phillipmcmahon » Tue Mar 24, 2015 9:18 pm

so i think this is to do with port mappings and router redirects.

i can get my subsonic/sonos working externally but ONLY if my router does a direct port mapping to the port that subsonic is running from. i.e. port 4040 at the router to port 4040 on the target server (or whatever port you run your subsonic server on).

i then ensure that i add the port info in the sonos customsd.htm page

e.g. http://server.phillipmcmahon.com:4040/w ... cmahon.com

if i try and get fancy :0), for example route from port 80 at the router to port 4040 on the server then yes i can authenticate the service and browse lists i CANNOT see album art or play a thing.

doing the direct port mappings then all works perfectly although it does mean that unless i run the service as root on port 80 i have to have port info in the URL which i would prefer not to and have the router do the redirect but this does not work and i think probably the source of issues for others.

i am happy to share my subsonic and password for testing. PM if you want the details.

phill
phillipmcmahon
 
Posts: 45
Joined: Sat Nov 26, 2011 10:11 am

Re: Sonos owners wanted for beta testing

Postby tmwsiy » Wed Mar 25, 2015 12:46 am

Fantastic! Thanks so very much for the help.
Nothing appears in my log when others try to play from my server.
Works perfectly fine locally.

Anyways: IP: http://108.20.181.116:8080/
user: jam
password: list

That's not an admin account, if you need that, let me know and I will send to you.

Thanks again for trying to figure this out.
tmwsiy
 
Posts: 180
Joined: Tue Apr 06, 2010 6:26 pm

Re: Sonos owners wanted for beta testing

Postby phillipmcmahon » Wed Mar 25, 2015 11:43 am

tmwsiy wrote:Fantastic! Thanks so very much for the help.
Nothing appears in my log when others try to play from my server.
Works perfectly fine locally.

Anyways: IP: http://108.20.181.116:8080/
user: jam
password: list

That's not an admin account, if you need that, let me know and I will send to you.

Thanks again for trying to figure this out.


I set this up on my sonos and it works perfectly fine. I can see your collection, album art and play tracks with no issues at all.

I can screenshot the values I out into the setup if needed. Let me know if you need anything else testing.

Do you think your original issue was router port mapping as I suggested in my previous post?
phillipmcmahon
 
Posts: 45
Joined: Sat Nov 26, 2011 10:11 am

Re: Sonos owners wanted for beta testing

Postby tmwsiy » Wed Mar 25, 2015 1:43 pm

phillipmcmahon wrote:
tmwsiy wrote:Do you think your original issue was router port mapping as I suggested in my previous post?


Great! Thanks for testing and checking it out: that's at least good news that it does work in some cases.
I was so excited to see Sindre's response that I overlooked your reply yesterday.

It very well could be the answer but I have no idea how to properly suggest to my users to set up their router.
What exactly do they need to do?
tmwsiy
 
Posts: 180
Joined: Tue Apr 06, 2010 6:26 pm

Re: Sonos owners wanted for beta testing

Postby phillipmcmahon » Wed Mar 25, 2015 3:44 pm

Your users don't need to do a thing. Your setup is working as far as I can tell.

Then need to ensure they enter the settings correctly in the Sonos custom service screen and then it should work fine just as mine did when I did it.

I can PM you a screenshot of what needs entered if needed. Let me know.
phillipmcmahon
 
Posts: 45
Joined: Sat Nov 26, 2011 10:11 am

Re: Sonos owners wanted for beta testing

Postby DoctorSmarty » Wed Mar 25, 2015 5:20 pm

A screen shot would be cool.
DoctorSmarty
 
Posts: 2
Joined: Tue Mar 24, 2015 4:01 pm

Re: Sonos owners wanted for beta testing

Postby tmwsiy » Wed Mar 25, 2015 5:22 pm

phillipmcmahon wrote:Your users don't need to do a thing. Your setup is working as far as I can tell.

Then need to ensure they enter the settings correctly in the Sonos custom service screen and then it should work fine just as mine did when I did it.

I can PM you a screenshot of what needs entered if needed. Let me know.


Hmmm, well, I have four users that can browse and access library but nothing happens when they try to play. Odd that they'd all get a setup step wrong. But yes, please send a screenshot regardless. Thanks very much for help.


And I guess I don't understand what you meant by this:
"i can get my subsonic/sonos working externally but ONLY if my router does a direct port mapping to the port that subsonic is running from. i.e. port 4040 at the router to port 4040 on the target server (or whatever port you "run your subsonic server on)."
tmwsiy
 
Posts: 180
Joined: Tue Apr 06, 2010 6:26 pm

Re: Sonos owners wanted for beta testing

Postby phillipmcmahon » Wed Mar 25, 2015 5:47 pm

Check the screenshot.

These settings work. I tested a few hours ago and just again now. I can browse, view album art and play tracks without issue.

Check your logs and you should see the activity.

Phill
phillipmcmahon
 
Posts: 45
Joined: Sat Nov 26, 2011 10:11 am

Re: Sonos owners wanted for beta testing

Postby captaintrips » Fri Mar 27, 2015 5:52 pm

this is great- I have Sonos and 150,000 tracks.
I've never been able to index them all with Sonos of course because of track limitation.
I just heard about Subsonic and added it to be able to have all my music on Sonos.
Works great! Thanks.

I am using locally and will try a remote server this weekend.
captaintrips
 
Posts: 4
Joined: Fri Mar 27, 2015 5:45 pm

Re: Sonos owners wanted for beta testing

Postby tmwsiy » Fri Mar 27, 2015 7:55 pm

is it possible to edit or view a previously setup SID?
This would be helpful to confirm values entered or make changes (like an IP that changed) without having to re-enter all the info from scratch.

thanks.
tmwsiy
 
Posts: 180
Joined: Tue Apr 06, 2010 6:26 pm

Re: Sonos owners wanted for beta testing

Postby phillipmcmahon » Fri Mar 27, 2015 8:03 pm

tmwsiy wrote:is it possible to edit or view a previously setup SID?
This would be helpful to confirm values entered or make changes (like an IP that changed) without having to re-enter all the info from scratch.

thanks.


to get round an ip change, sign yourself up for a no-ip or a dyndns URL and run the updater client either on your subsonic server or some routers support dynamic dns updates.

that way you can register the DNS and not the IP. for example this is the URL i register and it works great, even when i get a new IP.

http://server.phillipmcmahon.com:4040/w ... cmahon.com
phillipmcmahon
 
Posts: 45
Joined: Sat Nov 26, 2011 10:11 am

Re: Sonos owners wanted for beta testing

Postby tmwsiy » Sat Mar 28, 2015 4:07 am

phillipmcmahon wrote:to get round an ip change, sign yourself up for a no-ip or a dyndns URL and run the updater client either on your subsonic server or some routers support dynamic dns updates.


That's great and super helpful! thanks for that tip!
LOL, I'll have to email you to better understand what you mean by "updater client" and how to get this set-up.
While I understand dyndns and the theory, not sure how to go about doing it.

It seems like some of the Subsonic clients that I have used (Android, iOS, Web), only can be setup with format "USER.subsonic.org".
So while I have parkerfy.com and parkertunes.com pointing towards my server, they sometimes don't work.
Will this dyndns approach work with all apps?

thanks again Phill
tmwsiy
 
Posts: 180
Joined: Tue Apr 06, 2010 6:26 pm

Re: Sonos owners wanted for beta testing

Postby flacflac » Sat Mar 28, 2015 7:51 am

Thanks for the setup instructions posted by fellow Sonos users. However, has anyone made remote playback work on an SSL server?

I can get it to display the remote server, I can browse but again cannot play tracks or see album art. It seems like httpS does not work.

Any help is appreciated. Thank you. :)
flacflac
 
Posts: 141
Joined: Mon Jun 01, 2009 7:43 am

Re: Sonos owners wanted for beta testing

Postby phillipmcmahon » Sat Mar 28, 2015 8:59 am

flacflac wrote:Thanks for the setup instructions posted by fellow Sonos users. However, has anyone made remote playback work on an SSL server?

I can get it to display the remote server, I can browse but again cannot play tracks or see album art. It seems like httpS does not work.

Any help is appreciated. Thank you. :)


i got my ssl setup to work fine.

have you got it working with ssl. i would get this done first and go from there. PM if you want someone to help you out/test etc.
phillipmcmahon
 
Posts: 45
Joined: Sat Nov 26, 2011 10:11 am

Re: Sonos owners wanted for beta testing

Postby rumremix » Wed Jun 10, 2015 8:18 pm

Feature request:

In the Subsonic browser interface, I can navigate to a folder and then click "play random" to randomly play just the songs that reside in that folder. This is useful for example if I want to randomly play all artists in my Brazilian folder, or perhaps my lossless folder, without having to create a special playlist.

In Sonos, the only option I have is to shuffle play everything. This is generally not desirable. I may enjoy rock, jazz, classical, calypso, sufi meditation music, and spoken word. But that doesn't mean that I want to listen to all of these styles shuffled together at the same time.

I really would love the option to shuffle play a specific folder through sonos, similar to the web interface. Please?

Thanks!
rumremix
 
Posts: 44
Joined: Sun Jul 07, 2013 5:54 am

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 2 guests