Page 2 of 3

Re: Subsonic 5.3.beta2 released

PostPosted: Sat Aug 22, 2015 3:11 am
by bcrivers
The tops songs feature doesn't is a hit or miss, most of my artists do not have their top songs listed. A few do. Would be possible to the manually mark the top songs?

Re: Subsonic 5.3.beta2 released

PostPosted: Sat Aug 22, 2015 9:28 pm
by Skywatcher
Another vote here for being able to disable the auto hide of the folder list. Pretty please?

Re: Subsonic 5.3.beta2 released

PostPosted: Sun Aug 23, 2015 12:51 pm
by Soorploom
Some of my family and friends are, alas, thick as two short planks and can't open the hidden folders list even although I've displayed a how-to-do message. Mind you, they probably shouldn't even be anywhere near a network connection. Definitely another vote for being able to disable the auto hide of the folder list.

Please.

Re: Subsonic 5.3.beta2 released

PostPosted: Sun Aug 23, 2015 3:48 pm
by lpr
Hello,

Since 5.3 beta1 I can't access none of my media folders, I get a "Folder not found" on a Windows 10 system. I tried reverting to 5.2.1 that was working before the update and It's now broken...
Here is what I tried on beta1 and beta2. I've logged as an administrator account in Windows Services. I also did a clean install.The only thing I'm not able to do is change my music folder's owner and security settings since they are on a NAS.
It looks like something got introduced in beta1 that changed my Windows 10 permission rights or something. I really need your help, I'm dead in the water and Subsonic was my Sonos music server. I would really like not to reinstall Windows 10...

I tried some of those tips with no luck.

https://jdrch.wordpress.com/2014/12/02/ ... ning-bugs/

Thanks in advance.

Re: Subsonic 5.3.beta2 released

PostPosted: Mon Aug 24, 2015 1:19 pm
by Nico
the last.fm integration isn't showing artists info for artists that weren't rtrieved with the 5.2 version, and in my case non of the artists info that do show up display the play top tracks button. (the start radio option does work)

Re: Subsonic 5.3.beta2 released

PostPosted: Thu Sep 03, 2015 8:23 pm
by lpr
lpr wrote:Since 5.3 beta1 I can't access none of my media folders, I get a "Folder not found" on a Windows 10 system. I tried reverting to 5.2.1 that was working before the update and It's now broken...
Here is what I tried on beta1 and beta2. I've logged as an administrator account in Windows Services. I also did a clean install.The only thing I'm not able to do is change my music folder's owner and security settings since they are on a NAS.
It looks like something got introduced in beta1 that changed my Windows 10 permission rights or something. I really need your help, I'm dead in the water and Subsonic was my Sonos music server. I would really like not to reinstall Windows 10...


Nice to see that the forums are back online!

Just a quick word to say that I fixed my problem by creating a new user on my NAS that is identical to the admin user that is running Subsonic's process on the server. This new user as full read & write access to the shared folders that are on the NAS.

Re: Subsonic 5.3.beta2 released

PostPosted: Fri Sep 04, 2015 9:49 pm
by jayw654
This is a DIRECT reply to Sindre Mehus about subsonic. Sindre you have made great strides i making Subsonic a great music streamer but it seems a very important request that is VERY legitimate has NOT been fulfilled for over 3 1/2 years. I know this because I have been watching for you to add Flac support in the browser web player. Reason is most people aren't very savvy so asking a person to install a client app for the support is out of the question. I have been told by many of your testers/loyalist that lossless support is coming to Subsonic in the browser web interface but has not come. Lossless is EXTREMELY important as people are seeing the benefits of having lossless and enjoying higher quality playback with other sources and bandwidth isn't much of an issue anymore so no reason not the add such support. I didn't spend 350 bucks for a pair of headphones to listen to MP3's. No down converting a lossless file to MP3 is certainly NOT acceptable either as the point is to get high quality playback. I plan to buy another streaming software when I get my tax check early next year that will bring the support I need. If you can't add the lossless I need then I'm forced simply forget Subsonic altogether. Hopefully you have some sort of interest in adding the support needed so I won't be forced to make a purchase elsewhere. I already commited in providing a 50 dollar donation if your payment system will allow it, and if the support needed is added. If you want people to support your product you need to give them what they want or they'll simply omit you and get what they need elsewhere. I'm not interested in anymore leads and false promises 6 months is plenty of time to get the support implemented after that I'm jumping ship, end of story.

Re: Subsonic 5.3.beta2 released

PostPosted: Sat Sep 05, 2015 12:37 pm
by frnx
@jayw654: Neither Chrome (45) nor Firefox (42a02) support FLAC on my computer, and I only found traces of people writing FLAC decoders for Flash and ending up disappointed. There's flac.js for JavaScript decoding, but after trying it out it started stuttering as soon as something on my browser started doing CPU-intensive tasks. Trying with FLAC-in-OGG yielded similar results.

Why don't you add a converter from FLAC to WAVE in Subsonic's transcoder settings (the "flac -d" command does the trick)? This will be supported natively by your browser and Flash, will not degrade the quality, obviously at the cost of occupying slightly more bandwidth (e.g. a 35M FLAC file is converted to a 47M WAVE file).

Re: Subsonic 5.3.beta2 released

PostPosted: Sat Sep 05, 2015 11:26 pm
by jayw654
ok if I uninstall flash WAV WILL work in the following browsers under HTML5:
Firefox = Success
Opera=Success but the playlist overlay acts a bit touchy and erratic
Chrome=Fail which is the most used browser currently even though Firefox is better. Please get Chrome support fixed and we're good.

Explorer or edge does NOT have native support for WAV so so no expectations for it to work in those browsers.

Lastly it works great on mobile device via DSUB

BTW I did not use the coverter I just dumped raw wav files onto the server. Don't like transcoding as it eats resources needlessly.

Re: Subsonic 5.3.beta2 released

PostPosted: Sun Sep 06, 2015 1:51 pm
by frnx
Weird, on my Chrome WAVE works just fine. According to this compatibility matrix found on MDN it should work on your end too...

Re: Subsonic 5.3.beta2 released

PostPosted: Sun Sep 06, 2015 6:13 pm
by grumpwagon
I have 2 issues and a request with the beta (I didn't try b1, so they may have been introduced then).

1) Some but not all of the album pictures (or podcast cover images) get tinted with random shades of color. Right now they're pink, but they have been yellow before. I believe it only happens when the server attempts to scale the size of the picture up/down, because clicking on the image fixes the tint. Here's an example:
Image

2) Artist info/Related artists do not show up for me on the web client. However, dsub is able to retrieve them, so they're clearly there. More info in the help forum, here.


The request is to add the awesome new "newest podcast" functionality to the API so dsub can add it.

Thanks!

Re: Subsonic 5.3.beta2 released

PostPosted: Tue Sep 08, 2015 3:28 pm
by Nico
Nico wrote:the last.fm integration isn't showing artists info for artists that weren't rtrieved with the 5.2 version, and in my case non of the artists info that do show up display the play top tracks button. (the start radio option does work)

I take this above issue back: it works wonderfully in the web browser ! 8)

Re: Subsonic 5.3.beta2 released

PostPosted: Sat Sep 19, 2015 11:01 pm
by Override92
grumpwagon wrote:I have 2 issues and a request with the beta (I didn't try b1, so they may have been introduced then).

1) Some but not all of the album pictures (or podcast cover images) get tinted with random shades of color. Right now they're pink, but they have been yellow before. I believe it only happens when the server attempts to scale the size of the picture up/down, because clicking on the image fixes the tint.

Thanks!


viewtopic.php?f=2&t=14711

Override

Re: Subsonic 5.3.beta2 released

PostPosted: Mon Sep 21, 2015 10:57 am
by phillipmcmahon
When using the chromecast feature it skips a track straight after finishing the track it is playing, then moves onto the next one.

track 1 - plays
track 2 - instantly skipped
track 3 - plays
track 4 - instantly skipped

Hopefully a simple fix...

Phill

Re: Subsonic 5.3.beta2 released

PostPosted: Mon Sep 28, 2015 7:54 pm
by grumpwagon
Override92 wrote:
grumpwagon wrote:I have 2 issues and a request with the beta (I didn't try b1, so they may have been introduced then).

1) Some but not all of the album pictures (or podcast cover images) get tinted with random shades of color. Right now they're pink, but they have been yellow before. I believe it only happens when the server attempts to scale the size of the picture up/down, because clicking on the image fixes the tint.

Thanks!


viewtopic.php?f=2&t=14711

Override


I've replied with an example in that thread.