Subsonic 6.0.beta1 released

Announcements and discussion of new releases.

Moderator: moderators

Subsonic 6.0.beta1 released

Postby sindre_mehus » Fri Feb 05, 2016 7:27 pm

Hi all,

The biggest release in a long time is ready for a test run:

New: Completely overhauled user interface.
New: HTML5 audio and video playback.
New: Integrated video converter for converting to streamable MP4 format. Selectable audio track.
New: Video subtitles, also on Chromecast. Supports SRT and VTT formats.
New: Keyboard shortcuts (press "?" to get started).
New: New "Index" page replaces artist list in left frame.
New: Artist thumbnail image and album notes (from Last.fm).
New: Show album year, song count, genre and duration
New: Show personal rather than average rating.
Sonos: Star/unstar tracks.
Sonos: Artist bio and album notes.
Sonos: Improved radio feature.
Sonos: Artist top songs.
Sonos: Nicer presentation on Android and iOS controllers.
Sonos: Show artist image, if cached.
REST: Added getAlbumInfo and getAlbumInfo2.
REST: Added playCount.
REST: Added musicFolderId parameter to getArtists.
Bugfix: Reimplemented cover art search using Last.fm.
Bugfix: Ensure changed cover art is displayed.
Security: Authenticate stream endpoints with tokens.

Looking forward to your feedback!
Sindre :)
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1954
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 6.0.beta1 released

Postby acroyear » Fri Feb 05, 2016 8:34 pm

Behind the scenes, did you update or change the version of ffmpeg? I'm finding that a long-standing issue with Chrome on Android's html5 tag has been resolved (or more specifically, I sent the support/dev person to the demo site, which didn't work for me yesterday, and found it worked for him). I'm not seeing anything different in the raw http request/response headers to indicate some hint that would get the audio tag to work properly.

Also, is the transcoding applied for all mp3 playback, or only when downsampling to a lower bitrate? When I downsample to 80 on the new server, I still get the bug. If I leave it unlimited, I no longer do.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 592
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Subsonic 6.0.beta1 released

Postby frnx » Fri Feb 05, 2016 8:35 pm

Yeeehaa, shortcuts! :D

So far no issues with the beta, no errors in the logs and DSub is not complaining either. The new keyboard shortcuts are great, and desktop notifications are showing up properly (they didn't always show with 5.3, not sure what caused it). Really nice job!

Just my .02€ : having one menu on the top and one on the left seems overkill now that the artist list is gone from the left menu. Also, that awesome new player lacks a "star" button (with an associated shortcut), if it's not too hard to add now!
frnx
 
Posts: 44
Joined: Sun May 31, 2015 8:30 pm

Re: Subsonic 6.0.beta1 released

Postby acroyear » Fri Feb 05, 2016 8:46 pm

Actually, top for core stuff, hidden/toggle side menu with 'burger' is a pretty common UI pattern now, especially under material design. consider the top menu more "tabs" than a menu. Subfire does this as well. All that is unusual is that the left-side menu defaults to expanded, but that's a matter of introducing people to the new pattern.

Maybe leave it expanded in the beta and default it 'closed' for the final release?
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 592
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Subsonic 6.0.beta1 released

Postby frnx » Fri Feb 05, 2016 8:56 pm

acroyear wrote:Actually, top for core stuff, hidden/toggle side menu with 'burger' is a pretty common UI pattern now


I'm not saying it doesn't look nice, It's just that having a full left panel for only 4 links seems like a waste of space. Well, I can always keep it closed, but still. :)
frnx
 
Posts: 44
Joined: Sun May 31, 2015 8:30 pm

Re: Subsonic 6.0.beta1 released

Postby xtxer » Fri Feb 05, 2016 9:01 pm

I'm not having much luck with this update, I'll have to roll back for now.

1. The layout does not work on my main browser- qutebrowser. This may be a niche browser but its rendering engine is qtwebkit, so I'm sure this affects many browsers besides mine: https://imgur.com/mnVhj1V
2. For Music, is there a way to see my folders? Not sure if I'm missing this. So far I can only see how to organize by random, recently added, starred, etc... can I no longer organize by my folder structure? My folder structure is Artist/Album... if I want to listen to an album by ZZ_Top how am I supposed to quickly do this now?
3. When I click on a movie to stream it says "The video must be converted to a streamable format (mp4 with h264/aac codec) before you can watch it". This... isn't ideal... but even worse is when I click on "Start video conversion", the converstion status simply says Error. And I don't seem to see the Logs to review from the web interface anymore either.

Not trying to rain on the parade, just trying to share my experience so that hopefully some bugs can be sorted out for the final release.
xtxer
 
Posts: 15
Joined: Fri Mar 15, 2013 12:28 am

Re: Subsonic 6.0.beta1 released

Postby frnx » Fri Feb 05, 2016 9:08 pm

xtxer wrote:3. When I click on a movie to stream it says "The video must be converted to a streamable format (mp4 with h264/aac codec) before you can watch it". This... isn't ideal... but even worse is when I click on "Start video conversion", the converstion status simply says Error. And I don't seem to see the Logs to review from the web interface anymore either.


I don't stream video a lot so I haven't tried very hard, but it's true that I've never been able to make video streaming work out of the box with Subsonic. After your comment I just tried using the recommended transcoding settings from the official docs in the beta, no luck either. Would be interested in hearing about this if it is solved!
Last edited by frnx on Fri Feb 05, 2016 9:09 pm, edited 1 time in total.
frnx
 
Posts: 44
Joined: Sun May 31, 2015 8:30 pm

Re: Subsonic 6.0.beta1 released

Postby acroyear » Fri Feb 05, 2016 9:09 pm

The music folder structure is under "Index".

As for conversions, when I looked in Settings->Transcoding, I found that the entries for flv/h264 video and mkv video were missing. They're still in my 5.3. Maybe adding those entries back will resolve the video?
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 592
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Subsonic 6.0.beta1 released

Postby acroyear » Fri Feb 05, 2016 9:22 pm

also, the automatic conversion (to mp4) works by making a copy of the movie in the same folder (with the added suffix .streamable.mp4). If the folder isn't writable (or out of disk space), that may cause an error.

with that automatic conversion, I worry about the amount of disk space used for movies, as it can, over time, double the size of one's collection. For myself, not a big issue as I'm still using Plex for my video, but something to consider.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 592
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Subsonic 6.0.beta1 released

Postby sindre_mehus » Fri Feb 05, 2016 9:34 pm

acroyear wrote:Behind the scenes, did you update or change the version of ffmpeg? I'm finding that a long-standing issue with Chrome on Android's html5 tag has been resolved (or more specifically, I sent the support/dev person to the demo site, which didn't work for me yesterday, and found it worked for him). I'm not seeing anything different in the raw http request/response headers to indicate some hint that would get the audio tag to work properly.

Also, is the transcoding applied for all mp3 playback, or only when downsampling to a lower bitrate? When I downsample to 80 on the new server, I still get the bug. If I leave it unlimited, I no longer do.


ffmpeg version is the same, but the handling of http range requests has been improved, which could explain this. Transcoding only happens when necessary. (The problem with transcoding is that it's difficult to set the correct content-length, as well as handle range requests).
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1954
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 6.0.beta1 released

Postby sindre_mehus » Fri Feb 05, 2016 9:37 pm

acroyear wrote:Actually, top for core stuff, hidden/toggle side menu with 'burger' is a pretty common UI pattern now, especially under material design. consider the top menu more "tabs" than a menu. Subfire does this as well. All that is unusual is that the left-side menu defaults to expanded, but that's a matter of introducing people to the new pattern.

Maybe leave it expanded in the beta and default it 'closed' for the final release?


The current behaviour is as follows:

1. For new users, the left-side menu is by default collapsed.
2. Subsonic remembers the state of the menu (per user), so when you start a new session it will be restored to the same state as previously.
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1954
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 6.0.beta1 released

Postby sindre_mehus » Fri Feb 05, 2016 9:44 pm

xtxer wrote:I'm not having much luck with this update, I'll have to roll back for now.

1. The layout does not work on my main browser- qutebrowser. This may be a niche browser but its rendering engine is qtwebkit, so I'm sure this affects many browsers besides mine: https://imgur.com/mnVhj1V
2. For Music, is there a way to see my folders? Not sure if I'm missing this. So far I can only see how to organize by random, recently added, starred, etc... can I no longer organize by my folder structure? My folder structure is Artist/Album... if I want to listen to an album by ZZ_Top how am I supposed to quickly do this now?
3. When I click on a movie to stream it says "The video must be converted to a streamable format (mp4 with h264/aac codec) before you can watch it". This... isn't ideal... but even worse is when I click on "Start video conversion", the converstion status simply says Error. And I don't seem to see the Logs to review from the web interface anymore either.

Not trying to rain on the parade, just trying to share my experience so that hopefully some bugs can be sorted out for the final release.


1. I saw the same problem in IE and added an (IE-specific) CSS hack for it. I'll see what I can do about this.
2. Click the "Index" button in the top bar.
3. To see the Subsonic log, open the left-side menu and click "About Subsonic". There is also a separate log file for the conversion in the same directory as the video file.
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1954
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 6.0.beta1 released

Postby Skywatcher » Fri Feb 05, 2016 9:55 pm

sindre_mehus wrote:
xtxer wrote:I'm not having much luck with this update, I'll have to roll back for now.

1. The layout does not work on my main browser- qutebrowser. This may be a niche browser but its rendering engine is qtwebkit, so I'm sure this affects many browsers besides mine: https://imgur.com/mnVhj1V
2. For Music, is there a way to see my folders? Not sure if I'm missing this. So far I can only see how to organize by random, recently added, starred, etc... can I no longer organize by my folder structure? My folder structure is Artist/Album... if I want to listen to an album by ZZ_Top how am I supposed to quickly do this now?
3. When I click on a movie to stream it says "The video must be converted to a streamable format (mp4 with h264/aac codec) before you can watch it". This... isn't ideal... but even worse is when I click on "Start video conversion", the converstion status simply says Error. And I don't seem to see the Logs to review from the web interface anymore either.

Not trying to rain on the parade, just trying to share my experience so that hopefully some bugs can be sorted out for the final release.


1. I saw the same problem in IE and added an (IE-specific) CSS hack for it. I'll see what I can do about this.


1. Having a similar problem in Edge on Windows 10. A large horizontal white bar that won't go away.
http://imgur.com/PAL6PfN
Skywatcher
 
Posts: 41
Joined: Tue Feb 16, 2010 7:08 am

Re: Subsonic 6.0.beta1 released

Postby keiichi000 » Fri Feb 05, 2016 10:03 pm

Okay, I created a forum account just to express this. I've had Subsonic for quite a long time and have loved the product, but I must say, I REALLY REALLY hate the redesign. This feels like a step backwards in usability for anyone who uses it through a browser:

1). **BUG** Changing folders on any screen does not work. It's defaulting to whatever folder I had last chosen, and won't move to any other folder.
2). Losing the always on Artist Panel is almost a deal breaker for me. It extremely limits the usefulness of the application
3). Replacing it with 4 icons in that left panel is almost a slap in the face. Please get rid of the four icon side panel and give us back our artist roll on the side. Those 4 items should be icons on the top, not a separate side panel.
4). The always on player at the bottom feels really unnecessary. Can we have a configuration option to turn this off as well?

Just all in all, completely dissatisfied with the new look and feel, and really tempted to just roll back to 5.3. That's how much I hate it. Or perhaps can you add an option for perhaps 'classic' vs 'modern' mode? This really concerns me, since I RARELY use the interface to play music, I log into the HTML interface to maintain my Subsonic collection. For playing music, I use the various mobile apps. So these features are a complete step back, since it makes moving through my music collection take about 5 extra steps to do things.

Thanks
Last edited by keiichi000 on Fri Feb 05, 2016 11:30 pm, edited 1 time in total.
keiichi000
 
Posts: 3
Joined: Fri Feb 05, 2016 9:49 pm

Re: Subsonic 6.0.beta1 released

Postby xtxer » Fri Feb 05, 2016 10:21 pm

sindre_mehus wrote:
1. I saw the same problem in IE and added an (IE-specific) CSS hack for it. I'll see what I can do about this.
2. Click the "Index" button in the top bar.
3. To see the Subsonic log, open the left-side menu and click "About Subsonic". There is also a separate log file for the conversion in the same directory as the video file.


1. Thanks Sindre!
2. Got it, works for me.
3. The log says "Error when reading output from video converter" "ffmpeg exit value: 141" Most likely the issue is that subsonic cannot write to my video directory... somebody above mentioned that it's going to make a .streamable.mp4 video every time somebody wants to watch something? Why this change? Subsonic was playing html5 just fine on my computer before the upgrade when flash wasn't installed... I have 5 TBs worth of movies and definitely don't have 5 TBs extra space to double everything lol
xtxer
 
Posts: 15
Joined: Fri Mar 15, 2013 12:28 am

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests