Subsonic 6.0.beta2 released

Announcements and discussion of new releases.

Moderator: moderators

Subsonic 6.0.beta2 released

Postby jmoonen » Sat Mar 26, 2016 11:49 am

Left menu can be activated again :-)
It works with Edge

Will do a complete test this evening

THX sindre
jmoonen
 
Posts: 9
Joined: Wed Oct 24, 2012 8:10 am

Re: Subsonic 6.0.beta2 released

Postby sauriodino » Sat Mar 26, 2016 5:28 pm

:arrow: The INDEX icon changed, now is more intuitive
:arrow: Icon over the albumart to load all songs to the playlist
:arrow: Repeat button on the player
:arrow: Star button on the player to favourite (the album?) I havent tried. :mrgreen:
:arrow: Internet TV/radio is back in the left menu
:arrow: New tv/radio player.

Thanks Sindre.
User avatar
sauriodino
 
Posts: 21
Joined: Fri Aug 03, 2012 3:14 am

Re: Subsonic 6.0.beta2 released

Postby mjeppo » Sat Mar 26, 2016 7:19 pm

Remote control function on the android subsonic app does not seem to function anymore with the beta2 release... :(
Streaming seems to start but no audio and player turns back to start after about 3 seconds. Switched back to beta1 and everything works fine again.
9.445 artiesten
21.140 albums
342.780 songs
14998,37 GB
28.673 uren
User avatar
mjeppo
 
Posts: 20
Joined: Thu Oct 20, 2011 8:18 am
Location: Groningen, the Netherlands

Re: Subsonic 6.0.beta2 released

Postby Jägs » Sat Mar 26, 2016 9:27 pm

Still having external playlist issues: viewtopic.php?f=2&t=16390
Jägs
 
Posts: 86
Joined: Wed Apr 06, 2011 9:52 pm

Re: Subsonic 6.0.beta2 released

Postby n0tsane » Sat Mar 26, 2016 10:54 pm

Installed from 6.0 beta1 and now get this message constantly: Failed to find parameter: instanceId

From the service log
Code: Select all
[btpool0-2] ERROR org.directwebremoting.dwrp.Batch - Failed to find parameter: instanceId, enable debug logging to see more info.
n0tsane
 
Posts: 5
Joined: Fri Aug 01, 2014 2:11 am

Re: Subsonic 6.0.beta2 released

Postby acroyear » Sun Mar 27, 2016 3:12 am

n0tsane wrote:Installed from 6.0 beta1 and now get this message constantly: Failed to find parameter: instanceId

From the service log
Code: Select all
[btpool0-2] ERROR org.directwebremoting.dwrp.Batch - Failed to find parameter: instanceId, enable debug logging to see more info.


Known issue. The browser cache is holding onto an older version of a file.

Do a "hard" reload by holding shift while hitting the browser's reload button, or control-f5. On Chrome, you can press on the reload button and you'll see "Hard Reload", which all do the same thing.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 592
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Subsonic 6.0.beta2 released

Postby tom_22 » Sun Mar 27, 2016 9:12 am

:-)

Video transcoding is enabled again, THX Sindre!!
tom_22
 
Posts: 19
Joined: Sun Jun 21, 2009 10:58 pm
Location: UK

Re: Subsonic 6.0.beta2 released

Postby bcrivers » Mon Mar 28, 2016 2:52 am

Nothing but love on this release..it is working great. No issues to report, other than having a drop down option for selecting a playlist. Once you have more than 30 or so playlists, it takes some time to find them. Great release so far!
bcrivers
 
Posts: 23
Joined: Sun Aug 28, 2011 10:20 pm

Re: Subsonic 6.0.beta2 released

Postby psoi » Mon Mar 28, 2016 8:12 am

Also have a problem with external player with playlist option (using foobar2000 v1.3.5):
Unable to open item for playback (Access to file 149320 is forbidden for user xxxxxx (403)):
"http://subsonic.xxx.xxx.xx/stream?player=3&id=149320&suffix=.mp3"


/var/subsonic/subsonic.log
Code: Select all
[2016-03-28 11:08:53,949] DEBUG StreamController - GET /stream?player=3&id=149320&suffix=.mp3, Range: null
[2016-03-28 11:08:53,951] WARN SecurityService - Unauthenticated access attempt: Datalinks
[2016-03-28 11:08:54,227] DEBUG StreamController - GET /stream?player=3&id=149321&suffix=.mp3, Range: null
[2016-03-28 11:08:54,261] WARN SecurityService - Unauthenticated access attempt: Unlimited
[2016-03-28 11:08:55,096] DEBUG StreamController - GET /stream?player=3&id=149322&suffix=.mp3, Range: null
[2016-03-28 11:08:55,097] WARN SecurityService - Unauthenticated access attempt: Neighbour of the Beast
[2016-03-28 11:08:56,109] DEBUG StreamController - GET /stream?player=3&id=149323&suffix=.mp3, Range: null
[2016-03-28 11:08:56,110] WARN SecurityService - Unauthenticated access attempt: Marauder
[2016-03-28 11:08:57,086] DEBUG StreamController - GET /stream?player=3&id=149324&suffix=.mp3, Range: null
[2016-03-28 11:08:57,087] WARN SecurityService - Unauthenticated access attempt: Future Uncertain
[2016-03-28 11:08:58,127] DEBUG StreamController - GET /stream?player=3&id=149325&suffix=.mp3, Range: null
[2016-03-28 11:08:58,128] WARN SecurityService - Unauthenticated access attempt: High Density
[2016-03-28 11:08:59,131] DEBUG StreamController - GET /stream?player=3&id=149326&suffix=.mp3, Range: null
[2016-03-28 11:08:59,132] WARN SecurityService - Unauthenticated access attempt: Normalised
[2016-03-28 11:09:00,074] DEBUG StreamController - GET /stream?player=3&id=149327&suffix=.mp3, Range: null
[2016-03-28 11:09:00,075] WARN SecurityService - Unauthenticated access attempt: Compact Living
[2016-03-28 11:09:01,086] DEBUG StreamController - GET /stream?player=3&id=149328&suffix=.mp3, Range: null
[2016-03-28 11:09:01,087] WARN SecurityService - Unauthenticated access attempt: Hund
[2016-03-28 11:09:02,138] DEBUG StreamController - GET /stream?player=3&id=149329&suffix=.mp3, Range: null
[2016-03-28 11:09:02,140] WARN SecurityService - Unauthenticated access attempt: Drop by anytime

psoi
 
Posts: 2
Joined: Mon Feb 15, 2016 8:38 am

Re: Subsonic 6.0.beta2 released

Postby Neil Hunt » Mon Mar 28, 2016 11:05 am

I originally posted this on the beta1 thread but it belongs here:

My Internet Radio has stopped working since 6.0beta 2. I get the error message "Unsupported media format" whether the Stream URL link points to a PLS, M3U or any other playlist format. Only direct links to MP3 files work.

Any ideas how to fix this?
Neil Hunt
 
Posts: 13
Joined: Thu May 24, 2012 7:57 pm

Re: Subsonic 6.0.beta2 released

Postby sindre_mehus » Mon Mar 28, 2016 1:20 pm

Jägs wrote:Still having external playlist issues: viewtopic.php?f=2&t=16390


My mistake. Will be fixed in the final version.
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1954
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 6.0.beta2 released

Postby taterb » Mon Mar 28, 2016 1:24 pm

Getting permissions problem when attempting to change Internet Radio settings as admin user:
Forbidden
You don't have permission to access /subsonic/internetRadioSettings.view on this server.
taterb
 
Posts: 5
Joined: Thu Apr 29, 2010 3:49 pm

Re: Subsonic 6.0.beta2 released

Postby Skywatcher » Mon Mar 28, 2016 1:29 pm

Neil Hunt wrote:I originally posted this on the beta1 thread but it belongs here:

My Internet Radio has stopped working since 6.0beta 2. I get the error message "Unsupported media format" whether the Stream URL link points to a PLS, M3U or any other playlist format. Only direct links to MP3 files work.

Any ideas how to fix this?


I've just added a couple of internet radio stations to 6.0b2 with no issues.
Try http://radio.linnrecords.com/cast/tunei ... aylist.pls for instance to see if it works. Just added it here and it's working OK.

Cheers,


Edit: Odd behaviour. It works until I log out and login again. Then I start getting the unsupported format error. :shock:
Skywatcher
 
Posts: 41
Joined: Tue Feb 16, 2010 7:08 am

Re: Subsonic 6.0.beta2 released

Postby taterb » Mon Mar 28, 2016 1:36 pm

The inability to add a new Internet station doesn't appear dependent on the URL.
Anything I put into those fields in IE, Opera, Chrome or FF results in a Forbidden msg upon Save.

EDIT: Also getting Unsupported format msgs for radio links too.
taterb
 
Posts: 5
Joined: Thu Apr 29, 2010 3:49 pm

Re: Subsonic 6.0.beta2 released

Postby Neil Hunt » Mon Mar 28, 2016 4:44 pm

Skywatcher wrote:I've just added a couple of internet radio stations to 6.0b2 with no issues.
Try http://radio.linnrecords.com/cast/tunei ... aylist.pls for instance to see if it works. Just added it here and it's working OK.

Cheers,


Edit: Odd behaviour. It works until I log out and login again. Then I start getting the unsupported format error. :shock:


No luck with your URL, I still get "Unsupported media format".
Neil Hunt
 
Posts: 13
Joined: Thu May 24, 2012 7:57 pm

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests