Subsonic 6.0.beta2 released

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic 6.0.beta2 released

Postby Neil Hunt » Mon Mar 28, 2016 4:55 pm

taterb wrote:The inability to add a new Internet station doesn't appear dependent on the URL.
Anything I put into those fields in IE, Opera, Chrome or FF results in a Forbidden msg upon Save.

EDIT: Also getting Unsupported format msgs for radio links too.


Could you try this URL: http://stream2.sbs.fi/rc-hki.mp3

It works for me as do all links ending in .MP3
Neil Hunt
 
Posts: 13
Joined: Thu May 24, 2012 7:57 pm

Re: Subsonic 6.0.beta2 released

Postby Jägs » Tue Mar 29, 2016 12:58 am

Thanks for your attention to this matter! Do you have an ETA of the final version? Just trying to determine if I should roll back or wait.

sindre_mehus wrote:
Jägs wrote:Still having external playlist issues: viewtopic.php?f=2&t=16390


My mistake. Will be fixed in the final version.
Jägs
 
Posts: 92
Joined: Wed Apr 06, 2011 9:52 pm

Re: Subsonic 6.0.beta2 released

Postby DimaH » Tue Mar 29, 2016 2:59 am

Hello! When I start subsonic 6.0.beta2 (standalone) all ok, but when connect to server from ie 11 (Windows 10), the error appears in the console:
1623399 [btpool0-7] INFO org.directwebremoting.servlet.UrlProcessor - Probably n
ot an issue: the url:/gi.js (org.directwebremoting.gi.GiHandler) Handler is not
available. This is only an problem if you wanted to use it.

What this can be?
Thanks!
DimaH
 
Posts: 14
Joined: Thu May 14, 2009 4:35 am

Re: Subsonic 6.0.beta2 released

Postby MonsterMuffin » Tue Mar 29, 2016 11:31 am

DimaH wrote:Hello! When I start subsonic 6.0.beta2 (standalone) all ok, but when connect to server from ie 11 (Windows 10), the error appears in the console:
1623399 [btpool0-7] INFO org.directwebremoting.servlet.UrlProcessor - Probably n
ot an issue: the url:/gi.js (org.directwebremoting.gi.GiHandler) Handler is not
available. This is only an problem if you wanted to use it.

What this can be?
Thanks!


Just tested IE11 at work and everything worked as you'd hope.
MonsterMuffin
 
Posts: 14
Joined: Tue Mar 10, 2015 10:04 am

Re: Subsonic 6.0.beta2 released

Postby insann » Tue Mar 29, 2016 6:18 pm

Hi,

You missed to add the new french translation in the new beta release !!

http://forum.subsonic.org/forum/viewtopic.php?f=8&t=3827

Could you add a transcode to the unplayable radio streams ?? because using firefox, AAC radios and html5 audio player don't work ! and that's bad :) ;p

EDIT : btw the html5 shared playlists don't work in firefox either ... i think you really need to transcode all those things ! ( its maybe my mistake but i'm maybe right !)
(END EDIT )

here is a link who don't work :

http://pub1.diforfree.org:8000/di_downtempolounge_hi

so if you can send to transcode to after restream to the html5 player it would be great !

in the playlist queue the share icone don't work or they aren't any ! maybe add this one : ( or one who looks like its just an idea ! )

http://www.innotta.com.au/wp-content/uploads/media/Icon_INNOTTA-SHARE-250.png

YOU'RE WEP APP IS AWESOME !!!

Thanks Sindre !

And little other topic you should consider :
http://forum.subsonic.org/forum/viewtopic.php?f=3&t=16401

Insann
insann
 
Posts: 39
Joined: Sat Nov 14, 2015 6:37 pm

Re: Subsonic 6.0.beta2 released

Postby phazzard » Tue Mar 29, 2016 11:36 pm

I love the new design and look - My only question is how do I get the index back in the left column - Seems like such a waste of space to have logout / settings / etc on left side but no index? Lots of blank space on left side now. Having the index in a page format like this is not easy to look for a specific artist when you have a huge collection and have to scroll with your eyes left to right line after line. Logout should not be in left column, it should be in the top bar - If you have the left column collapsed you have to extend it anytime you want to log out? Where do I find the count of songs / albums / etc?
Thanks
phazzard
 
Posts: 45
Joined: Thu Jul 08, 2010 6:43 pm

Re: Subsonic 6.0.beta2 released

Postby deejay2302 » Wed Mar 30, 2016 12:15 am

n0tsane wrote:Installed from 6.0 beta1 and now get this message constantly: Failed to find parameter: instanceId

From the service log
Code: Select all
[btpool0-2] ERROR org.directwebremoting.dwrp.Batch - Failed to find parameter: instanceId, enable debug logging to see more info.




I have the same Message. Ever and ever.... What can i do?

@Sindre And another bug is at the Graphic at lower left side. I can not see the graphic.^^
21.681 Artists
58.141 Albums
674.091 Songs
5072,14 GB (~ 49.341 Hours)
User avatar
deejay2302
 
Posts: 163
Joined: Tue Oct 06, 2009 5:36 pm
Location: Germany

Re: Subsonic 6.0.beta2 released

Postby phazzard » Wed Mar 30, 2016 12:43 am

OK this is looking really good - Everything seems to be working - Found the Artist / Album count under About Subsonic and was able to add the artist list back to the left panel by going to settings / personal and clicking show index in left sidebar - Very nice job!
Thanks
phazzard
 
Posts: 45
Joined: Thu Jul 08, 2010 6:43 pm

Re: Subsonic 6.0.beta2 released

Postby tocheeba » Wed Mar 30, 2016 1:07 am

^ I agree with the post above me. Index / Playlists should be in the left menu as well - at least give us an option. I think the index browsing is super awkward.
tocheeba
 
Posts: 15
Joined: Wed Jul 06, 2011 5:05 pm

Re: Subsonic 6.0.beta2 released

Postby kosmos » Wed Mar 30, 2016 8:03 am

First some good news...

Page layout within Microsoft Edge browser is properly formatted, nice work Sindre.

And now for a problem.

The Link 'Save As Playlist' does nothing. This behaviour is to be found in both Internet Explorer 11 and Microsoft Edge. Suggesting a permissions problem perhaps? There is no activity recorded in the log for when I try to save the currently playing tracks as a playlist, simply nothing happens. Which is a bit of an embuggerance since the only way I can now create a playlist is to make an empty one under the playlists menu, pick songs, from my currently playing queue and then add them to the existing playlist. Things get even more complicated when I change the play order. Since Save as Playlist doesn't work I have to delete the existing playlist, create a new empty one, arrange the tracks in the order I like select them then add them to the empty playlist.
kosmos
 
Posts: 9
Joined: Fri Jul 08, 2011 8:46 pm

Re: Subsonic 6.0.beta2 released

Postby ozzyrb5 » Wed Mar 30, 2016 11:41 pm

Hi is anyone having issues with Sonos with the latest Beta release?

Mine was working perfectly but I updated my Synology DS215j with the latest DSM 6 as well as installing the latest Beta.

I had to hack the nginx config to allow me to run Subsonic on port 80 and stop the auto-forward to port 5000.

I've been using the browser client since upgrading at the weekend and my iSub and AVsub apps work on my iPhone and iPad, but when I try to use Sonos I'm getting timeouts browsing larger folders in my Library. I have folders setup as 0-#, A-B, C-D.....Y-Z. The smaller folders such as Y-Z work fine, but larger folders timeout and throw an 'Unable to browse Music' error.

Subsonic and Sonos are registering automatically. I can browse the larger Recently Added / Random album lists, it just seems to affect the folder lists. Tracks do play but sometimes it timesout and will stop attempting to play the track (message connection with Subsonic lost), but then re-connect and resume the track.

I have found browsing via Sonos controller noticeable slower and album art / folders don't refresh as quick as before.

Just looking for some debug suggestions before I roll back the Beta or try to reset the DSM to ver 5.

Thanks
ozzyrb5
 
Posts: 12
Joined: Tue Jul 23, 2013 11:29 pm

Re: Subsonic 6.0.beta2 released

Postby ozzyrb5 » Thu Mar 31, 2016 12:15 am

Appears if I modify the subsonic.sh file and change SUBSONIC_HOST=0.0.0.0 to the LAN IP of the Synology then Sonos can now browse the larger folders.

Suspect it's the nginx config rather than the Beta causing the issue
ozzyrb5
 
Posts: 12
Joined: Tue Jul 23, 2013 11:29 pm

Re: Subsonic 6.0.beta2 released

Postby baxtr » Thu Mar 31, 2016 1:35 am

phazzard wrote:I love the new design and look - My only question is how do I get the index back in the left column - Seems like such a waste of space to have logout / settings / etc on left side but no index? Lots of blank space on left side now. Having the index in a page format like this is not easy to look for a specific artist when you have a huge collection and have to scroll with your eyes left to right line after line. Logout should not be in left column, it should be in the top bar - If you have the left column collapsed you have to extend it anytime you want to log out? Where do I find the count of songs / albums / etc?
Thanks



in settings/personal one of the checkboxes is "show index in left sidebar"
baxtr
 
Posts: 99
Joined: Sat Feb 13, 2010 4:19 am

Re: Subsonic 6.0.beta2 released

Postby noxon » Thu Mar 31, 2016 8:03 am

Slight annoyance:

When returning to the web page, it'll register whichever song I was playing before i left the web page again as Now Playing - both in the interface locally and with last.fm. The track isn't playing, it has just been loaded into the player.
noxon
 
Posts: 14
Joined: Thu Apr 30, 2009 12:38 pm

Re: Subsonic 6.0.beta2 released

Postby mockingbrd » Thu Mar 31, 2016 1:20 pm

noxon wrote:Slight annoyance:

When returning to the web page, it'll register whichever song I was playing before i left the web page again as Now Playing - both in the interface locally and with last.fm. The track isn't playing, it has just been loaded into the player.


Came here to post the same thing. I'm using Firefox 45.0.1.

Thanks for the continued updates!
mockingbrd
 
Posts: 49
Joined: Wed Feb 23, 2011 4:09 pm

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest