Subsonic Android 1.4 released

Announcements and discussion of new releases.

Moderator: moderators

Subsonic Android 1.4 released

Postby sindre_mehus » Wed Jul 07, 2010 11:38 am

Just released Subsonic Android 1.4 on the Android Market.

What's new:

o Shuffle play! (Works similar to "Party shuffle" in the stock Android Music app).
o Improved cleanup of empty directories and temporary files.
o Fully cached files are now available to other music players.
o Better behavior when SD card or network is unavailable.
o Misc bug fixes.

If you like the app, why not leave a positive rating/comment on Android Market?

Thanks for all your past and future feedback!

Cheers,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Postby mluhring » Wed Jul 07, 2010 1:55 pm

Couple of things.

I have been using the app for about 8 months now and it is getting better and better.

Here are some observations based on my usage of the app.

For me, shuffle play is of limited value in it's current state. Random play through a large library with multiple genre's does not give a very cohesive listening experience. Typically I would want to listen to a particular genre depending on my mood, but that's just me. It would also be nice to shuffle a playlist or album around. That would be of more value.

This next item has been bothering me since I started using the Android app. Large playlists are pretty much unusable. A large playlist is 1000 or more songs. These large playlists try to simulate what Apple does with their genius mixes. I pick all music from a group of artists that fit into a particular genre and add them to a playlist. The playlists themselves are small text files and should not be hard to download, but the app usually times out trying to read these files. If you could fix how the app deals with large playlists that would be wonderful.

As a software engineer, I know it is hard to imagine all use cases when dealing with a diverse user group. So hopefully these use cases will give you just another perspective.

Keep up the good work!


P.S. Just checked the server app and it also takes quite a long time to load a large playlist. That may actually be the bottleneck.
mluhring
 
Posts: 11
Joined: Sun Nov 15, 2009 2:20 pm

Postby wattershed » Wed Jul 07, 2010 4:39 pm

Very cool, excited about being able to take what's cached in Subsonic and play that in other players.

I'll echo what mluhring says about the shuffle feature, though. Currently I have to rely on a 3rd party app (MortPlayer) for the ability to take a folder and do a shuffle playback, since the stock player relies on ID3 tags exclusively to sort music.

I know every user wants something tailored for them and it's impossible to please everybody. That said, if I have 150 songs which are my 'pump me up, get me going' type songs which I like to hear at the gym, I currently have to make a copy of those, place them in their own 'Gym' folder, and use MortPlayer to play them back. That means downloading them to my sdcard, which takes up space I'd love to have for photos and backups of apps.

Being able to point Subsonic at a subfolder and telling it 'start playing songs from this folder in no particular order' would allow me to stream random songs from my 'Gym' folder and free up the space taken up on my sdcard.

The web side of Subsonic meets and exceeds every wish I have in a streaming desktop music player, and the Android app is *so close* to being the only music app I need. In the car, at work, the app's functionality is top notch; the shuffle play though within a specific folder would seal the deal and make it a bonified 5-star application.
wattershed
 
Posts: 22
Joined: Sun Mar 14, 2010 8:36 am

Postby sindre_mehus » Wed Jul 07, 2010 5:00 pm

No problem, I guess I can simply add a button or menu item which shuffles the current playlist, similar to how the Subsonic web interface works.

Would that work for you?

Rgds,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Postby Linklater » Wed Jul 07, 2010 5:05 pm

Thanks for the server and for the Android app. Donated already and probably will in the future if it keeps getting better!

A few suggestions:

- Move App to SD card - should be an easy update to handle this great new feature of Froyo (Android 2.2). I believe you just have to set a flag to allow the user to do this.

- Ability to seamlessly move between Offline and Online modes, based on whether the server is reachable or not.

- Ability to reduce the repeated notifications when the server has a problem downloading a file (silent mode?)

- Increased control of pre-caching behavior... Perhaps having a battery-conserving mode/switch which limits the pre-caching to just one song (currently selected song).. Also, finer-grained control of the cache size.. Perhaps also the ability to flag certain songs as "keepers" that will always be kept in the cache when it reaches capacity (the software can then remove the non-keeper songs first)...

Just a few kindly thoughts! Rock on my man.
Linklater
 
Posts: 2
Joined: Wed Jul 07, 2010 4:54 pm

Postby wattershed » Wed Jul 07, 2010 7:04 pm

sindre_mehus wrote:No problem, I guess I can simply add a button or menu item which shuffles the current playlist, similar to how the Subsonic web interface works.

Would that work for you?

Rgds,
Sindre


You'd make a lot of peoples' days if there were a shuffle playlist option, yes!

Something I noticed with the opportunity to dive into the v1.4 update this morning, it seems that I'm getting "A network error occurred" messages when trying to enter random folders. I've never had this problem before, and with it being a new build I wasn't sure if anyone else was experiencing this too or if it's just a coincidence and I'm having bouts of packet loss from my HTPC > my phone today.

I restarted subsonic-service.exe as well, hasn't seemed to help matters. The desktop client is handling everything fine as usual.
wattershed
 
Posts: 22
Joined: Sun Mar 14, 2010 8:36 am

Postby AmazingLarry » Wed Jul 07, 2010 7:05 pm

Great new version. Loving the new changes.

One issue:
Once I play a song, it gets stuck in my notification bar. Even when paused or if the last song finishes playing, it's still in the notification bar.

The only way I can get rid of it is to use a task killer. I don't mind if it gets stuck there like this if you can add a true "Exit" option, otherwise I would like the behavior back where it would leave the notification bar when nothing is playing.

Thanks.
AmazingLarry
 
Posts: 26
Joined: Wed Nov 25, 2009 2:50 pm

Postby seanpkeown » Thu Jul 08, 2010 1:47 am

Hey Sindre, I'm loving the android application. Sorry to dump more on your plate but i thought that i would give you an update on what i found when playing music on my Android phone.

If you notice that i have a subsonic folder that is automatically created when i play a song. Underneath the subsonic folder lies a music folder.

Subsonic>Music>

Image

For some reason when i play a song i creates a folder under the Music folder then it creates another music folder with the same artist name underneath it. In my example ZZ Top.

Now the folder Subsonic>Music>ZZTOP actually holds the music but when i play offline it looks here for the music Subsonic>Music>Music>ZZTOP
When i copy the song out of the Subsonic>Music>ZZTOP and place it Subsonic>Music>Music>ZZTOP i can now play the song in offline mode.

Image


This only happens when i play the song.

When i press download it only puts the song in the Subsonic>Music> folder in turn not allowing it to play offline but it doesn't duplicate it like above. It does however create a song.mp3 and a song.mp3.partial both being the same size.


One last thing i promise. ^_^

I also noticed that when i play songs they hang once in a while when loading even when connected to the wireless. I noticed that the problem got worse if my signal was low on my phone which sounds correct except that the songs that i played had an orange symbol next to them meaning that they were cached which made me really confused. While playing the song i put my phone into airplane mode to ignore any cell signal and the songs started playing fine without the skip here or there. I then turned airplane mode back off and they skipped again.
I know that this probably doesn't make any sense but i thought that i would let you know to hopefully help you in troubleshooting any bugs.

I wish you the best of luck.

~ Sean K


My Info -
Subsonic Version 4.0.1 Build 1529
Android 1.5 Cupcake
Phone Motorola Backflip
seanpkeown
 
Posts: 100
Joined: Tue Jun 09, 2009 10:41 pm

Postby seanpkeown » Thu Jul 08, 2010 2:12 am

For some reason when i play a song i creates a folder under the Music folder then it creates another music folder with the same artist name underneath it. In my example ZZ Top.

Now the folder Subsonic>Music>ZZTOP actually holds the music but when i play offline it looks here for the music Subsonic>Music>Music>ZZTOP
When i copy the song out of the Subsonic>Music>ZZTOP and place it Subsonic>Music>Music>ZZTOP i can now play the song in offline mode.


I thought that this was the case but after waiting a few minutes and playing a few more songs. The other songs started to show up in my offline mode. I had to delete my songs off my phone for this to start happening. But while some songs show up they don't necessarily play. Its random which song will play in offline mode and which one won't. I was hoping that i could help but in the process I've confused my self more.

This only happens when i play the song.

When i press download it only puts the song in the Subsonic>Music> folder in turn not allowing it to play offline but it doesn't duplicate it like above. It does however create a song.mp3 and a song.mp3.partial both being the same size.


This could be from me being too impatient.

Maybe i could convince you to re-add the dump database button again to make it easier to dump the songs and start fresh while you're making changes to the application.

Good Luck Again
~ Sean K
seanpkeown
 
Posts: 100
Joined: Tue Jun 09, 2009 10:41 pm

Postby rwagter » Thu Jul 08, 2010 4:08 pm

A sanity check, since I've also just upgraded to android 2.1 on my Hero.

With previous versions it seemed that when pausing the music or when then playlist reached it's end the play icon vanished, however now it stays on focus thus never ending the software. Can anyone confoirm this is due to 1.4 ??

Ralph

ps it seems that there are a lot more music interupts within a song lately, have no clue whether this is due to the android upgrade or the client, it is rather annoying though
rwagter
 
Posts: 13
Joined: Tue May 11, 2010 8:29 pm

Postby sindre_mehus » Thu Jul 08, 2010 4:56 pm

rwagter wrote:With previous versions it seemed that when pausing the music or when then playlist reached it's end the play icon vanished, however now it stays on focus thus never ending the software. Can anyone confoirm this is due to 1.4 ??


Yes, it's a bug/feature in 1.4. I'll fix that in the next release, though.
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

what about offline?

Postby lpadron » Fri Jul 09, 2010 2:17 am

Sindre,

Android apps keeps getting better and better . . . but . . .

Offline play still doesn't work for me. When I select the OFFLINE server and try to play ANY previously cached tracks, I get an "error downloading".

I've mentioned this issue several times. Have noticed others mention it also. Never seen a reply.

Am I doing something wrong in the OFFLINE selection process?

Regards,

Lee
lpadron
 
Posts: 17
Joined: Thu Jun 03, 2010 6:00 pm

Postby patocox » Fri Jul 09, 2010 2:26 am

Hey there,

Upgraded to 1.4 and now I cant connect either in my LAN or 3G. Says a network error occurred - try again later. I was able to use 1.3 fine. I pass the Test Connection, however when I try to view my artist list, it doesnt connect. I can connect via the web just fine internally and externally. I can hit your demo site fine via the android. Any ideas? Is there a log I can view?

Im on a Droid 2.1 OS and my collection is rather large - about 118GB
-Pat
patocox
 
Posts: 3
Joined: Fri Jul 09, 2010 2:19 am

Postby cwilliams » Fri Jul 09, 2010 9:39 am

sindre_mehus wrote:No problem, I guess I can simply add a button or menu item which shuffles the current playlist, similar to how the Subsonic web interface works.

Would that work for you?

Rgds,
Sindre


Yes! With 600gigs of music, shuffle all is also fairly useless for me. Shuffle/Repeat for the playlist would be an awesome feature!

lpadron wrote:Offline play still doesn't work for me. When I select the OFFLINE server and try to play ANY previously cached tracks, I get an "error downloading".


Yep, Offline is still broken. I cleared my entire music cache before trying the new version. Downloaded an album, switched to offline mode, and it doesn't play. This time no error message is produced, it just says "Downloading - 0 B" above the progress bar.

sindre_mehus wrote:
rwagter wrote:With previous versions it seemed that when pausing the music or when then playlist reached it's end the play icon vanished, however now it stays on focus thus never ending the software. Can anyone confoirm this is due to 1.4 ??


Yes, it's a bug/feature in 1.4. I'll fix that in the next release, though.


Looking forward to that fix!

Linklater wrote:- Ability to seamlessly move between Offline and Online modes, based on whether the server is reachable or not..


Putting Offline tracks as a one click button - like where Party Shuffle mode is - would definitely speed things up. It's three clicks to get to offline tracks, and then 2 to switch back. One button would trump this!

Linklater wrote:- Increased control of pre-caching behavior... Perhaps having a battery-conserving mode/switch which limits the pre-caching to just one song (currently selected song).. Also, finer-grained control of the cache size.. Perhaps also the ability to flag certain songs as "keepers" that will always be kept in the cache when it reaches capacity (the software can then remove the non-keeper songs first)...
The size/cache control in the new version works very well for me, what problems with it are you having?

seanpkeown wrote:For some reason when i play a song i creates a folder under the Music folder then it creates another music folder with the same artist name underneath it.


Strange, I cleared my cache before trying to the new version and I am definitely not getting the behavior you are describing with extra folders being created.
cwilliams
 
Posts: 30
Joined: Tue Apr 07, 2009 12:28 am

Postby wattershed » Fri Jul 09, 2010 4:36 pm

patocox wrote:Hey there,

Upgraded to 1.4 and now I cant connect either in my LAN or 3G. Says a network error occurred - try again later. I was able to use 1.3 fine. I pass the Test Connection, however when I try to view my artist list, it doesnt connect. I can connect via the web just fine internally and externally. I can hit your demo site fine via the android. Any ideas? Is there a log I can view?

Im on a Droid 2.1 OS and my collection is rather large - about 118GB
-Pat


Sindre, this sounds like the same issue I mentioned above, anything that could have been changed from 1.3 > 1.4 that would cause this? My collection's in the ~400gb range but I doubt that would have much to do with this. It definitely seems to be a subfolder size issue, as a subfolder with one 12-track album in it loads fine (90% of the time) whereas a large folder with 15 subfolders and 300 total songs might load after 15 or so tries...and even then that's not a guarantee.

I'm noticing this is also affecting my playlists - a 150-song playlist will ALWAYS generate the "a network error..." message. I haven't made any external changes to my library between 1.3 & 1.4, and suddenly this playlist simply will not load. Playlists of 18, 38, & 69 songs all loaded, though many of those didn't load the first 3-5 times I tried to load them.

Any thoughts? This is making the app largely unusable for me...
wattershed
 
Posts: 22
Joined: Sun Mar 14, 2010 8:36 am

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 4 guests

cron