Subsonic 4.1 released

Announcements and discussion of new releases.

Moderator: moderators

m4a files not playing

Postby deuce32 » Thu Oct 14, 2010 1:24 am

I upgraded to 4.1 today on a windows home server.

I have not been able to play m4a files since the upgrade (mp3s work fine). Here is the error from the log:
[2010-10-13 20:14:54,882] DEBUG TranscodeInputStream - Starting transcoder: [c:\subsonic\transcode\faad] [-w] [D:\shares\Music\pjacobs32\iTunes\iTunes Media\The Beatles\The Beatles (White Album) [Disc 1] [2009\1-07 While My Guitar Gently Weeps.m4a]
[2010-10-13 20:14:54,898] DEBUG TranscodeInputStream - Starting transcoder: [c:\subsonic\transcode\lame] [-b] [128] [-x] [-] [-]
[2010-10-13 20:14:54,929] DEBUG InputStreamReaderThread - (c:\subsonic\transcode\lame) Warning: unsupported audio format

I have verified that all transcodings are active for the web player.

The transcoder plug-ins, which were present prior to the upgrade, are under c:\subsonic\transcode

The transcoder settings for m4a > mp3 are:
step 1: faad -w %s
step 2: lame -b %b -x - -

Everything was working prior to the upgrade.

Any help would be appreciated.

Thanks.
Paul
deuce32
 
Posts: 3
Joined: Thu Oct 14, 2010 1:11 am

m4a problem solved

Postby deuce32 » Thu Oct 14, 2010 1:38 am

My transcoding settings must have been changed during the upgrade. Everything worked once I changed them back to the default configuration for the Windows transcoding pack.
deuce32
 
Posts: 3
Joined: Thu Oct 14, 2010 1:11 am

video ever

Postby heynowsaywhat » Wed Oct 20, 2010 9:23 am

i've been looking for hours and i know this has been brought up...but will subsonic ever have video support?
and
why did 4.0.beta1 have video mask and now it subsonic doesn't?

thanks
User avatar
heynowsaywhat
 
Posts: 7
Joined: Wed Oct 20, 2010 8:12 am

Postby GJ51 » Sat Oct 23, 2010 1:57 am

peher wrote:Hello Sindre

Since I upgraded this morning I can't use the web player anymore
I just get the "Get Flash player" message instead of the player.

I tried on 2 computers, I restarted tomcat twice and I don't see anything special in the logs.

I saw on the forum that someone had the same issue with a previous beta version and that he downgraded to resolve the problem....

Any idea of what might be causing the issue ?


You are most likely opening the 64 bit version of IE instead of the 32 bit.
Last edited by GJ51 on Tue Nov 02, 2010 8:49 am, edited 1 time in total.
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3492
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Postby maxslug » Tue Oct 26, 2010 11:25 pm

peher wrote:After looking a bit I saw that I had this error

Code: Select all
Error
Exception     java.lang.NoClassDefFoundError
Message     com/yahoo/platform/yui/compressor/JavaScriptCompressor


so I downloaded the yuicompressor , put it in subsonic/WEB-INF/lib/ and now it works again...


Hi, I'm getting this too, installing from scratch, running standalone, and reverse proxying from apache. Is it really just a missing file, and if so, could you post on how to add back into the archive file?

EDIT: To those of you playing at home...

a .war is actually a .jar, which java's version of a .tar

Code: Select all
wget http://yuilibrary.com/downloads/yuicompressor/yuicompressor-2.4.2.zip
unzip yuicompressor-2.4.2.zip
mkdir tmp
cd tmp
jar xvf ../subsonic.war
cp ../yuicompressor-2.4.2/build/* WEB-INF/lib
rm ../subsonic.war
jar cvf ../subsonic.war *


NOTE: I had to install the java*-devel package on my mythdora box in order to get the 'jar' utility (yum install java-1.6.0-openjdk-devel)

-m
maxslug
 
Posts: 44
Joined: Tue Oct 26, 2010 11:23 pm

Re: m4a problem solved

Postby JesterTX2001 » Mon Nov 01, 2010 2:35 am

deuce32 wrote:My transcoding settings must have been changed during the upgrade. Everything worked once I changed them back to the default configuration for the Windows transcoding pack.


Yeah I had to re-download Windows' transcoding packages and copy them over what was already in C:\Subsonic\Transcode, but that seemed to do the trick.
JesterTX2001
 
Posts: 2
Joined: Mon Jul 20, 2009 9:26 pm

"Get Flash Player" in .war deployed 4.1

Postby toaster13 » Tue Nov 02, 2010 2:26 pm

Sindre -

I'm having this problem too, but it works just fine when I use the standalone (jetty embedded) version. I want to migrate to .war in tomcat 1.6 so I can do proper SSL with apache.

Both installs use the same JVM/JAVA_HOME, however when I start and connect to the tomcat/.war version, the player area says "Get Flash Player" instead of displaying the player. The standalone works literally on the same client and server. Its just a matter of which version is actually running as to whether the player area functions. Bypassing the apache/ssl layer does not help. Not sure what's going on. Please advise.

Thanks!

[quote="peher"]Hello Sindre

Since I upgraded this morning I can't use the web player anymore
I just get the "Get Flash player" message instead of the player.

I tried on 2 computers, I restarted tomcat twice and I don't see anything special in the logs.

I saw on the forum that someone had the same issue with a previous beta version and that he downgraded to resolve the problem....

Any idea of what might be causing the issue ?[/quote]
toaster13
 
Posts: 2
Joined: Tue Nov 02, 2010 2:18 pm

Re: "Get Flash Player" in .war deployed 4.1

Postby toaster13 » Tue Nov 02, 2010 3:05 pm

BTW, I just rolled back to 4.0.1 and it appears to be working. Looks like a bug with 4.1?

Thanks.

[quote="toaster13"]Sindre -

I'm having this problem too, but it works just fine when I use the standalone (jetty embedded) version. I want to migrate to .war in tomcat 1.6 so I can do proper SSL with apache.

Both installs use the same JVM/JAVA_HOME, however when I start and connect to the tomcat/.war version, the player area says "Get Flash Player" instead of displaying the player. The standalone works literally on the same client and server. Its just a matter of which version is actually running as to whether the player area functions. Bypassing the apache/ssl layer does not help. Not sure what's going on. Please advise.

Thanks!

[quote="peher"]Hello Sindre

Since I upgraded this morning I can't use the web player anymore
I just get the "Get Flash player" message instead of the player.

I tried on 2 computers, I restarted tomcat twice and I don't see anything special in the logs.

I saw on the forum that someone had the same issue with a previous beta version and that he downgraded to resolve the problem....

Any idea of what might be causing the issue ?[/quote][/quote]
toaster13
 
Posts: 2
Joined: Tue Nov 02, 2010 2:18 pm

Postby GJ51 » Wed Nov 03, 2010 6:21 am

I got this error after updating the jw player. The download has the wrong version of swfobjects.js. Make sure you have ver 2.2
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3492
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Previous

Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests