Subsonic 4.3.beta1 released (Video support)

Announcements and discussion of new releases.

Moderator: moderators

Subsonic 4.3.beta1 released (Video support)

Postby sindre_mehus » Fri Dec 31, 2010 8:31 am

Dear friends,

First of all: Happy holidays and best wishes for 2011! A big thank you for your continued support of Subsonic.

Please note that Subsonic 4.3.beta1 was released yesterday. The big news this time is support for video streaming.

Video streaming uses ffmpeg for converting the videos to a streamable format on-the-fly. You can even stream to Android phones (Android 2.2 or better required).

Hope you like it!
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Postby alphawave7 » Fri Dec 31, 2010 9:06 am

WhooHoo!

Using a Panasnic DMC-SZ3 which shoots .mts file format, and would prefer not to have to convert all my vids...can anyone suggest a transcode, if ffmpeg can even do it? TIA!
alphawave7
 
Posts: 1037
Joined: Thu Feb 11, 2010 9:54 am

Postby utopian » Fri Dec 31, 2010 10:06 am

great can't wait to try this out... :)
User avatar
utopian
 
Posts: 111
Joined: Sun Feb 14, 2010 3:52 pm

Postby jjwa » Fri Dec 31, 2010 12:50 pm

Very nice feature :).

It works! But it seems the bandwidth requirements are difficult to keep up with for my phone, even on WiFi.

After fully watching a file, it did not appear with an orange 'this-file-has-been-saved' star in Subsonic, making me guess it was not really saved.

The player's interface looks a lot like the YouTube interface. But when I start streaming, then pause the file right at the start, and wait (a pre-loading tactic to get smooth playback I use for YouTube, or music in Subsonic), I don't see a little 'loading-in-advance' lighter red bar moving beyond the point where I was watching. Is that simply not displayed, or is it actually not preloading?

So I guess in short, my question is:
Does it do all the caching/buffering/file-saving for video just as it does for music? Or is that still very much a work in progress? Or maybe it will not be added/possible?


And most important:
Thanks! :) Sweet addition.
jjwa
 
Posts: 17
Joined: Sun Jul 18, 2010 3:44 am

Postby agroni1888 » Fri Dec 31, 2010 3:34 pm

AHAHAHA sindre once more you got me! Will donate again soon enough, this is just an epic update (surely it isnt perfect yet, but still).

I have one big question:

When i Pause the movie, does it still load (caching the movie) the movie (like youtube does)? Hope it does, because for me this is really the most important thing :)
edit: oh the poster above asked the same thing :D good looking forward for an answer on this

what I also realized is taht on full hd movies (streamed with 1000kbs) the sound and the video is very very asynchron (like 15secs!) sometimes - I don't know if theres anyway to fix this? I guess not right? (but thats not so bad :) )

What would be nice:
-Add seperate Adding for movie folders (just a checkbox "Is movie folder" or something) --> because i dont want all my users to be able to watch movies
- Own Control for movies (means disable download / set maximal streaming rate and so on)
- do not inlcude the covers in default subsonic homepage (at least i dont want them there, dont know if this is already done).

But again:

EPIC update!

Thank you.
agroni1888
 
Posts: 31
Joined: Thu Feb 19, 2009 12:09 pm

Postby stabu » Fri Dec 31, 2010 3:44 pm

Does it need a certain version of ffmpeg? im trying to use it on freenas and its not working
stabu
 
Posts: 4
Joined: Wed Jul 21, 2010 1:30 pm

Postby sindre_mehus » Fri Dec 31, 2010 4:34 pm

@agroni1888 & jjwa: Yes, it will continue to load the video when you pause it (at least it does it when playing it in a browser on a normal computer). You can verify it yourself by monitoring the Status page in Subsonic while streaming.

Unfortunately the scrubber control doesn't work (the slider underneath the video), so it doesn't show the download progress. Also, it can't be used to skip within the video so you have to use the drop-down box instead.

Furthermore, caching/saving on Android is not possible. This is because the playback is handled by the Flash-based JW Player rather than programmatically by the Android media player.

Thank you,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Postby mfalzon » Fri Dec 31, 2010 8:51 pm

Great start! Been waiting for this, can't wait till its perfected. Playback isn't that great for me on pc and Android. Bandwidth shouldn't be and issue 25mbit on host wide and 30mbit on remote side. Server specs are decent and should be more than enough. ( I use airplay( I think that's the name) for video streaming to iphone 4 and works flawlessly on same server )

If there is anything I can do to help let me know.
mfalzon
 
Posts: 15
Joined: Mon Oct 04, 2010 5:12 pm

Postby blink515 » Fri Dec 31, 2010 10:55 pm

Thanks for this. Been excited for it ever since I had seen the code updates on the source forge site.

One problem though. I tried it on my Windows Home Server box where Subsonic is normally installed and the video streaming will not work whether i use a pc or the android app. I backed up my settings uninstalled and reinstalled and still nothing. So I decided to install it on my Windows 7 pc and it works perfectly.

Is it something to do with the Windows Home Server OS that is preventing the playback?

Thanks for everything.
blink515
 
Posts: 6
Joined: Sun Nov 28, 2010 12:59 am

Postby utopian » Sat Jan 01, 2011 12:51 pm

do u just added your video files thru the music folders location ?
User avatar
utopian
 
Posts: 111
Joined: Sun Feb 14, 2010 3:52 pm

Thank You

Postby Mouse » Sat Jan 01, 2011 1:40 pm

This is great, keep up the good work. Happy New Year...
Mouse
 
Posts: 5
Joined: Mon Aug 09, 2010 10:30 pm

Postby jjwa » Sat Jan 01, 2011 1:52 pm

utopian wrote:do u just added your video files thru the music folders location ?

Yes, just pretend it's a music folder. It even calls videos 'songs' in Subsonic, hehe.
jjwa
 
Posts: 17
Joined: Sun Jul 18, 2010 3:44 am

Postby cabotine » Sat Jan 01, 2011 2:50 pm

nice work
videostreaming works fine for me...
just took it as an impulse for finally making a donation...
keep up the good work...
cabotine
 
Posts: 12
Joined: Sat Jan 01, 2011 2:45 pm

Postby frankspin » Sat Jan 01, 2011 6:48 pm

Video streaming worked fine for me as well.

Only "issue" is that it just shows a folder as "Season #" which is no big deal, I can just add & remove as needed.
frankspin
 
Posts: 11
Joined: Fri Aug 06, 2010 2:31 pm

Postby Shikaku » Sat Jan 01, 2011 7:26 pm

I love the update. Makes video much easier. However, I did notice the comment about the scrubber. Is there no way to activate the scrubber in Subsonic? I was reading through the coding last night, trying to make it work. It would certainly make the streaming function top notch if you could somehow activate it. Especially since the pulldown navigation bar doesn't seem to be working at the moment. Also, any video I upload says it has a duration of 0 seconds. Any advice?

Is there a preferred video format for the JWplayer within Subsonic? Perhaps that is why my videos are not working as well as I would have hoped?

It's a great first step, but apparently it doesn't seem to be working as well I would like it to yet. Every time I click on the embedded navigation bar (scrubber) it just starts the video file over and I have to rebuffer the file again. That's fine for me, but not for guests who log on to my server and discover they can't navigate the file without restarting the download.

Any advice/tips on this matter would be very helpful to me. I spent a lot of time yesterday configuring my server.

Again, great application and I look forward to future releases.
Shikaku
 
Posts: 1
Joined: Sat Jan 01, 2011 5:28 am

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests