Subsonic 4.5.beta1 released

Announcements and discussion of new releases.

Moderator: moderators

Subsonic 4.5.beta1 released

Postby sindre_mehus » Mon Jun 20, 2011 7:19 pm

Hi all and sorry for the long time since last release.

I just put out version 4.5.beta1 of the Subsonic server, with the following changes:

New: Twitter/Facebook integration.
New: Share songs and videos by sending someone a link.
New: Support video in external player.
New: Support higher video bitrates, 3000 and 5000 kbps.
New: Added Bulgarian translation, courtesy of Ivan Achev.
New: Updated Norwegian translation, courtesy of Tommy Karlsen.
New: Updated German translation, courtesy of deejay2302.
New: Support http header "Content-Range" when streaming.
New: Ignore "@eaDir" folders on Synology devices.
API: Added REST method getPodcasts.
API: Added REST method getShareUrl.
API: Added user email to REST API.
API: Added example XMLs to API documentation.
API: Encoded passwords were not decoded correctly in REST methods createUser and changePassword.
API: Added "format" and "size" parameters to REST method stream.
Bugfix: Don't include podcasts when generating random songs.
Bugfix: Handle whitespace in podcast urls.
Bugfix: Updated expired ssl cert.
Bugfix: Mac installer: make transcode dir executable.

Your feedback is welcome!

Thanks for your continued support and interest in Subsonic :-)

Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Re: Subsonic 4.5.beta1 released

Postby Aethies » Mon Jun 20, 2011 10:19 pm

sindre_mehus wrote:Hi all and sorry for the long time since last release.

I just put out version 4.5.beta1 of the Subsonic server, with the following changes:

New: Twitter/Facebook integration.
New: Share songs and videos by sending someone a link.
New: Support video in external player.


Your feedback is welcome!

Thanks for your continued support and interest in Subsonic :-)

Sindre


Simply OUTSTANDING! With all the new garbage laws that are being posted, if your home video (we make videos of our motorcycle rides) has any music in it that resembles copywrited songs, it will not allow you to post them to youtube or fb. This is an awesome way that I can share a link to my friends in our group.

You do a fantastic job Sindre and I, along with everyone on this forum that uses subsonic greatly appreciates the work that you do! I mean, seriously, words are not enough!

Thanks again!
Aethies

Ubuntu Server 12.04
===================
3,281 artists
9,432 albums
113,608 songs
2636.09 GB (10,769 hours)
===================
User avatar
Aethies
 
Posts: 197
Joined: Fri Oct 24, 2008 4:33 pm

Postby courageousrobot » Tue Jun 21, 2011 12:42 am

Excellent! Works great so far...

One comment - I can't seem to find a way to limit *video* bitrate... I really don't want my users downloading at 5000kbps, it really clogs the pipe for other users. Does this feature exist?
courageousrobot
 
Posts: 12
Joined: Tue Apr 12, 2011 12:25 am

Postby ccandreva » Tue Jun 21, 2011 2:15 am

Question: Why does sharing need a subsonic.org address ? My server has a static IP so I've never set one up, and didn't plan to.
User avatar
ccandreva
 
Posts: 104
Joined: Fri May 28, 2010 8:22 pm

Postby sindre_mehus » Tue Jun 21, 2011 6:41 am

ccandreva wrote:Question: Why does sharing need a subsonic.org address ? My server has a static IP so I've never set one up, and didn't plan to.


For simplicity. The public IP is generally not known to the Subsonic server (and it also cannot know if it's dynamic or not) - whereas the subsonic.org address is known, it supports dynamically changing IPs, and it works both within your lan and from the outside.

Thanks,
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Postby bushman4 » Tue Jun 21, 2011 12:55 pm

Just an FYI... it appears that, if I share something with someone else (or many someone else's) that every time they play it, it scrobbles to Last.fm as if I played it. At least according to the log file...

Probably not the desired behavior for most...

But the new feature is awesome! Definite great addition!

Thanks again,

Glenn
Glenn Sullivan
Subsonic 5.2.1 (Standalone on Apache/Tomcat 6)
WHS 2003, Dual Core Athlon, 4 Gb RAM, 12 TB
50 regular Subsonic Users

Library as of 2016-03-21:
4,034 artists
16,595 albums
182,904 songs
4582.16 GB
21,558 hours
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Postby budd » Tue Jun 21, 2011 1:05 pm

Thanks for all the work you do on Subsonic! The new beta is pretty good!

I think it would be nice if there was some kind of entry in the log to see access by IP address when using the sharing function.

Will there be any plans to extend the sharing functionality? Right now it appears that you can only share files in the same folder, but what about making playlists and sharing that or sharing your current playlist?

Aside from that, the beta looks awesome. I donated a long time ago in the past, but probably will be again in the near future, this program keeps getting better and better.
Last edited by budd on Tue Jun 21, 2011 2:05 pm, edited 1 time in total.
budd
 
Posts: 1
Joined: Tue Jun 21, 2011 12:58 pm

Scrobbling

Postby vollbr0t » Tue Jun 21, 2011 1:20 pm

Awesome new featues.

Although i did also realize some unwanted behavior with music-links. The music send to someone is displayed as played by the sender (and also scrobbled).
vollbr0t
 
Posts: 75
Joined: Wed Jan 19, 2011 6:35 pm

Postby ccandreva » Tue Jun 21, 2011 2:05 pm

Back to "Share" :-)

I see. Does it need to go through the subsonic.org proxy, or could you add an option to enter the full URL to the Subsonic server ? (At least I remember name.subsonic.org being a proxy.)
User avatar
ccandreva
 
Posts: 104
Joined: Fri May 28, 2010 8:22 pm

Postby SparkyRih » Tue Jun 21, 2011 3:54 pm

ccandreva wrote:Back to "Share" :-)

I see. Does it need to go through the subsonic.org proxy, or could you add an option to enter the full URL to the Subsonic server ? (At least I remember name.subsonic.org being a proxy.)


I also would like to be able to use my own domain to share media :)
VMWare ESXi 5.5 > Ubuntu 16.04 > Subsonic 6.0 (Modded with PHP based registration feature)

Image
User avatar
SparkyRih
 
Posts: 216
Joined: Wed May 11, 2011 1:52 pm
Location: The Netherlands

Postby jeffpetersen » Tue Jun 21, 2011 4:17 pm

Thanks for beefing up the podcast system! Is there any chance to add support for login? This is a pretty common feature in podcatchers now.

For instance, Never Not Funny Primo requires a username and password in order to download the XML file. If you want to see the feed login, let me know!
jeffpetersen
 
Posts: 38
Joined: Sat Feb 07, 2009 9:12 pm

Lost my connection after update!

Postby Jokestr » Tue Jun 21, 2011 5:45 pm

I seem to have completely lost any and all remote connections since the update. I've never have a problem with my url connecting in the past, and now I'm going on about 2 days of attempted reconnects with no progress. Logs are empty in regards to this issue.

STATUS: Successfully forwarding port 4040

STATUS: xxxxxx.subsonic.org is registered, but could not connect to it. (ConnectTimeoutException)
Last edited by Jokestr on Wed Jun 22, 2011 5:16 pm, edited 1 time in total.
Jokestr
 
Posts: 12
Joined: Mon Jan 03, 2011 8:09 pm
Location: US

Mac OS X

Postby manga84 » Tue Jun 21, 2011 8:08 pm

Has anyone tried the update with OS X? Any problems?
manga84
 
Posts: 7
Joined: Thu Feb 10, 2011 7:29 pm

Postby Jokestr » Tue Jun 21, 2011 8:40 pm

maybe me? I'm not sure....I'm on the latest and greatest OS X (10.6.7)

The only variable that recently changed, is the Subsonic upgrade (to beta), and I also started the google music cloud the other day, which takes several days to (slowly) upload your collection. That doesn't seem to be eating up that much of my pipeline though, and it shouldn't affect my server's initial "handshake" with the subsonic server.

I'm not sure what to try next, expect maybe a rollback?
Jokestr
 
Posts: 12
Joined: Mon Jan 03, 2011 8:09 pm
Location: US

Update kills custom settings

Postby mgyellow » Tue Jun 21, 2011 8:57 pm

Wanted to give the beta a try, but did not quite work out the way it should.

What i had: Subsonic installation in C:\Program Files (x86)\Subsonic and configuration file pointing to D:\Subsonic for all other files.
What i did: make a backup folder: "C:\Program Files (x86)\Subsonic\backup" and copied all contents of the subsonic dir in it.
An unneeded step, according to the install guide for the beta:
If you're upgrading an existing Subsonic installation, you don't have to uninstall the old version first. In any case, the existing Subsonic settings are preserved.


After the install, the backup folder was gone. So here's a tip: dont backup to the subsonic folder itself...
After installation of the new service, the account used to run the service was reset to the local system account.
Changed that to the special subsonic account i created and it started up again. Phew... :)

Also, the text for the new sharing functionality is in english and not in the language set for subsonic. No biggy.
mgyellow
 
Posts: 7
Joined: Mon Jul 12, 2010 11:14 pm

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 2 guests