Raspberry Pi Transcoding Question

General discussions.

Moderator: moderators

Raspberry Pi Transcoding Question

Postby tberman333 » Mon Mar 20, 2017 10:26 pm

I have been using Subsonic for a long time and have come to realize it is the only reason why I keep my old desktop PC on all the time. To save some energy, I figured I would try to install Subsonic on an old Raspberry Pi I had that was not really using for anything else. This is the original Pi (Model B with 512MB of Ram). I got Subsonic up and running with little issue. It is playing all MP3 files just fine, but FLAC files are not playing. My guess is the Pi is just not powerful enough to do the transcoding, but was wondering if anyone has had success with this. I am thinking it may be worth upgrading to a newer Pi (or something similar) if others have had success.

Thanks for the input!

EDIT - I still have the question above but I looked at the logs more closely and think there may be a problem with the transcoder configuration. I name my files as "(#) Name.flac" and the log says:

Syntax error: "(" unexpected

I have the recommended configuration setup (ffmpeg -i %s -map 0:0 -b:a %bk -v 0 -f mp3 -)... I think the %s is causing the problem because of the ( in my filename. I am going to look into this, but if anyone has a suggestion it would be appreciated!
tberman333
 
Posts: 37
Joined: Fri May 18, 2007 9:29 pm
Location: West Hartford, CT - USA

Re: Raspberry Pi Transcoding Question

Postby tberman333 » Tue Mar 21, 2017 1:07 am

I found the answer, so figured I would post it here... The answer was in deep in the comments on this page:

https://mj2p.co.uk/a-raspberry-pi-subso ... ng-java-8/

Here is the answer:
But here is a little problem. `ffmpeg` is not available in Raspbian Jessie. But there is `avconv` which is a fork of `ffmpeg`, so all the parameters used with `ffmpeg` work fine. `avconv` is in the `libav-tools` package.

pi$`sudo apt-get install libav-tools lame`

To save yourself from changing the `ffmpeg` command to `avconv` in Subsonic, I did this with links. Not sure if this is the right way, though.

pi$`sudo ln -fs /usr/bin/avconv /var/subsonic/transcode/ffmpeg`
pi$`sudo ln -fs /usr/bin/lame /var/subsonic/transcode`
tberman333
 
Posts: 37
Joined: Fri May 18, 2007 9:29 pm
Location: West Hartford, CT - USA

Re: Raspberry Pi Transcoding Question

Postby moraisen » Thu Jun 22, 2017 3:28 pm

tberman333 wrote:I found the answer, so figured I would post it here... The answer was in deep in the comments on this page:

https://mj2p.co.uk/a-raspberry-pi-subso ... ng-java-8/

Here is the answer:
But here is a little problem. `ffmpeg` is not available in Raspbian Jessie. But there is `avconv` which is a fork of `ffmpeg`, so all the parameters used with `ffmpeg` work fine. `avconv` is in the `libav-tools` package.

pi$`sudo apt-get install libav-tools lame`

To save yourself from changing the `ffmpeg` command to `avconv` in Subsonic, I did this with links. Not sure if this is the right way, though.

pi$`sudo ln -fs /usr/bin/avconv /var/subsonic/transcode/ffmpeg`
pi$`sudo ln -fs /usr/bin/lame /var/subsonic/transcode`


I used to use Subsonic on a Windows host without problems. Afterwards I've switched to a RPI 1 B, too. I did blame the raspberry's performance for not working properly.
After reading this Thread, everything makes sense now.
Currently using this fix, without any conflicts so far.
Devs, I would recommend considering implementing this in future releases
moraisen
 
Posts: 2
Joined: Thu Oct 25, 2012 8:30 am


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest