Track Will Not Advance

General discussions.

Moderator: moderators

Re: Track Will Not Advance

Postby Freshman » Fri Jun 09, 2017 12:36 pm

I can confirm that evilmanimani's workaround with flac & lame appears to be "workarounding" correctly :) Thank you evilmanimani!
Posts: 4
Joined: Mon Jun 05, 2017 2:00 pm

Re: Track Will Not Advance

Postby quimbo » Mon Jun 12, 2017 1:09 pm

Thank you evilmanimani. i have also confirmed that this has fixed the issue I was experiencing.
Posts: 11
Joined: Wed Sep 22, 2010 1:22 am

Re: Track Will Not Advance

Postby bigman » Mon Jun 19, 2017 12:07 am

I was experiencing a slightly different issue:
My flac songs were transcoding only the first 25%-30% of the song before advancing to the next song. Using Evil's workaround, I can get the entire song to play.

I'm on 6.1.1 (build fc853b) – May 31, 2017, and had been using the default transcoding settings.
Posts: 11
Joined: Wed Apr 23, 2014 2:09 pm

Re: Track Will Not Advance

Postby Deviant0ne » Fri Jun 23, 2017 9:18 pm


I am experiencing this issue as well - I have tried running Subsonic stand-alone with the suggested transcoding settings, though my tracks will not advance. I have also installed the .WAR version in the latest version of Jetty using the suggested transcoding settings - with that configuration, the FLAC song will stop part-way through the song, so I'm not sure what's going on. If I don't transcode at all, the FLAC songs play fine.

I am currently running Subsonic + Jetty (9.4.6) + Java 8 (update 131) on FreeNAS 11 inside of a standard jail - any assistance with this would be greatly appreciated.
Posts: 10
Joined: Fri Jun 23, 2017 9:14 pm

Re: Track Will Not Advance

Postby triplesixes » Sat Jul 01, 2017 11:27 am

Had same trouble with tracks advancing, evilmanimani's workaround did not fixed it. I had to revert back to 6.0 (build 830afc).
Last edited by triplesixes on Sun Aug 27, 2017 12:30 pm, edited 1 time in total.
Posts: 16
Joined: Mon Jan 16, 2012 5:31 pm

Re: Track Will Not Advance

Postby chasmo » Wed Jul 26, 2017 5:43 pm

I have the same problem even after adding the lame transcoding, and it occurs when:

A) Playing transcoded FLAC files in the web player
B) playing transcoded FLAC files on the AVSub app and
C) Sending FLAC files directly to a Chromecast Audio device.

Prior to adding the lame transcoding layer, about 1 in 3 transcoded FLAC files would stop the player(s) from advancing. With the lame layer, it's now about 1 in 5 files that lock up the player(s). Subsonic is not usable in this state.
Posts: 31
Joined: Sat Jan 19, 2013 7:08 pm

Re: Track Will Not Advance

Postby PoGo » Wed Jul 26, 2017 9:05 pm

Actually the issue is not solved for me either.

The frequency of this behaviour dropped as chasmo described it.
But it's still there !

Agreed, this is not usable....
Posts: 36
Joined: Thu Apr 21, 2011 11:07 pm

Re: Track Will Not Advance

Postby thegoods » Wed Aug 30, 2017 7:03 pm

evilmanimani's workaround seems to have fixed it for me so far, and also has the most excellent side effect of seeking through flac's much faster. thanks evilmanimani!
Posts: 9
Joined: Sun Jun 14, 2015 7:01 pm

Re: Track Will Not Advance

Postby acroyear » Thu Aug 31, 2017 12:50 pm

Maybe that's the trick. lame is adding a field (the duration) that ffmpeg does not when it streams.
Joe Shelby
User avatar
Posts: 552
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA


Return to General

Who is online

Users browsing this forum: No registered users and 2 guests