Page 1 of 1

Album art gets corrupt after modifying id3 tags via subsonic

PostPosted: Wed Oct 08, 2008 2:17 pm
by cooperdude
If you have mp3 files that have album art embedded and modify the id3 tags via Subsonic, the album art gets corrupted. It happens every time.
I've tried uninstalling completely and reinstalling, but that doesn't seem to do the trick.

Thanks again for some great software!

PostPosted: Mon Oct 20, 2008 8:56 pm
by BrianDelShasta
I posted with that issue a while back as well, but nothing ever came of it. Also worth noting is that you sometimes have to push the save button a couple of times to actually save *all* the tags you've changed. For instance, let's say I change all categories of every song on an album and hit save. It goes through each one and says 'updated'. Then if I hit save again it skips most but again updates a few here and there because they were not actually updated completely the first time around. I haven't been able to narrow down how to produce this issue consistently, so I just always hit save about 3 times ;)

PostPosted: Sun Oct 26, 2008 1:53 pm
by sindre_mehus

Thanks for reporting this - it's a nasty bug. I promise to look into this in Subsonic 3.6. (It might be hard to fix it, since the bug most likely is in a third-party library, but we'll see).

BrianDelShasta: sorry for not responding to your original post. I had put it on my todo-list though :-)


PostPosted: Tue Nov 04, 2008 3:47 am
by BrianDelShasta
No problem!
Here's a little more info on the second issue of having to hit the Save button multiple times:

1) start with an mp3 file with a properly embedded album image
2) edit the tag within subsonic, change a single item, or multiple
3) hit 'Save' and the it will say "Updated", but checking the tag reveals nothing was actually changed, and the embedded image is not yet corrupted
4) hit 'Save' again and it will say "Updated" again! This time it will update the tag, but also corrupt the image.

Hitting save again does nothing (it says "Skipped").
The above does not occur if there is no embedded image(s).

Hope that helps you track it down!

PostPosted: Tue Nov 04, 2008 8:14 am
by sindre_mehus
Thanks for the detailed info, Brian.

PostPosted: Tue Oct 05, 2010 2:06 am
by Coolmax
Has this bug been fixed yet..?

PostPosted: Tue Oct 05, 2010 2:38 am
by Coolmax
Its ok, i tried it and the embedded cover art seems to still be intact