Issues seeing music in Subsonic- fuse-s3fs

General discussions.

Moderator: moderators

Issues seeing music in Subsonic- fuse-s3fs

Postby cheddarfist » Sat Nov 21, 2015 6:04 pm

I read the forums first and have seen this working by other users- and have tried the same, but have been unable to convince subsonic to index a s3fs (amazon s3) share. I've even manually made a directory and copied a file into the share (e.g. mkdir foo; cp blah.mp3 foo) and that didn't show up either (I read that subsonic wouldn't see directories that weren't make with mkdir or something).

The folders index fine anywhere in the filesystem (e.g. /home/subsonic), but not in the s3fs share. I've tried *everything* in the recommended posts including:

1> making a subsonic user and chmod'ing/chowning the folder to the user, modifying /etc/default/subsonic to run as 'subsonic' etc...
2> adding allow_other to the fstab entry- added a cache dir as well..just because why not..
3> hupping subsonic repeatedly as well as fuse
4> rescanning folders and clearing database out, etc
5> unmounting/remounting the fs then starting subsonic...etc

Nothing I've done will show allow music from a s3fs folder to show up in subsonic. I see no errors on the logs either...No permission errors etc...I've tried running it both as root and as a non-privileged user to no avail..

Any thoughts?
Thank you,
CF
p.s. ubuntu 14.04 ec2
cheddarfist
 
Posts: 1
Joined: Sat Nov 21, 2015 5:55 pm

Return to General

Who is online

Users browsing this forum: No registered users and 5 guests