Video playback on Android Tablet + Casting

General discussions.

Moderator: moderators

Video playback on Android Tablet + Casting

Postby squashed » Tue Dec 22, 2015 11:59 pm

I'm not sure I really have a problem - maybe my brain is too slow and too small now. Possibly just need the collective wisdom passing on.

I've been using Subsonic for years now and have been using it (V5.3) on a Windows 7 "Server" - The clients have been a mixture of Windows 7 Chrome and Windows XP Chrome. I have the Chomecast extensions loaded and everything works as I would expect it to. I can watch videos (different source formats) and listen to music with the Subsonic out-of-the-box settings for transcoding. I can cast music and videos from my Windows 7 Chrome browser. This all works fine - as standard.

I have just bought an Android Tablet - with Android 5 installed. I've installed the Chromecast app - apps like YouTube cast fine. I have installed Chrome browser and the Subsonic Android App (which, in turn installs the MX Player).

I have two problems that I need your help with:-

1. Video doesn't play at all in JWPlayer in the Chrome Browser on the tablet. It just shows the spinning 'loading' graphic. Music does but not first time - I have to pause and press play again.

2. Video in source AVI format doesn't play in the Subsonic App - but MPG and M4V does. However, if I force MKV format then it does but it takes an absolute age (10 minutes) to start the video (it's instant on my Windows PCs)

and an understanding 'issue' with casting.

Issue: err... not really sure how you cast from the tablet from Subsonic (music or video). With the Chromecast app installed I can 'Mirror my screen' but that's not quite the same thing is it? So, my understanding of native casting is that the context is handed to the Chromecast device that recovers it independently of the device used to initiate the cast. So for example, if I use the YouTube app then once I've handed control to the Chromecast device I could, in theory, switch off my tablet and it would continue on the TV. This is, indeed how it works on my Windows 7 PCs with Chrome Browser and Subsonic client.

No such concept on the Android Tablet. I must be missing something.

So, one posting = 2 problems and an explanation.

Thanks in advance.
squashed
 
Posts: 9
Joined: Sun Jul 18, 2010 3:51 pm

Return to General

Who is online

Users browsing this forum: No registered users and 2 guests