DLNA is not working

General discussions.

Moderator: moderators

DLNA is not working

Postby 3Dscrewer » Sat Mar 31, 2018 11:38 am

Hi ...
I can see the Server everywhere and I can Browse the Folders, can see playlist .... but can not play any tracks at different devices.
Thats the log
[31.03.18 13:14:33 MESZ]
UPnP request - objectId: 0, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 50
[31.03.18 13:14:35 MESZ]
and so on and so on .....

Any Ideas?


Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm

Re: DLNA is not working

Postby kampfhamster83 » Tue Jun 19, 2018 12:14 pm

I have the same problem, but maybe I have a starting point...
Go to your DLNA-Service by using the VLC player (local network / universal plug'n'play) and browse through to any title, click right on it and open "information".
In the last line of the dialog, you can check if the ip address is the same, that you call the service from.

In my case a have two network adapters (one for vpn) and the ip address in the last line is the ip of my vpn lan adapter even, if the ip of the dlna service is the normal local network address. So my dlna devices can browse the dlna service for playlists an tracks, but the play function do not work, because the dlna service of subsonic provides the play-link of the songs to the wrong network interface.

Posts: 1
Joined: Tue Jun 19, 2018 10:03 am

Re: DLNA is not working

Postby 3Dscrewer » Thu Jul 05, 2018 6:01 pm

Yes, that might be true. I'm using W10P with installed Hyper-V with Linux Server / Nextcloud. All Data is going thrue a virtual Networkcard and it is sometimes difficult for some progs assuming that the first entry is the right one.
Anyway, since a couple of time, it is working fine.
Thanks ...

Da du Deutsch bist ...
mir war das nur aufgefallen, weil AVM mit den Telefonen ja DLNA Server findet.
Primär benutze ich zwischenzeitlich einen Raspberry 3 mit optischen Digitalausgang und Volumio2 um die Musik an die Anlage zu streamen, Airplay geht damit auch, also von play:sub oder AVSUB. Damit ist DLNA im Grunde weniger interessant, nur funktionieren sollte es, wenn du verstehst was ich meine :D
Posts: 195
Joined: Tue Feb 13, 2018 1:11 pm

Re: DLNA is not working

Postby intangir » Wed Aug 08, 2018 8:12 pm

I had the same issue and found the answer:

login as admin, goto USERS

goto GUEST, set it to be able to play files, and give it access to your folders

also you can goto players, and look under the guest user, if you see that the last time guest was on was when you tried your DLNA/UPnP client, then its surely using guest access

i set it and it worked for me
Posts: 3
Joined: Mon Feb 13, 2012 3:51 am

Return to General

Who is online

Users browsing this forum: No registered users and 8 guests