Page 1 of 1

Two Instances, two different ports on Ubuntu 10.04 64bit

PostPosted: Tue Sep 21, 2010 12:09 am
by irie27
I'm running Ubuntu 10.04 64 bit. I'm running Subsonic to use port 4040. However, every once in awhile, another instance starts up and uses port 8080. When this happens, I no longer have access to the Subsonic server. I have to kill the Subsonic server running on port 8080. Once done, I then restart Subsonic and everything runs fine.

I can't figure out why another instance starts up.

thank you

PostPosted: Tue Sep 21, 2010 6:41 am
by bormuff
Did you previously run/install Subsonic via the standalone .tar.gz file, and now more recently have used the .deb package?

PostPosted: Tue Sep 21, 2010 9:26 am
by irie27
Can't remember. I've been running it for about 2 yrs now. I do remember using the .deb package the past few upgrades.

PostPosted: Tue Sep 21, 2010 8:12 pm
by bormuff
What do you get if you type:
Code: Select all
$ locate

You should get something like:
Code: Select all

PostPosted: Tue Sep 21, 2010 8:34 pm
by irie27
/usr/share/subsonic/ uses port 4040
/var/subsonic/ uses port 8080

That's my problem. Can I just move the files from /var/subsonic to /usr/share/subsonic without any problems?

PostPosted: Tue Sep 21, 2010 9:16 pm
by bormuff
I'd just rename the one that uses port 8080 to be something like subsonic.old for now.

Do you run Gnome or KDE or similar? Check the appropriate 'startup applications' menu option to see if there is something pointing to /var/subsonic/; if so, disable/delete it too.

PostPosted: Tue Sep 21, 2010 9:33 pm
by irie27
When I renamed the folder /var/subsonic to /var/subsonic.old , I restarted subsonic and the folder was created again.

Would it be easier to just delete both "versions" and reinstall from the .deb?

PostPosted: Tue Sep 21, 2010 9:44 pm
by bormuff
Don't rename the folder, just try renaming the .sh file inside it initially; you'll also want to try and work out why it gets called, my bet is as per my previous post.

Might also be worth checking under /etc/init.d/ to see if you have more than one Subsonic related file there. You should have just the one which will call /usr/bin/subsonic which in turn is a symbolic link to /usr/share/subsonic/

PostPosted: Tue Sep 21, 2010 10:05 pm
by irie27
I made the changes to startup. I'll reboot later and see what happens. Thank you for your help!