can stream on 3G but not over wifi

General discussions.

Moderator: moderators

can stream on 3G but not over wifi

Postby phlancelot » Thu Jan 06, 2011 1:44 am

Just got the server setup on my ubuntu lappy, managed to forward the required ports and i can access it by pointing to xxxx.subsonic.org in my browser just fine.

my problem comes when trying to access the library on my android 2.1 device. im using an HTC desire and got the subsonic app downloaded just fine, works with the demo songs great.

i had trouble connecting it to my server, i receive "A network error occurred" message 4 times then I get a "Connection Failure. A network error occurred. Please check the server address or try again later."

I tinkered around and noticed when I shut off wifi I can connect using the same settings that gave me the error with no problem over my 3G wireless carrier network.

i think it might have something to do with the fact that my android device is on the same wifi network as my laptop and so it is getting confused when i feed it the external IP?? I tried putting my internal IP for the laptop in 192.168.1.xxx:4040 but this does not seem to help anything, tried it without the port number to no avail also....

anyone know how i can access my songs from within the same wifi network that my server is using??

any help is greatly appreciated, thanks!!!
phlancelot
 
Posts: 6
Joined: Tue Jun 30, 2009 8:06 am

Postby alphawave7 » Thu Jan 06, 2011 4:00 am

Yes, the Android app has, IIRC, 3 server spots, so I used one as 'Home' which has my servers lan IP (192.168.0.3:8080). When home on wifi, I use 'Home'. Away, I use the subsonic.org addy. Works a treat.
alphawave7
 
Posts: 1037
Joined: Thu Feb 11, 2010 9:54 am

Postby phlancelot » Thu Jan 06, 2011 8:24 pm

I tired doing as you suggested alphawave7 but I run into problems when entering the IP address of my PC on the LAN. It seems if I enter anything without an http:// in front of it it gives me an "invalid URL" message so there seems to be no way I can enter the IP. If I do just put the IP after the http:// I still get the same error as before... seems strange if it works for you, I wonder if its a different version of the android app or something?

anyone else experiencing this problem?
phlancelot
 
Posts: 6
Joined: Tue Jun 30, 2009 8:06 am

figured it out!

Postby phlancelot » Fri Jan 07, 2011 5:31 pm

OK so i followed a guide to subsonic i found elsewhere on the web and I managed to find a work around in case anyone else has the same problem and is wondering how to fix it.

as i said before it works fine when im on the 3G network out and about.... to fix my problems on wifi I changed the 3rd address in the android app to http://xx.xx.xx.xx:4040 where the x represent my EXTERNAL IP address... originally I was using the INTERNAL one but found this to just give me 4 network errors. I am quite puzzled as to why this works and pointing to http://xxxx.subsonic.org does not as I thought they essentially route to the same thing.... oh well, not complaining... I now have a functional subsonic stream anywhere I need it!!! time to donate to this AMAZING program!

happy streaming!
phlancelot
 
Posts: 6
Joined: Tue Jun 30, 2009 8:06 am


Return to General

Who is online

Users browsing this forum: Bing [Bot] and 5 guests