Can't Connect At Work

General discussions.

Moderator: moderators

Can't Connect At Work

Postby shizzyraw » Tue Jan 11, 2011 10:50 pm

I absolutely love subsonic, but I have one problem, I can't connect from the office. I'm pretty sure it has something to do with a policy that blocks dotted decimal IP addresses or port redirects or something like that. I type in my subsonic address i.e. user.subsonic.org and it seems like it's going to connect but once the address in the address bar switches to my servers IP address:port it gets blocked. I set up a host at no-ip and tried that for the redirect but ended up with the same result.

I have used homepipe.net (doesn't redirect to my IP, www.homepipe.net/user1234 format) to listen to my music on my server at home while at work but now they are pushing a premium monthly membership to use it more than 10 times a month. I really want to avoid this as it is the most poorly laid out, ugly cumbersome interface that I have ever seen.

Has any one else experience a similar challenge and thought of a clever work around? If so please share.
shizzyraw
 
Posts: 5
Joined: Tue Jan 11, 2011 10:34 pm
Location: US

Postby fonsoy » Wed Jan 12, 2011 1:05 pm

I haven't experimented with it, but in the command console it's possible to assign a /subsonic virtual directory to subsonic. Does that allow you to run both your default web server and the subsonic web server on port 80?
fonsoy
 
Posts: 38
Joined: Mon Jan 10, 2011 12:07 pm

Postby bushman4 » Wed Jan 12, 2011 4:39 pm

If your problem is really that they do not allow connections to dotted decimal names, one option would be to set up a domain and have it redirected to your house... it takes a bit of setup, and maybe a few bucks a year for the domain name, but it's doable.

I would find the cheapest registrar that you can, and register any domain you'd like. Then, go to zoneedit.com and set up free DNS hosting for that domain... this is a couple of steps, including notifying your domain registrar that zoneedit.com is hosting your DNS for you.

Then, add an entry to your zoneedit zone with your IP address and a name like "subsonic."

Then, http://subsonic.domain.com:portnumber should work...

This is assuming that your problem really is the dotted decimal notation, and NOT the port number... a quick test:

do you see my login page?

http://GlennSullivan.HomeServer.com:8082

If so, then this should work for you.

If not, your company may be blocking ports besides 80, and that will require a different solution.

Hope this helps,

Glenn
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Postby shizzyraw » Wed Jan 12, 2011 5:09 pm

Glen,

Yup, It is the port number. This morning I pinged www.google.com and got the IP address, typed that into the address bar and the page popped up no problem. Couldn't see your log in page either. I'm guessing the don't allow port numbers in address (address:port)

Will a domain still work, or you think I'm screwed?
shizzyraw
 
Posts: 5
Joined: Tue Jan 11, 2011 10:34 pm
Location: US

Postby fonsoy » Wed Jan 12, 2011 5:35 pm

shizzyraw wrote:Glen,

Yup, It is the port number. This morning I pinged www.google.com and got the IP address, typed that into the address bar and the page popped up no problem. Couldn't see your log in page either. I'm guessing the don't allow port numbers in address (address:port)

Will a domain still work, or you think I'm screwed?


I recommend you to run the server on a non-blocked port. In many cases port 22, 21, or 443 isn't blocked. I especially recommend port 443. In most cases it's meant for HTTPS, but using it for Subsonic couldn't harm you.
fonsoy
 
Posts: 38
Joined: Mon Jan 10, 2011 12:07 pm

Postby bushman4 » Wed Jan 12, 2011 6:05 pm

I agree with fonsoy... unless you are not running another web server on your machine, in which case just use port 80...

Are you running another web server? Do you need to be? If it's a windows box, sometimes IIS is loaded even if you are not using it, but it's easy to disable...

If you choose to use port 443, make sure that you still use http:// in front of the URL, NOT https://. All current popular browsers should be OK with that...

Do you have any techie friends in your IT department? If this doesn't work, they may be doing stateful inspections on these other ports, and disallowing traffic that is not designed for that port... but that is unlikely. You would need help from IT to go much past this, unless you can get it on port 80.

HTH,

Glenn
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Postby shizzyraw » Wed Jan 12, 2011 8:18 pm

Trying to use port 443 but I can't even connect locally. localhost:443 fails (firefox can't establish a connection with the server at localhost). The server is configured correctly and the sys tray says the server address is http://localhost:443/ . I think I'm almost there, I use teamviewer at work because It's the only VNC software that works, now I know it's because it uses port 443 (and yes I have it disabled at the moment so that port should be clear). Any Ideas? Would IIS have something to do with it (not sure what it is)?
shizzyraw
 
Posts: 5
Joined: Tue Jan 11, 2011 10:34 pm
Location: US

Postby bushman4 » Wed Jan 12, 2011 8:31 pm

IIS would definitely have an issue...

What version of windows are you running on?

What comes up if you go to:

http://localhost

how about

https://localhost

If you want to test to see if IIS is stepping on SubSonic's toes, open a command prompt and type:
Code: Select all
Net Stop "World Wide Web Publishing"


Then set subsonic to use port 80 and restart subsonic. then try:
http://localhost

If that works, and you don't need IIS, then it should be easy to disable IIS and then just use Subsonic on port 80...

Glenn
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Postby shizzyraw » Wed Jan 12, 2011 9:43 pm

Glenn,

Windows 7 Ultimate x64

When the Subsonic port is set to 80

http://localhost - brings up the subsonic login page

https://localhost - firefox can not connect

I have never had a problem connecting to subsonic (or any other web servers, such as SABnzbd, sickbeard) through locally through port 80 but my office must be blocking it. Port 443 is what's giving me trouble. I ran the command you provided, and still can't connect locally through port 443.
shizzyraw
 
Posts: 5
Joined: Tue Jan 11, 2011 10:34 pm
Location: US

Postby bushman4 » Thu Jan 13, 2011 1:15 pm

OK, so it sounds like you CAN run it on port 80...

Have you tried to open port 80 on your router, and then accessed your IP address directly from work?

Unless you ISP is blocking port 80 inbound (which it might) then you should be able to just use:

http://IP.Add.re.ss

from work, and it should work...

Glenn
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Postby shizzyraw » Fri Jan 14, 2011 6:12 pm

Glenn,

You, good sir are a genius! Sure enough setting it to port 80 worked. Now typing in my external IP address, (without a port number) at work takes me right to the Subsonic log in page. Of course, teamviewer was also occupying port 80 in addition to 443 on the media server, so I wound up setting up the Subsonic server on my HTPC, and setting up a netwok share to the drive in the media server where my music lives (which in itself was a bit of a pain). Now all is good in my world, thanks again for all of your help!!

Shannon
shizzyraw
 
Posts: 5
Joined: Tue Jan 11, 2011 10:34 pm
Location: US

Postby bushman4 » Fri Jan 14, 2011 6:14 pm

No problem... networks is "what I do..."

Glad I could help,

Glenn
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA


Return to General

Who is online

Users browsing this forum: No registered users and 3 guests