[Android] Bug - credentials cached when switching servers

General discussions.

Moderator: moderators

[Android] Bug - credentials cached when switching servers

Postby WPWoodJr » Tue Feb 01, 2011 5:04 pm

I'm trying to access the same Subsonic server with two different sets of credentials from the Android app. One set is my admin account the other is my guest account. However after switching from one server configuration to the other in the Android app, the credentials are cached and I remained logged in to the previous account. Even if I go into setup and change the credentials to something bogus, I am still logged in.

Exiting the Subsonic app and re-starting it does not help. It must be the PC Subsonic server that is caching the credentials?
Last edited by WPWoodJr on Wed Feb 02, 2011 1:28 am, edited 1 time in total.
WPWoodJr
 
Posts: 29
Joined: Tue Feb 01, 2011 12:40 am

Postby wizardai » Wed Feb 02, 2011 12:28 am

I'm not sure about that. When I first set up the android app the same happened to me. So I ended up making server #2 my server and leaving server #1 alone. Once I did that it worked for me. Doesn't seem that the cached info updates well/right away.
wizardai
 
Posts: 13
Joined: Wed Feb 02, 2011 12:14 am

Postby WPWoodJr » Wed Feb 02, 2011 1:30 am

I had Server #2 set up as my admin account and Server #3 set up as my guest account. Initially I used Server #3 and got into the guest account. When I went back to Server #2 it remained logged in as guest (I could tell through the server's web interface).

After awhile (an hour or so?) the cached credentials expired and I was able to get into my admin account using the credentials stored in Server #2.
WPWoodJr
 
Posts: 29
Joined: Tue Feb 01, 2011 12:40 am


Return to General

Who is online

Users browsing this forum: No registered users and 3 guests