Remove ffmpeg clutter from log files

Tutorials, tips and tricks.

Moderator: moderators

Remove ffmpeg clutter from log files

Postby spookybathtub » Wed Mar 05, 2014 4:24 am

I started noticing errors like this in my subsonic.log file when playing certain songs.
Code: Select all
[2014-03-04 19:09:37,118] DEBUG InputStreamReaderThread - (/var/subsonic/transcode/ffmpeg) [swscaler @ 0x1cc44f0] deprecated pixel format used, make sure you did set range correctly
[2014-03-04 19:09:37,125] DEBUG InputStreamReaderThread - (/var/subsonic/transcode/ffmpeg) [swscaler @ 0x1cc44f0] No accelerated colorspace conversion found from yuv420p to rgb24.
[2014-03-04 19:09:37,127] DEBUG InputStreamReaderThread - (/var/subsonic/transcode/ffmpeg) [mp3 @ 0x1ccf170] Frame rate very high for a muxer not efficiently supporting it.
[2014-03-04 19:09:37,128] DEBUG InputStreamReaderThread - (/var/subsonic/transcode/ffmpeg) Please consider specifying a lower framerate, a different muxer or -vsync 2

It never really hurt anything, but I don't like cluttered log files, so I tracked down the problem. When ffmpeg encounters a song with album artwork, it processes it as a video track, usually with MJPEG encoding. We can tell ffmpeg to ignore video tracks by adding -vn to the transcode settings, like this:
Code: Select all
ffmpeg -i %s -vn -ab %bk -v 0 -f mp3 -

This makes cleaner log files, reduces hard drive access, and might reduce CPU consumption by a microscopic amount. Don't worry about the album artwork, Subsonic processes it separately, so it will still appear in web views. Of course, don't add this to your video transcoder.
spookybathtub
 
Posts: 110
Joined: Thu Oct 07, 2010 7:13 am

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 2 guests