How to install Subsonic on FreeNAS

Tutorials, tips and tricks.

Moderator: moderators

Re: How to install Subsonic on FreeNAS

Postby anika200 » Thu Nov 21, 2013 7:27 pm

Hello All,

I have posted a howto thread for freenas 9.1.1 over at their forumshttp://forums.freenas.org/threads/how-to-install-subsonic-4-8-on-freenas-9-1-1.15016/.

If there are any suggestions please let me know, Thanks
anika200
 
Posts: 2
Joined: Fri Jun 14, 2013 12:20 am

Re: How to install Subsonic on FreeNAS

Postby mcavity » Fri Mar 14, 2014 3:48 pm

Now its a drop in plugin on freenas 9.2.1.2 !
mcavity
 
Posts: 11
Joined: Sat May 02, 2009 3:15 pm

Re: How to install Subsonic on FreeNAS

Postby TroyAR62 » Sat Sep 27, 2014 4:54 pm

I recently set up FreeNAS version 9.2.1.7 and it does not seem that drop in plugin for Subsonic works.....or I am just not bright enough to get it figured out. I have Plex set up and working just fine. Any help someone can give is greatly appreciated. I add storage to "media" and it seems I am never able to mount it, so even though I can get the web gui to open.....I can never add any media folders. Then, when I reboot the server, Subsonic does not restart and when I try to manually start it, it fails to start.

Greatly appreciate any assistance.....I have been using Subsonic for quite some time now on Windows, but would like to set up on a NAS server instead. Also have been using MusicCabinet on a Windows box and was wondering if there are any similar forks which allow for the LastFM features such as artist radio and artist top tracks?

Thanks,

Troy
TroyAR62
 
Posts: 1
Joined: Sat Sep 27, 2014 10:08 am

Re: How to install Subsonic on FreeNAS

Postby mudsharkymon » Fri Dec 27, 2019 3:33 am

Oh, boy. I see this thread not updated in a couple of years...
FreeNAS 11.2 is out with a new interface and a new way to configure plugins.
The subsonic (6.0_7) install is filling in defaults to the jails it creates as you "Next" through the install.
Each of the last screens of the install (Jails, Network, and Custom) I am at a loss how to answer.
allow_tun? Maybe?
And, does anyone know why if you look at the "Legacy" interface it shows under plugins only "Installed" not "Available"?
Thanks all
Playback Application and version: Subsonic
Subsonic Version: 5.1 (build 4310) - January 18, 2015
Server Version: jetty-6.1.x, java 1.7.0_65, FreeBSD (86.2 MB / 148.0 MB)
Hardware Platform: FreeNAS
mudsharkymon
 
Posts: 57
Joined: Mon May 04, 2009 5:36 am

Previous

Return to Tutorials

Who is online

Users browsing this forum: Bing [Bot] and 2 guests