How to install and optimize subsonic on a Qnap NAS Server

Tutorials, tips and tricks.

Moderator: moderators

Re: Problem compiling ffmpeg

Postby subsolar » Wed Aug 31, 2011 9:21 pm

Morkeleb wrote:
subsolar wrote:Seems the current ffmpeg from mplayer2 requires a newer version of x264:
Code: Select all
[/opt/etc/mplayer2-build] # make
script/ffmpeg-config
ERROR: libx264 version must be >= 0.115.

What to do now? :oops:


I'm afraid I can only suggest to use an older version of mplayer2.
Another option would be to ask in the developer irc channel of mplayer2
(#mplayer2 on irc.freenode.net)
divVerent is the main developer and he should be around from time to time.
Ask him for advice.

I tried to compile the latest version of x264 (i think i mentioned this already).
Compiling itself works, however apparently due to an outdated version of gcc,
the resulting build is not ok and it will cause x264 to crash.

Others in an x264 channel could not reproduce the error, but that was because
they had a proper gcc version - they say 4.2 is buggy and should be avoided.

I tried to compile gcc but it has many dependancies and I just did not manage it.
Maybe you have more success.

Sorry I can give a solution...


Can you (or anyone) give the steps on how to switch to an older version of mplayer2 (the one you were/are using)? I'm not at all familiar with git (and not exactly familiar with Linux either).
subsolar
 
Posts: 3
Joined: Sun Aug 14, 2011 11:57 pm

Re: How to install and optimize subsonic on a Qnap NAS Serve

Postby Morkeleb » Wed Oct 26, 2011 12:44 pm

Hi there.
To get an older version of mplayer you would need to checkout/clone an older version instead of the current one.
See http://stackoverflow.com/questions/1655 ... -about-git
If you knew the correct version (some hashcode that represents the version in git) you can follow
my guides and instead of checking out the current version, check out the old one.
You may however need to check out an old version of both mplayer2 and the additoonal changes from divverent.

Since this is more complicated here since it involves merging two repositories I don't know
enough about git to tell you the versions I have. All I can give you is my current git diff output:
diff --git a/mplayer b/mplayer
index 618f760..6fb05f6 160000
--- a/mplayer
+++ b/mplayer
@@ -1 +1 @@
-Subproject commit 618f760866441a01051a0177529c7524082f4e37
+Subproject commit 6fb05f6694444a5d186a4e65bc78afabe8db7e2b-dirty

I however made a copy of my mplayer2-build, you can try that one:
http://85.126.136.170:81/mplayer2-build.tar.bz2

Its path for me is /opt/etc/compile/mplayer2-build
and it's state is directly after I compiled and installed it.
So you may only need to do an install yourself.

Hope this helps
Morkeleb
 
Posts: 19
Joined: Wed Mar 02, 2011 9:35 pm

Re: How to install and optimize subsonic on a Qnap NAS Serve

Postby subsolar » Thu Nov 24, 2011 7:15 pm

Thanks again, I did download your copy. Unfortunately things did not work from there either. I also tried to recompile the project with some different options, but it always gives an error at some point.
Code: Select all
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1
[/opt/etc/compile/mplayer2-build/mplayer] #


Oh well.
subsolar
 
Posts: 3
Joined: Sun Aug 14, 2011 11:57 pm

Re: How to install and optimize subsonic on a Qnap NAS Serve

Postby wowo » Thu Nov 24, 2011 8:59 pm

I have an QNAP TS-239 Pro II. It has an Intel Atom 1.8GHz Single-core Processor.
I have installed Subsonic with the qpkg from sl1000 this can be found on the QNAP international forum:
QPKG Software Application Disussions > Subforums > QPKG Betas > Subsonic > [QPKG] Subsonic

It works very good. (Subsonic.qpkg version 4.5)
Subsonic 4.7 (build 3105) running on QNAP TS-239 Pro II (Intel Atom 1.8GHz Single-core ; 1GB RAM)
wowo
 
Posts: 24
Joined: Mon Oct 24, 2011 9:27 pm

Re: How to install and optimize subsonic on a Qnap NAS Serve

Postby patters » Sat Aug 04, 2012 1:29 pm

A little off topic, but...

@Morkeleb, I'm trying to compile Perl with threads enabled on Synology NAS (also ARM CPU) and I'm running into a segmentation fault in the compile. Searching high and low I can see someone (possibly you) had posted about having this exact issue on Qnap on various linux/perl lists but with no solution:
http://www.linuxquestions.org/questions ... pl-922506/
http://www.linuxquestions.org/questions ... rl-923545/

Did you run into this problem? And if so how might I get past it? I had initially struggled with it not picking up shared libraries properly. I have been fixing that Errno.PL issue as per your post in this thread, then running:
Code: Select all
export LD_LIBRARY_PATH=/opt/lib:/opt/arm-none-linux-gnueabi/lib
./Configure -de -Dcc=gcc -Dprefix=/opt -Dusethreads -Dlocincpth='/opt/arm-none-linux-gnueabi/include /opt/include' -Dloclibpth='/opt/arm-none-linux-gnueabi/lib /opt/lib /lib'
make

Which eventually results in this error at the point at which it uses perl to compile the documentation I think:
Code: Select all
./perl -f -Ilib pod/buildtoc -q
make: *** [pod/perltoc.pod] Segmentation fault (core dumped)

I have tried perl-5.16.0 and then also perl-5.12.3 (the version from your example) with the same result.
I also read that someone had the same issue, but got around it by compiling with symbols enabled (-g compiler flag). This didn't work for me unfortunately.
patters
 
Posts: 1
Joined: Sat Aug 04, 2012 1:02 pm

Re: How to install and optimize subsonic on a Qnap NAS Serve

Postby Morkeleb » Sat Aug 18, 2012 11:03 am

I'm sorry I can't help you on this much except provides some thoughts. I never had such an issue and I would need to research it from the start as you already have and I don't really have that much experience either (and it's now been a long time since I worked on the subject) and just found a way for me to compile perl.

Obviously so many things can go wrong when compiling and they can be rather diverse and each needs its own investigation. I for instance never managed to compile a newer version of gcc on my qnap.
And that might actually be something you want to consider: Try different versions of gcc when compiling perl.
I have the impression that the issue might not be with what you are compiling but that the compiler throws up on the stuff it tries to compile. Another (if possible later) version of gcc might do better here.

But thats really just a though off the top of my head.
Morkeleb
 
Posts: 19
Joined: Wed Mar 02, 2011 9:35 pm

Re: How to install and optimize subsonic on a Qnap NAS Serve

Postby thechez » Sun Dec 28, 2014 2:51 am

I tried following the basic instructions on here and got the big three to install. Then I got stuck
trying to find the MD0_DATA folder using ssh.

Does anyone know where the Tomcat files are located on one of the ARM based NAS'?
I have a TS-231 where I'm trying to install an instance of Subsonic but am unavailable to find
the MD0_DATA folder. I'm not seeing it in any of the folders so I'm unable to edit the Tomcat
users. Does anyone know if they changed things significantly with the ARM Marvell processors?

Thanks.
thechez
 
Posts: 2
Joined: Sun Dec 28, 2014 2:43 am

Previous

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 1 guest