Page 2 of 4

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Tue Oct 11, 2011 12:34 am
by Robandcathy
Ugh I had it running for a while, then I crashed my server playing with cert's. I know the guide was very well written with some variables which through trial and error i figured out, now since I had to reinstall back to basics and stuck again.
I went through the entire install. On my srver localhost:8080 brings up subsonic, on client it does not. Which telles me that the server firewall is not configured correctly. On the server I opened 8080 udp/tcp for incoming and port 80 udp/tcp for out going, am I missing some ports? Seems like install went well just can't get to real world yet again.

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Tue Oct 11, 2011 1:31 am
by Robandcathy
So back to ground zero, if someone can post firewall walk through would be great, I have installed and working properly ('if windows firewall is turned off") I added udp/tcp incomming for port 8080 and out going port 80 TCP/UDP what am I missing?? I dont want to open up to many ports.

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Tue Oct 11, 2011 2:25 am
by BKKKPewsey
Can you confirm the following
  1. The subsonic server is on a Windows 7 pc and has a standard Microsoft firewall (No nasty Norton crap :evil: )
  2. With the firewall ON, from the server, localhost:8080 brings up SS ok
  3. With the firewall ON, from a client machine within the local lan, ServerIP:8080 does NOT access SS (What do you get in browser?)
  4. With the server firewall off you can access SS from within your own lan from a client pc

Could you answer in the help section as we are no longer in Tutorial territory
:mrgreen:

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Wed Nov 02, 2011 1:11 pm
by stafari
Great post! Worked fine on Win2008R2. One thing that wasnt covered by the OP was the network sharing issues. I dont have any of my media local to the box, and with the normal subsonic setup, just change the Logon As service tab to a local account to access network shares. In this guide, change the Apache Logon As service to your network account, AND give it Admin rights on the local box to start the service.

very great work! thanks!

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Mon Dec 05, 2011 7:18 pm
by bpschroder
What are you using on the Home Server for DNS local services?

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Wed Dec 14, 2011 12:01 am
by csobsidian
Sorry for the delay in answering and the long absence from the forum. Thank you all for assisting those with questions in the interim and for those with suggestions for improvements.

@Robandcathy: I know your post was from two months ago, but were you able to resolve your issues?
@stafari: Thanks for the info. I host all of my media on the WHS box itself and therefore was not aware of and did not include any fix for using remote files. My guess is that this will be 99.9% of the people with WHS2011 (or straight-up 2008R2).
@bpschroder: I have modified some entries in the DNS server that comes installed with WHS2011. There is ample information out there on this but if you need some specific help I can try to help out as I have time. Feel free to PM me directly and I will answer as I can.

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Mon Jul 16, 2012 12:03 am
by domenicfz
I have successfully installed Subsonic using Tomcat and IIS. Everything works perfect except when I tried to upload a zip file remotely (using www.mydomain.com). It throws the following error (which I am sure is an IIS error)

Server Error
404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

However, it works just fine when logged in to the server on my home network (localhost)

I apologize if this is posted somewhere but I have yet to find it. Thanks in advance to any help/direction to a fix on this.

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Tue Jul 17, 2012 10:45 am
by trickydick
@bpschroder - I'm using m internal DNS builtin to window. I do not run a domain (any longer). I turn off filter interal redirection on my router so I can access my sites interally.

@domenicfz - can you upload the zip file using the direct Ip? You may have up your IIS header binding to allow the IP (or if its the only site remove all bindings). Have you check IIS to see if Zip files were allowed?

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Wed Aug 22, 2012 7:34 pm
by wvcs
Great stuff. I guess the question I have what approach would I take if I simply want to add the /subsonic to my outside registered WHS 2011 server? This would minimize my effort to register another address and still allow the default whs.domain.com site to end up at the WHS default page. Would I remove the rewrite rule and/or change the subsonic bindings?

Thanks Bill

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Sat Aug 25, 2012 12:43 pm
by wvcs
I'm getting a little closer using this solution, but now I seem to have a problem. I'm seeing a redirect loop. Any thoughts or recommendations?

Thanks Bill

EDIT:

RESOLVED: The problem I was have was in the rewrite rule. I was using a pattern match of subsonic since I'm using the default subdirectory behind my WHS 2011 server. Once I change it to wildcard and used an * it worked perfectly from both inside and outside my router. mywhs.homeserver.com/subsonic.

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Sat Sep 22, 2012 3:50 am
by Robandcathy
Been waiting till official release of 4.7 has anyone instaled this on whs 2011, would I follow the same directions?
Tks Rob

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Sat Sep 22, 2012 5:09 am
by GJ51
Runs fine on WHS 2011. Just run the Winsows Setup.exe to upgrade. Remember to edit the service logon permissions if you need to access shares stored elsewhere. Other than that it should just upgrade and be ready to go.

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Sun Sep 23, 2012 1:35 am
by Robandcathy
Just to be certain, because every time I touch this I end up with a thousand issues....so I no longer need the .war file and just use the exe, one, and should I use tomcat 6 or 7 because I know tomcat 7 had issues with whs2011. Thanks

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Sun Sep 23, 2012 2:43 am
by GJ51
Now you're getting a bit more complicated.

You can use either, ... but ... for most users the Windows installer is easier.

The important thing to understand is that you should select one and then stick to that vesion.

The Windows installer is easier because you get the icon in the tray that allows you to easily set up what port you want to use. WHS uses 80/443 already so you want to make sure that you use a different port for Subsonic - it's just easier. Secondly, setting up SSL in the Windows version is also much easier.

If you go with the Windows installer, just follow the Windows instructions in the Tutorial section.

The WAR version does have advantages, but fo most users it's a bit more complicated to install. You have to set up Tomcat and the follow the instructions on the Subsonic instructions page on the Subsoic website. It's not too difficult. but setting up SSL can be a bit of a challenge - in fact one I have yet to conquer.

If you already have the WAR version up and running - then just stop Tomcat, delete the work directory, the subsonic directory under tomcat/webapps, and delete the old war file - then drop in the new WAR file and restart Tomcat.

ONLY USE Tomcat 6

Re: Setup Subsonic on IIS 7 (Windows Home Server 2011) - ARR

PostPosted: Sun Sep 23, 2012 2:54 am
by GJ51
Robandcathy wrote:Just to be certain, because every time I touch this I end up with a thousand issues....so I no longer need the .war file and just use the exe, one, and should I use tomcat 6 or 7 because I know tomcat 7 had issues with whs2011. Thanks


If you alreday have the WAR version running without problems then just download and use the new WAR file as I described above.

Stop Tomcat - if you're already running the WAR version you don't need to reinstall Tomcat - just stop the service.

Open file explorer to C:\Program Files\Apache Software Foundation\Tomcat 6.0 - delete the work subdirectory

Go to C:\Program Files\Apache Software Foundation\Tomcat 6.0\webapps and delete the subsonic directory and the subsonic .war file (this is not the C:\Subsonic that stores your users and data - do not worry about deleting this)

Copy the new Subsonic.war file into C:\Program Files\Apache Software Foundation\Tomcat 6.0\webapps

Restart Tomcat

Thats all there is to it if you already have the WAR version currently running.

Please ask if this isn't clear.