Subsonic for Synology

Third-party modifications and add-ons, Apps and Clients

Moderator: moderators

Re: Subsonic for Synology

Postby mbirth » Sat Dec 05, 2015 1:15 am

For people with a Docker-capable Synology, I'm using the hurricane/docker-subsonic image and it works flawlessly. Didn't try transcoding, though. But since it's using a Debian base image, all needed tools are just an apt-get away.
User avatar
mbirth
 
Posts: 5
Joined: Tue May 17, 2011 8:01 am

Re: Subsonic for Synology

Postby Oxize » Tue Jan 12, 2016 3:02 pm

I am still using Version 4.8 (build 3434) – April 17, 2013, since nobody want to make a package for Synology Community. If you guys have a step by step guide how i can install an upgraded/fresh subsonic install on my synology (ds214+), let me know. There alot more ppl who want the lastest version of subsonic installed. I have root-access with gate-one.
Oxize
 
Posts: 1
Joined: Tue Jan 12, 2016 2:57 pm

Re: Subsonic for Synology

Postby Marquepr » Sat Jan 30, 2016 3:10 pm

This is how I upgrade:

1- Download the latest subsonic.war file from the subsonic website.
2- Stop the running Subsonic 4.8 package on your nas
3- Connect to your NAS through SSH
4- Go to the Subsonic folder on the NAS
Code: Select all
cd /volume1/@appstore/Subsonic

5- Remove the old subsonic.war
Code: Select all
rm subsonic.war

6- Copy the newly downloaded subsonic.war to the Subsonic Folder (replace /volume1/public with your download location)
Code: Select all
mv /volume1/public/subsonic.war  /volume1/@appstore/Subsonic

7- Restart the Subsonic Package from the Package Manager GUI

You may need to wait a few minutes before accessing Subsonic again. There is probably something that could be restarted from the command line but I am quite inexperienced with the CLI... Anyway this has been working for me for nearly 2 years, until I upgraded to DSM 6.0 Beta 2 last weekend. So if your are running any DSM version other DSM 6.0 Beta2, this will work.
Marquepr
 
Posts: 3
Joined: Sat Jan 30, 2016 2:55 pm

Re: Subsonic for Synology

Postby rezn0r » Wed Feb 03, 2016 4:34 am

Marquepr wrote:This is how I upgrade:
----
You may need to wait a few minutes before accessing Subsonic again. There is probably something that could be restarted from the command line but I am quite inexperienced with the CLI... Anyway this has been working for me for nearly 2 years, until I upgraded to DSM 6.0 Beta 2 last weekend. So if your are running any DSM version other DSM 6.0 Beta2, this will work.


So simple but so brilliant, THANK YOU. I had been sitting on 4.8 for an extremely long time and was scared to screw with it until I found your post. The only other thing I had to do was fix the perms on the .war file with chown subsonic:users subsonic.war

Sucks to hear your method broke for DSM6b2 - maybe it's something to do with Java paths or env variables being reset with the OS upgrade?

Either way - thanks again!
rezn0r
 
Posts: 1
Joined: Wed Feb 03, 2016 4:14 am

Re: Subsonic for Synology

Postby barnyd » Thu Feb 11, 2016 11:45 am

Hi to everyone, new to the forum, but not new to Subsonic, ive had a version running on my PI for over a year now which has integrated pretty seamlessly with my Sonos setup.

Anyway, i recently purchased a Synology DS716+ nas, which is a fantastic piece of kit. I fancied having Subsonic running on it and have followed the guides on here down to the letter but ive run into a issue which i can only think is file system related.

It all seems to configure and work fine, however when i click 'scan media folders' nothing happens. The shares are setup fine, the permissions are fine (ive used 'Everyone'). There is also nothing happening in the logs.

When i plug a NTFS formatted USB drive into the NAS and setup some shares with some music on, they are picked up and scanned in the libary perfectly and as expected. All i can think of is that it is the Btrfs filesytesm (non RAID) being used on the NAS. Ive started from scratch and tried the Subsonic 6 beta version but its still the same.

Does anyone have any advice, or ideally any expereince with using Btrfs formatted drives with Subsonic ? Im not actually convinced its a Synology issue so this may not even be the right place to ask!

many thanks in advance :P
User avatar
barnyd
 
Posts: 5
Joined: Thu Feb 11, 2016 11:22 am

Re: Subsonic for Synology

Postby Optira » Thu Feb 11, 2016 4:50 pm

Hi barnyd,

it has nothing to do with Btrfs. I've an DS216+ (also Btrfs) and had the same problem. I did a lot of testing and found a solution: You need to add the user/group "http" (read) to the folder. Then delete and again add the media-folder in subsonic (/volume1/###).
Optira
 
Posts: 12
Joined: Tue Aug 18, 2015 9:05 pm

Re: Subsonic for Synology

Postby barnyd » Thu Feb 11, 2016 5:19 pm

Hi Optira,

Thanks so much for the reply. Great to know its not the filesystem. Ill give it a whirl and let you know. Forums like this are wonderful :D
User avatar
barnyd
 
Posts: 5
Joined: Thu Feb 11, 2016 11:22 am

Re: Subsonic for Synology

Postby barnyd » Thu Feb 11, 2016 8:54 pm

Yep, it works. I figured it mustve been filesystem based rather than permissions as it worked on my usb drive but there you go. Thanks for doing all the hard work for me prior!

Run into another issue now, I cant connect Sonos to Subsonic. It wont connect when i add my username and pw from within Sonos apps, says a connection could not be made.Thats for another day and not for this sub board anyway!

Thanks for all your help.
User avatar
barnyd
 
Posts: 5
Joined: Thu Feb 11, 2016 11:22 am

Re: Subsonic for Synology

Postby Optira » Thu Feb 11, 2016 8:56 pm

raydiognome wrote:I stopped and started Tomcat and of course now Subsonic won't start! Just like DviousDogzz I get "FAIL - Application at context path /subsonic could not be started.

Same here - can't get Subsonic running again. Seems Subsonic isn't working with Synology/Tomcat very well.
Will go back to my raspberry...
Optira
 
Posts: 12
Joined: Tue Aug 18, 2015 9:05 pm

Re: Subsonic for Synology

Postby barnyd » Thu Feb 11, 2016 9:56 pm

That happened to me a few times today as well after stopping Tomcat, a simple (but annoying) reboot of the Diskstation sorted it out
User avatar
barnyd
 
Posts: 5
Joined: Thu Feb 11, 2016 11:22 am

Re: Subsonic for Synology

Postby himayv » Tue Apr 05, 2016 7:55 pm

it has nothing to do with Btrfs. I've an DS216+ (also Btrfs) and had the same problem. I did a lot of testing and found a solution: You need to add the user/group "http" (read) to the folder. Then delete and again add the media-folder in subsonic (/volume1/###).


Hi Optira,

Could you say more about how you did this? I followed these instructions, but my Synology's Subsonic instance (5.3, running hurricane image via Docker) won't see any of my music. My music is all sitting at the root of a share called "music" and I've tried changing the permissions both on the http group as well as all users, but it doesn't see my music. I even tried creating a brand new share with full control to everyone, but it couldn't see it. Oddly, it's able to save "/music" as a folder location, but any other folder I enter leaves a red "location not found" message.

Could you (or anyone else) say more about how they're able to configure their Synology so Subsonic can see their music files? I know it must be permissions but I feel like I've tried everything there. Thanks in advance!
himayv
 
Posts: 1
Joined: Tue Apr 05, 2016 7:35 pm

Re: Subsonic for Synology

Postby vferg » Tue Sep 20, 2016 8:41 pm

I know its been several months since the last post but I just came to say THANK YOU for that last comment on permissions... I got my first NAS a month ago and have slowly been transferring data plus applications over to it. I never expected it to be so difficult to run some of the applications I use on it! Subsonic in particular had some of the least support. Thankfully I used ghenry22's GitHub setup and even tried using the wad file swap to get the latest version which all worked WAY easier than expected. Of course when I went to add music I had the same issue ive seen a lot of people have which is getting music to appear after adding the library. For the last few weeks I have tried a lot of stuff but after seeing this post about providing http with read permissions I decided to check, sadly that one did have permissions for read but decided to give read/write to the library and added it back after that and sure enough all music is now there. Thanks for the comment about http and also thanks ghenry22 overall for providing us with what looks to be the only real way to get the latest version of subsonic setup on synology! Now on to the next problem lol.
vferg
 
Posts: 37
Joined: Wed Feb 13, 2013 6:53 pm

Re: Subsonic for Synology

Postby vferg » Wed Dec 28, 2016 3:50 pm

So after a few months of this running stable I ran into my first big issue that I will need to address relatively soon. Since this setup is done on the system partition of the Synology it is starting to become a problem. The system partition appears to be a little over 1gb in size and my subsonic directory has grown to almost 700mb in size. So Subsonic, along with Synology's system files, has now taken up over 90% of free space on the device. I actually ran out space but was able to delete a subsonic log file that grew pretty large which helps me for now but this is going to become an issue sonner than later again. I haven't tried anything yet but wondering if anyone may have any ideas as to what I can do to resolve this? Ultimately it would be great if this entire directory could be moved to the storage drives location instead of /var but I'm guessing there is a reason why it can not do that? Also I saw some alternatives to create soft links either for files or directories but not sure if that would work in this situation properly. Would anyone else have any suggestions before I start experimenting on my own? Outside the space issue I have had no other issues running it this way so it works fine just a bad location for large db's. 1 other thing its effected is the ability for the system to download its system updates due to not enough space as well, I wasn't as concerned about that but I guess solving this would also help fix that from happening as well.
vferg
 
Posts: 37
Joined: Wed Feb 13, 2013 6:53 pm

Re: Subsonic for Synology

Postby vferg » Sat Jan 07, 2017 9:28 pm

I was able to edit all the files that referenced /var/subsonic and changed them to /volume1/subsonic, I believe it was 2 files. After that I just moved the /var/subsonic directory to /volume1/subsonic using mv and started the service again which worked without any issues. Space issues are solved as well.
vferg
 
Posts: 37
Joined: Wed Feb 13, 2013 6:53 pm

Re: Subsonic for Synology

Postby billraff » Tue Jan 10, 2017 2:46 pm

I posted a topic in the Help section with some questions on my Tomcat/Synology issue. That topic is here -

viewtopic.php?f=2&t=17101

Since others in this thread are running a similar setup I was wondering if anyone else is having an issue shutting down Subsonic and restarting Subsonic under Tomcat? I have to recycle the NAS which I would prefer not to have to do.
Thanks
billraff
 
Posts: 12
Joined: Sun Nov 13, 2016 4:32 pm

PreviousNext

Return to Mods, Apps and Clients

Who is online

Users browsing this forum: No registered users and 3 guests